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Stratagy IVP8 Storage Upgrade Procedure

The Stratagy IVP8 is a two to eight port voice processing system that installs inside the cabinet of the Strata CTX 
or Strata DK telephone system.  The IVP8  uses a solid state CompactFlash® card to provide up to four hours of 
storage. In some applications, your customer may require more hours of storage.

This bulletin announces the availability of pre-formatted 256MB CompactFlash cards directly from Toshiba  (part 
number SG-256MB-UP) and explains the procedure to upgrade the systems using the Toshiba supplied Compact-
Flash card. The CompactFlash card offered by Toshiba comes already formatted. The procedure copies all files, 
including company and user greetings and any messages that existed in the database at the time the files were 
copied.

Required Equipment
In order to perform the upgrade procedure you need the following equipment:

♦ A portable computer running on Microsoft® Windows® 98 or higher with an available PCMCIA 
CompactFlash PC Card Adapter (preferred option) or a CompactFlash card adapter that connects
to the PC using a USB connector.

...or Windows 95 with an available PCMCIA card slot and a PCMCIA CompactFlash PC Card Adapter

♦ A 256MB CompactFlash card supplied by Toshiba (part number SG-256MB-UP).

Note The Stratagy system will be out of service while performing this upgrade. The total time required 
for this upgrade should be less than 30 minutes. A time should be scheduled with the end user to 
perform this upgrade that will have a minimal impact on his customers and business.

Upgrade Procedure
Note If the system has not been installed at a customer site and has no customer information 

programmed, skip Steps 1~6 and start with Step 7.

1. Connect to the Stratagy system with Stratagy Admin.

Note See page 3-2 of the Stratagy Installation and Maintenance Manual for details on accessing the 
system using Stratagy Admin.

2. Back up the customer database using the correct version of Stratagy Admin.
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TTB02-19 Upgrade Procedure
Note See page 11-3 of the Stratagy Installation and Maintenance Manual for details on the Backup 
Utility.

3. From Stratagy Admin, press ALT+S to shut the system down.

4. Enter the system password.

5. Select “Shutdown and STOP for power off” from the Shutdown menu and press Y when prompted. All of the 
Port LED’s light solid when the Stratagy system has completed its shutdown.

6. Remove the IVP8 from the slot in the Strata CTX/Strata DK telephone system.

7. Place the IVP8 on a clean antistatic surface before proceeding.

CAUTION! You will be handling the Stratagy when it is most fragile — unpacked and exposed. 
The Stratagy, if handled properly, will give long, reliable service. To ensure that the 
unit is not damaged during installation or maintenance, follow these precautions. 
Damage may not always be immediately evident (e.g., no physical damage on the 
outside of the unit) and system failure may result weeks or months later.

♦ Handle the Stratagy with care. Mechanical shock from dropping, shaking, excessive force when 
seating the IVP8 into the slot, rocking a connector on or other activities can severely damage the 
assembly.

♦ Wear an anti-static wrist strap when working on any Stratagy system with exposed printed 
circuit boards. An anti-static wrist strap is included with every Stratagy IVP8. It can also be re-
used and left with the Strata CTX or Strata DK cabinet. An electrostatic charge from your body 
can damage the circuitry permanently.

♦ Hold the Stratagy by the edges or the strap and never touch the board’s surface. Pressure on the 
printed circuit board or contaminants from your hands can cause component failure.

8. Remove the original CompactFlash card from the socket by applying pressure with your thumb on the label of 
the Compact Flash card. Slide the card up toward the top and remove it from the socket.

9. Insert the original CompactFlash into the portable PCs’ CompactFlash PC card adapter. From the portable PC, 
double-click on the “My Computer” icon to confirm the PC recognizes the adapter and CompactFlash card as a 
local disk. Windows assigns a drive letter to the adapter and CompactFlash card if it is recognized (e.g., I:\).

10. Close the “My Computer” window.

11. Start Windows Explorer.

12. If one doesn’t already exist, create a folder on the portable PC’s primary drive (e.g., c:\) to which to copy the 
files from the original CompactFlash card (e.g., c:\upgrade\AbcCmpny).

13. Using Windows Explorer, highlight all files on the original CompactFlash card drive by clicking on the drive, 
then click EDIT >SELECT ALL or press CTRL+A.

14. Using the Windows Explorer “Copy & Paste” procedure, transfer a copy of all the files from the Compact
Flash drive (e.g., I:\), to the folder created earlier for that company (e.g., c:\upgrade\AbcCmpny).
See the addendum page (last page) for a pictorial description of the "Copy & Paste" procedure.
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.

CAUTION! When the adapter is active (has a CompactFlash card installed in it), there will 
be a utility on the PC toolbar to deactivate or eject the drive. Use this utility any
time a CompactFlash card is removed from the adapter and the computer is on. 
Not doing this could result in permanent damage to the CompactFlash card.

select Stop or Eject, which ever is available, wait till the PC has stopped accessing the card & then remove the card.

16. Insert the 256MB CompactFlash card into the adapter. From the portable PC, double-click on the “My Com-
puter” icon to confirm the PC recognizes the adapter and CompactFlash card as a local disk. Windows assigns a 
drive letter to the adapter and CompactFlash card (e.g., I:\).

17. Start Windows Explorer (or press F5 to refresh if it is still running) and navigate to the folder that contains the 
files of the company being upgraded. In this example it is c:\upgrade\AbcCmpny.

18. Highlight all files and folders within the folder. Copy & Paste the files to the 256MB CompactFlash card. 
During the file copy, several errors will be displayed stating folders already exist with that name in this 
destination folder. Choose Yes to all to overwrite those files.

19. Select Stop or Eject, wait till the PC stops accessing the CompactFlash & then remove the card from the adapter

20. Insert the new CompactFlash card into the Stratagy systems CompactFlash socket. Make sure the orientation of 
the card is correct in the socket.  The Compact Flash card will click into place when it is completely seated.

21. Install the IVP8 back into the slot of the Strata CTX/Strata DK telephone system. The Status LED blinks amber 
and green while the system is booting up. When the boot process is complete the Status LED is solid green. The 
IVP8 can be inserted into a “live” slot of the Strata CTX/Strata DK telephone system.

22. Connect the Stratagy system to the Stratagy Admin PC using Stratagy Admin. When the Main Menu displays, 
the system’s storage hours are shown on the screen in the Space field. Confirm the updated storage hours.

23. Place test calls into the system to confirm the system answers, transfers, records and makes message waiting 
calls.

15. Select Stop and/or Eject & then remove the Compact Flash card from the adapter. If using an USB adapter,
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TTB02-19 Warranty
Warranty
The 256MB Toshiba CompactFlash comes with a 1 year warranty and can be sent in without the Stratagy IVP8 if it 
is defective. To determine if the 256MB CompactFlash is defective retain the original 64MB CompactFlash and 
plug it into the Stratagy IVP8. If it boots up then the problem is with the new CompactFlash and not the Stratagy 
IVP8.

Your dealership must keep the original Stratagy IVP8 64MB CompactFlash card for warranty and repair purposes. 
If the Stratagy IVP8 system is sent in for repair or warranty replacement, it will only be accepted with the original 
64MB CompactFlash card installed. Receipt of a Stratagy IVP8 sent in for repair or warranty replacement with 
anything other than the original 64MB CompactFlash card installed will be returned without repairs being per-
formed. 

Important! The CompactFlash cards are not interchangeable from one IVP8 to another.

In the event of a system failure, Stratagy systems that are sent out as Advanced Board Exchange will only ship with 
the standard CompactFlash card installed, 64MB in the Stratagy IVP8. It will be necessary for you to reinstall the 
larger CompactFlash card in the replacement system.

Troubleshooting
If a system fails that has been upgraded, it is recommended you re-install the original CompactFlash card into the 
system and attempt to restart it. If the system boots to an operational state with the original CompactFlash card 
installed, it is probable the software on the upgraded CompactFlash card has been corrupted.

Note The system is considered operational if, when connected to the Stratagy Admin PC, the Main 
Screen displays and the system answers and transfers calls and performs message waiting 
notifications. If the software on the upgraded CompactFlash card gets corrupted, this procedure 
can be performed again to validate the integrity of the new card. If the system works with the new 
card installed after the software has been reloaded on it, the card might still be good and can 
continue to be used in the Stratagy system. If the upgraded CompactFlash card does not work after 
the software is reloaded on it, or if the same card fails multiple times, the upgraded CompactFlash 
card should be sent in for repair. If the software is reloaded on the upgraded card using old files 
that were copied from the original CompactFlash card in the early life of the system, the database, 
greetings and messages will be old. The current database and greetings can be restored to the 
system from a current backup.
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Addendum to TTB02-19R – Description of the “Copy & Paste” Procedure using Windows Explorer 
A1. On the “Folders” panel on the left, click on the drive letter assigned to the 64M Compact Flash card 

by the operating system – in this example the Compact Flash card is drive I: – verify it is highlighted. 
A2. Also verify that the right panel of the explorer window (displaying the files & sub-folders) shows the 

files “Autoexec.bat” and “Config.sys”. Otherwise, click on Tools > Folder Options (on the menu bar), 
open the “View” tab, select “Show hidden files and folders”, uncheck “Hide protected operating 
system files” and click on the “OK” button. “Autoexec.bat” and “Config.sys” should now be visible.   

A3. Press Ctrl-A to select all the contents of the source drive (64M Compact Flash). Verify that all items 
in the right panel are highlighted, as in figure below. Press Ctrl-C to copy all the items to clipboard. 

 
A4. In the “Folders” panel, click on the destination folder that was created before. If the destination folder 

has not yet been created, create the folder now. Verify that this destination folder is highlighted – see 
the figures below. In this example the folder is c:\upgrade\AbcCmpny. 

A5. Press Ctrl-V to paste the items from the clipboard (to which they were previously copied with Ctrl-C) 
to the highlighted destination folder. Wait till the “Copying…” process finishes and the window closes. 

 
 

 
A6. Select Stop and/or Eject and then remove the 64M Compact Flash card. Insert the 256M Compact 

Flash card in the adapter. Using the folder c:\upgrade\AbcCmpny as the source, all its contents will 
be copied to the 256M Compact Flash card drive (I:), the destination, by a “Copy & Paste”. 

A7. Click on the folder c:\upgrade\AbcCmpny. Press Ctrl-A to select & highlight all items in this folder. 
Then press Ctrl-C to copy all the highlighted items to clipboard. Next, click on the Compact Flash 
drive I: and highlight its icon. Then press Ctrl-V to paste all the copied items to the Compact Flash 
card – wait till the copying finishes. Finally, Select Stop and/or Eject, then remove the 256M Compact 
Flash card. Install it on the same IVP8 that had the 64M Compact Flash and verify proper operation. 

Ninja Joe
“Autoexec.bat” and “Config.sys”. Otherwise, click on Tools > Folder Options (on the menu bar),
open the “View” tab, select “Show hidden files and folders”, uncheck “Hide protected operating
system files” and click on the “OK” button. “Autoexec.bat” and “Config.sys” should now be visible.


	Stratagy IVP8 Storage Upgrade Procedure
	Required Equipment
	Upgrade Procedure
	Warranty
	Troubleshooting

