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COPY RIGHT NO TICE

This manual is a publication of Maple Systems, Inc., and is provided for use by its customers only.  The contents of the
manual are copyrighted by Maple Systems, Inc.; reproduction in whole or in part, for use other than in support of Maple
Systems equipment, is prohibited without the specific written permission of Maple Systems.

WAR RANTY

Maple Systems warrants each product to be free from electrical and mechanical defects in materials and workmanship for a
period of two years from the date of shipment.  This warranty does not apply to defects in the Products caused by abuse,
misuse, accident, casualty, alteration, negligence, repair not authorized by Maple Systems, use on current or voltages other
than specified by Maple Systems, or application or installation not in accordance with published instruction manuals.  This
warranty is in lieu of any other warranty either expressed or implied.

Maple Systems’ liability is limited to the repair or replacement of the Product only, and not costs of installation, removal, or
damage to user’s property or other liabilities.  If Maple Systems is unable to repair or replace a nonconforming Product, it
may offer a refund of the amount paid to Maple Systems for such Product in full satisfaction of its warranty obligation.
Maximum liability of Maple Systems is the cost of the Product.

Information furnished by Maple Systems, Inc., is believed to be accurate and reliable.  However, no responsibility is assumed
by Maple Systems for the use of this information nor for any infringements of patents or other rights of third parties which
may result from its use.  No license is granted by implication, or otherwise, under any patent or patent rights of Maple
Systems, Inc.  Maple Systems retains the right to revise or change its products and documentation at any time without notice.

IF SER VICE IS RE QUIRED

Package the unit in its original packaging container or, if unavailable, any suitable rigid container.  If a substitute container is
used, surround the unit with shock absorbing material; damage in shipment is not covered by the warranty.  Include a letter
with the unit describing the difficulty and designating a contact person.  Send to the following address:  Maple Systems, Inc.,
808 134th  Street SW, Suite 120, Everett, WA  98204-7333.

Only Products that have been issued a Return Material Authorization (RMA) number from Maple Systems may be returned.
All RMAs must be accompanied with a written purchase order for tracking purposes or, in the case of out-of-warranty
repairs, for repair charges on a time and material basis.

All returns will be tested to verify customer claims of noncompliance with the product warranty.  Improper return packaging,
which makes verification impossible, will void the warranty.  Products passing the tests will be returned “AS IS” to the
customer.

If noncompliance is verified and is not due to customer abuse or the other exceptions described with product warranty, Maple
Systems will, at its option, repair or replace the Product returned to it, freight prepaid, which fail to comply with the
foregoing warranty, provided Maple Systems is notified of such noncompliance within the two-year warranty period.

AP PLI CA TIONS AS SIS TANCE

This man ual is de signed to pro vide the nec es sary in for ma tion for trou ble-free in stal la tion and op er a tion of your new Op er a tor
Inter face Ter minal (OIT).  How ever, if you need assis tance, please call Ma ple Systems at 425-745-3229 or visit our web site
at www.maple-systems.com.
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Introduction - Welcome

Welcome to the Maple Systems’ Silver Series of Operator Interface Terminals (HMIs). Using graphic HMIs has never been
easier.  This powerful family of graphics operator interface terminals connects to programmable logic controllers (PLCs) to
provide the human-machine interface in industrial applications.  The Silver Series has several features not found in other
graphic HMIs.  This manual explains the operation of the Silver Series HMIs and how to implement the many available
features using the EZware-500 Configuration Software.

EZware Sup port

HMI Models Sup ported

For the latest list of Silver Series Models supported by EZware, please visit our website at http://www.maple-systems.com.

PLCs Supported

For the latest list of PLCs and controllers supported by the Silver Series HMIs, please visit our website at
www.maple-systems.com/cntrllrs_ezw.htm.

About Your Doc u men ta tion

Maple Systems provides many resources to allow you to get the most out of your Silver Series HMI.

� Silver Series Operation Manual (shipped with EZware-500 as a PDF file) - describes installation, general operation
and features of the Silver Series using EZware-500 configuration software.

� Controller Information Sheets - important information specific to each supported protocol.

� EZware-500 On-line Help - covers the operation of EZware. Always available by clicking Help Topics from the
Help menu in EasyBuilder.

For more information about these and other training sources, visit the Maple Systems web site at:
http://www.maple-systems.com

Con ven tions

When using EZware-500, there are usually several ways to perform a task. For example, if you want to copy a graphics
object, you can:

� Click the Copy command on the Edit menu.

� Click the Copy button on the Standard toolbar.

� Press the CTRL + C keys on your com puter.
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In most cases, we will describe each method when the task is first discussed.  The menu method is then used whenever the
task is used in later procedures.  Other conventions used in this book are listed in the following table.

Convention Meaning

Bold
Characters that you must type exactly as they appear.  For example, if you are directed to type
a:\setup, you should type all the bold characters exactly as they are printed.

Italic

Placeholders for information you must provide.  For example, if you are directed to type filename, you
should type the actual name for a file instead of the word shown in italic type.  Italics are also used to
indicate a glossary term.

ALL CAPITALS Directory names, file names, key names, and acronyms

KEY1+KEY2
A plus sign (+) between key names means to press and hold down the first key while you press the
second key.

click Refers to clicking the primary mouse button (usually the left mouse button) once.

Double-click Refers to quickly clicking the primary mouse button (usually the left mouse button) twice. 

Right-click
Refers to clicking the secondary mouse button (usually the right mouse button) once.  Right-clicking
usually opens shortcut menus.

The following table identifies symbols and margin icons.

Icon Meaning

� Identifies a procedure.

� Indicates a reference to additional information.

� Indicates an important note.

What You Need

The following items are needed to configure and operate your HMI.

Configuration Software EZware-500

Configuration Cable 
(HMI to PC) Y-adapter cable1 7431-0098

Personal Computer2 User Provided

Power Cable 6030-0009

24VDC Power Supply User Provided (for details refer to Appendix A: Specifications)

PLC User Provided

Controller Information Sheet
Maple Systems provides Controller Information Sheets which contain important information specific
to each PLC. Please locate the sheet that corresponds to your PLC on our website.

Communication Cable
(HMI to PLC)

Refer to Maple Systems’ Tech Note 1061 for a list of available cables or build your own using the
cable diagrams available on our web site (www. maple-systems.com).

1Allows you to con nect HMI to PC us ing RS232 and a PLC that uses RS485 at the same time

2Computer requirements include at least a Pentium 90Mhz PC, 16MB RAM, 10MB available hard disk space, VGA video
controller, Microsoft Windows 95, 98, 2000, or NT, and one available RS-232 serial port.

HMI Ba sics

Operator Interface Terminals (HMIs) provide much more versatility than traditional mechanical control panels.  An HMI
allows a plant floor operator to monitor current conditions of a control system and, if necessary, to initiate a change in the
operation of the system.  HMIs connect to programmable logic controllers (PLCs) typically through the PLC’s serial
communications port.  The HMI can be programmed to monitor and/or change current values stored in the data memory of
the PLC.

HMIs can have either text-based or graphics-based displays.  A text-based HMI can display printable text characters but no
graphics.  Some text-based HMIs can display text characters in various sizes.  A graphics-based HMI can display printable
text characters of varying fonts and sizes and graphics shapes such as icons, bitmaps, or pictures.  Using pictures instead of
words or characters often greatly simplifies the operation of the HMI, making the HMI much more intuitive to use.
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Some HMIs use touch screen displays while others use a membrane-style keypad.  Membrane-style keyboards are best used
in applications in which the keypad is likely to become dirty.  Touch screen displays are placed over the HMI screen thus
providing much more flexibility than typical membrane-style keypads.  Because of this, switches can be created on a touch
screen that appear only when needed.

The Maple Systems Silver Series HMIs are graphics-based touch screen HMIs.  Before we get any further into the operation
of these HMIs, it is necessary to define some terms that will be used throughout this manual.

Projects

The HMI has two basic segments of internal memory.  The code memory contains the information required by the HMI that
controls how it operates such as the features supported and how it communicates to a PLC.  The HMI programmer does not
have the ability to change code memory.  The project memory pertains to all of the window screens created and any other
features that the HMI programmer can create using the EZware-500 configuration software.  Therefore, the term project is
used to designate the file that is sent to the HMI from the EZware-500 software.

Objects

An object is any action that the HMI performs while it is communicating to the PLC. In order to get the operator interface
terminal to ‘do anything’, you must program the HMI with objects. Objects perform actions such as display text or graphics,
write a value to a PLC register, or display an alarm.  Objects most often are graphics shapes that are to be displayed on the
HMI screen.  For example, a Text Object is used to display text on the HMI.  But objects are also used to configure the HMI
to perform some action.  For example, a PLC Control Object tells the HMI to continuously monitor a PLC register that is
used by the PLC to request a new window.  Some objects can display a graphics shape on the HMI screen and perform some
action.  For example, a Toggle Switch Object creates a graphic object on the HMI that when pressed, activates a bit in the
PLC.

Graphics Object

A graphics object is any text, icon, or picture that can be displayed on the HMI.  Graphics objects are further defined by how
they are composed or created.  A Text Object is a graphics object that  displays text on the HMI screen.  A Bitmap Object is a 
graphics object that displays a bitmap on the HMI screen.  Bitmaps are files stored in the HMI to display pictures.  A Shape
Object is a graphics object that displays a shape on the HMI screen.  Shapes are also files stored in the HMI to display
pictures.  Shapes differ from bitmaps in that shapes are stored using a vector-based file format whereas bitmaps use a
pixel-based file format.  Each format has its advantages and disadvantages.  We will not go into any more detail about bitmap
objects and shape objects until later in this manual.  For now, think of them as  objects used to display pictures on the HMI
screen.  Finally, a Group Object is the most complex type of graphics object.  It is a combination of other objects.  Briefly, a
group object consists of one or more objects that are ‘grouped’ together and stored as one object.  A good example is a
keypad, which is really a combination of several keys each designed to perform a specific task.  When grouped together, a
keypad can be stored as a group object for use in other projects or windows.

Windows

A window is a screen that can be displayed on the HMI.  Windows can be full-sized to completely cover the HMI display or
partially sized.  Any partially sized window is usually referred to as a popup window.  Windows can appear on the HMI
display by a request from the PLC or by a press from the touch screen.  Windows can be configured to any size.  Once a
window is displayed, it can be moved around the HMI display, removed from the display, or minimized to an icon.
Windows can even overlap each other. Each window can display graphics objects and there is no limit to the number of
graphics objects that can be placed on each window.  The Silver Series is capable of storing up to 1999 windows , but the
actual limit is determined by the total amount of memory used for the application.  A more in-depth discussion of windows is 
covered in later chapters.  For now, think of windows as screens that can be displayed on the HMI.
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What is a Silver Se ries HMI?

The Silver Series of HMIs by Maple Systems are graphics operator interfaces designed to connect to PLCs in an industrial
environment. The displays are covered with a 4-wire analog resistive touch screen designed for harsh industrial
environments.  The touch screen uses the latest in touch screen technology enabling the HMI programmer to create switches
that are very fine in resolution.  Unlike many other touch screen HMIs on the market, the Silver Series is not limited to a
fixed number of cells in which switches can be created.  The HMI programmer can create as many switches of varying sizes
and shapes as he wishes, limited only by the total amount of memory available for the project.
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Three LED indicators are provided on the face of the Silver Series HMI to provide instant feedback to the HMI operator of
the current operating condition of the HMI. 

LED Indicator Purpose

PWR LED (yellow) indicates if power is applied to the HMI

CPU LED (green) indicates if the HMI is operating correctly

COM LED (red) indicates communications activity on PLC port

The Silver Series HMI has two serial ports, which provide a connection to a PLC using RS-232 or 
RS-485 communications and an RS-232 connection to a computer for programming.  The serial ports also provide the ability
to connect multiple HMIs in series to a single PLC port!  The two serial ports also provide the ability to use the EZware-500
configuration software in Simulation Mode enabling the HMI programmer to test his project on the PC instead of
downloading the project to the HMI.

The Silver Series is powered using +24VDC.  The viewing level of the HMI display can be adjusted using a contrast switch
located on the back of the unit, or using Local Bits LB9091 and LB9092 for Contrast Up/Down.  Finally, a reset switch is
provided on the back of the HMI to reinitialize the HMI if an operational failure occurs.  The Silver Series is designed for
industrial environments and carries a NEMA 4 rating as well as CE compliance for noise immunity and emissions.

There are currently SEVEN models in the Silver Series.

Model Display size
Resolution

(pixels)
LCD Type Brightness

(cdm2)
Contrast

Recipe/RTC
Module

Ethernet &
Compact

Flash

HMI520M 5.7” 320 x 240
4-shade blue
mode STN

60 15:1 Standard No

HMI520T 5.6" 320 x 234
256-color

TFT
500 150:1 Standard No

HMI520T E
(Enhanced)

5.6" 320 x 234
256-color

TFT
500 150:1 Standard Yes

HMI530T 7.7" 640 x 480
256-color

TFT
400 250:1 Standard No

HMI530TE
(Enhanced)

7.7" 640 x 480
256-color

TFT
400 250:1 Standard Yes

HMI550H 10.4” 640 x 480
256-color

TFT
250 100:1 Standard No

HMI550HE
(Enhanced)

10.4” 640 x 480
256-color

TFT
250 100:1 Standard Yes

Finally, the Silver Series are powered by a 200 MHz Intel XScale processor, making it one of the fastest HMIs available on
the market.  Even the most complicated graphics can be displayed quickly on the HMI screen.  In addition, the HMI uses a
proprietary algorithm to find the most efficient means of extracting data from the PLC.  This lowers the amount of
‘bottleneck’ time due to the relatively slow communications baud rate of most PLCs.  Therefore, the update rate to gather
information from the PLC is very fast.
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List of Fea tures

The next chapter will guide you through the creation of your first project.  Before you proceed, you may wish to read this
brief list of some of the features offered in the Silver Series HMI.

Icon Name Description

Bit Lamp Creates a graphics object to reflect the current status of a PLC bit.

Word Lamp Creates a graphics object to reflect the current state of a multi-state PLC data register.

Set Bit
Creates a touch screen graphics object that represents a two-state switch.  When pressed it
sets/resets a PLC bit.

Set Word
Creates a touch screen graphics object that represents a multi-state switch.  When pressed it
can place a constant value in a PLC register or jog the value.

Toggle Switch
Creates a touch screen graphics object that represents a two-state switch changing state
(picture) based upon a PLC bit.  When pressed, it can control another PLC bit.

Multi-State
Switch

Creates a multi-state touch screen graphics object that changes state (picture) according to the 
value in a PLC data register.  When pressed, it sends a value(s) to another PLC register.

Function Key Creates a touch screen graphics object, which displays a window or edits a PLC register.

Numeric Input
Displays a number stored in a PLC register. The number can be changed using a numeric
keypad.

Numeric Data Displays a number stored in a PLC register

ASCII Input
Displays ASCII characters stored in a PLC register. Characters can be changed using an
alphanumeric keypad.

ASCII Data Displays ASCII characters stored in a PLC register

Moving Shapes
Creates a multi-state graphics object, which changes state (picture) and position on the screen
according to a value in a PLC register.

Animation
Creates a multi-state graphics object, which changes state (picture) on the screen according to
a value in a PLC register. The positions on the screen are predefined.

Indirect Window
Configures the HMI to monitor PLC data registers or coils to display  for a specific window
popup by a PLC word address

Direct Window Displays a Window based on a bit in a PLC Register

Alarm Displays Creates alarms to display alarms sent from the Alarm Scan Object

Trend Displays
Creates a trend graph. Samples data in a single or multiple 16-bit PLC register and plots the
data on a time graph

Bar Graph
Displays

Creates a bar graph with alarm monitoring 
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Meter Displays Creates a scale meter

Alarm Bar Displays alarms detected by the Alarm Scan Object on a single horizontal scrolling line.

Recipe Transfer Transfers data to the specified PLC registers

Event Displays Displays messages according to ‘events’ that occur in the PLC

Alarm Scan Contains the data for detecting alarm conditions.

System
Message

Customizes the content of system-generated messages.

PLC Control Configures the HMI to monitor PLC data registers to display full window screens.

Event Log Monitors and records assigned events

Data Transfer
Configures the HMI to periodically transfer data stored in one set of registers to another set of
registers in the HMI or PLC.
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Chapter 1 - Installation of HMIs

Before You Be gin

Please read the following for proper handling of your new HMI.

Unpacking the Unit

Carefully unpack the HMI.  Please read any instructions or cautions that appear on the shipping container.  Check
all material in the container against the enclosed packing list.  Maple Systems, Inc. will not accept responsibility for
shortages against the packing list unless notified within 30 days.  The equipment and its accessories were inspected
and tested by Maple Systems before shipment; all of the equipment should be in good working order.  Examine the
equipment carefully; if any shipping damage is evident, notify the carrier immediately.  You are responsible for
claim negotiations with the carrier.  Save the shipping container and packing material in case the equipment needs to
be stored, returned to Maple Systems, or transported for any reason.

Man aging Elec tro static Dis charge

It is best NOT to remove the rear enclosure of the HMI.  When the rear part of the enclosure is removed, the
circuitry inside is exposed to possible damage by electrostatic discharge during handling.  Minimize the possibility
of electrostatic discharge by:

• Discharging personal static by grounding yourself prior to handling the HMI

• Handling the HMI at a static-free grounded workstation

• Connecting the frame ground (   ) connector of the HMI to a clean earth ground

• Placing the HMI in an anti-static bag during transport

CE Com pli ance

The Silver Series HMIs have been tested to conform to European CE requirements per Council Directive
89/336/EEC.  The European Union created these requirements to ensure conformity among products traded in those
countries.  Specifically, the Silver Series HMIs meet or exceed the noise emissions and immunity requirements as
set forth in the EN50081 (Emissions) and EN50082 (Immunity) standards.  These products are designed to
withstand electrical noise in harsh industrial environments.  They also conform to requirements that limit electrical
emissions.  However, this does not guarantee that the products will be totally immune from possible malfunction in
cases where severe electrical noise occurs.  Therefore, we strongly recommend that you follow the guidelines
outlined in this chapter for proper wire routing and grounding to insure the proper operation of the Silver Series
HMI.

NEMA Rat ing

The Silver Series HMIs are rated for NEMA 4/12 (indoor) or IP65 installations.  This means that when the HMI is
properly mounted to a panel or other enclosure, the front enclosure of the HMI will provide protection to the inside
of the panel from splashing water, wind blown dust, rain, or hose-directed water.  The HMI must be installed
according to the instructions in this chapter to be properly sealed.

En vi ron men tal Con sid er ations

The Silver Series is designed to operate in temperatures from 0-45° C.  It is intended for indoor installations and not
designed for outdoor applications.  Avoid installing the Silver Series in environments with severe mechanical
vibration or shocks.  Do not install the HMI in enclosures with rapid temperature variations or high humidity.
Either will cause condensation of water inside the device and eventual damage to the HMI.

1010-1001a, Rev 01

In stal la tion of HMIs 9



Safety Pre cau tions

Please observe the following precautions when installing the Silver Series HMI.  Failure to comply with these
restrictions could result in loss of life, serious personal injury, or equipment damage.

Warning:  Do not operate the HMI in areas subject to explosion due to flammable gases,
vapors, or dusts.

Warning:  Do not connect the HMI to an AC power source.  You will cause permanent damage 
to the HMI.

Warning:  Do not attempt to use a DC power supply that does not meet HMI power
requirements.  You may cause malfunction or permanent damage to the HMI.

Warning:  Do not power the HMI with a DC power supply used for inductive loads or for input
circuitry to the programmable logic controller.  Severe voltage spikes caused by these devices may
damage the HMI.

Con trol Panel De sign Guide lines

Pay careful attention to the placement of system components and associated cable routing. These items can
significantly enhance the performance and integrity of your control application.
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Control Panel Grounding

The control panel should be connected to a good, high-integrity earth ground both for safety considerations and
shielding purposes.  Maple Systems cannot overemphasize the importance of good grounding.  If you fail to use
good grounding procedures during installation, sporadic malfunction of the HMI may occur:

� Connect the HMI’s chassis ground terminal to a reliable earth ground with a low-resistance path.

� Route all earth ground wires that lead from the HMI, the PLC, the power supply, and the line filter to a
central earth ground point such as a barrier strip.  This will ensure that no ground current from one device
influences the operation of the other devices.

� Connect the HMI chassis ground terminal to the control panel door using a heavy-gauge short braided cable
or ground wire to minimize resistance.

� Connect the power cable’s shield wire to the HMI’s chassis ground terminal.

� Connect the control panel to earth ground using a copper grounding rod close to the HMI and control panel.

Hinged doors on control panels do not provide a long-term electrical connection to the rest of the enclosure.
Corrosion develops over time and prevents good electrical contract. For this reason, a separate wire braid should be
installed from the hinged control panel to the rest of the enclosure.

For a more in-depth overview of ground wiring techniques, refer to technical note #1027, “HMI Ground Wiring and 
Electrical Noise Reduction,” which you can find at http://www.maple-systems.com/0907/09071027.pdf .

Connect HMI Chas sis Ground to Con trol Panel

To reduce the possibility of electrical interference, connect the chassis ground terminal of the HMI to a clean earth
ground.  If the control panel is metal, make sure it is properly grounded.  Then connect a short heavy-gauge wire
(#18 AWG) from the chassis ground terminal of the HMI to a mounting bolt on the control panel door.  The
mounting bolt must have good electrical contact to the control panel; scrape away any paint that may be covering
the panel to provide a good connection.

If the control panel is made of a non-conductive material, it is essential that you connect the chassis ground terminal
of the HMI to a clean earth ground point located close to the panel.
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Power Sup ply Se lec tion

The power supply used to power the HMI should provide an output of +24 VDC  5% measured at the HMI power
terminal block.  A 24VDC regulated power supply dedicated to the HMI is required (refer to Appendix A:
Specifications for the input current requirements).  Use a power supply with a 1.1 Amp output rating for the
HMI520 models and a 2.5 Amp output rating for the HMI530 and HMI550 models.

The power cable for the HMI should be 18AWG, 2-conductor wire with a shield drain wire and protective shield
(foil or braid). The shield drain wire must be connected to earth ground at both ends of the cable. Please refer to the
“Connect the HMI to Power” section for more information.

A power line filter installed at the AC input to the HMI power supply is highly recommended as a safeguard against
conducted RF noise, which is often present on factory power lines. The wires connecting the output of the power
line filter to the power supply should be kept as short as possible to minimize any additional noise pickup. The case
of the power line filter should be connected to a quiet earth ground. The power line filter should have a current
rating of at least 3 Amps with common mode and differential mode attenuation.

Do not use the power supply used to provide power to the HMI to power switching relays, solenoids, or other active
devices.

Cable Routing and Noise Im munity

Follow these guidelines when routing cable to the HMI:

� Always route the HMI communication cable and the power cable away from any AC voltage or rapidly
switching DC control lines.

� Never bundle the HMI cables together with 120VAC power wires or with relay wiring.

� Try to keep at least 8 inches (20 cm) of separation between the HMI cables and other power wiring. If
voltages greater than 120VAC are used in the system, greater separation is required.

� If the HMI cables must come near AC wiring, make sure they cross at 90 degrees.

� Run AC power wires in a separate grounded conduit to reduce electrical noise interference.

� Keep the cable lengths for the HMI as short as possible. Do not coil excess cable and place it next to AC
powered equipment.

� Cover any equipment used in the enclosure that operates at high frequency or high current levels with a
grounded metal shield.
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In stal la tion

It is necessary to follow all installation procedures described in this chapter for electrical noise immunity and CE
compliance.

Your Maple Systems HMI is designed to connect easily to your PLC. External rear connectors provide quick
connections for power, communications and programming wiring.

There are two serial ports on the rear of the HMI. Both of these are D-subminiature 9-pin connectors.  Use the
female connector for RS-232 communications to a PLC.  Use the male connector for RS-485 communication to a
PLC and RS-232 communications to a PC.

Use the supplied separate 3-position terminal block to provide power to the HMI.

Connect the HMI to Power

The power cable for the HMI should be 18AWG, 2-conductor wire with a shield drain wire and protective shield
foil. You may buy cable P/N 6030-0009 by the foot from Maple Systems to make these.

Always run the DC ground wire directly back to the signal return of the power supply.  Do not use the chassis
ground wire as your signal return!  Maple Systems recommends using an axial ferrite coil with each HMI550H
HMI to further reduce the electrical interference that may be conducted on the power lines.  Thread the positive and
negative wires of the power cable through the ferrite coil so that the coil is no more than two inches from the HMI’s
power input.

�To connect the HMI to power:

1.   Connect the power cable to the HMI

a.  Strip the power cable shield to expose 2” of the black and red wires.

b.  Strip about ¼” of insulation from the black and red wires.

c.  Thread the black and red wires through the ferrite core. The shield wire must be outside.

d.  Connect the red wire to the DC positive (+) input of the HMI power terminal.

e.  Connect the black wire to the DC negative (-) input of the HMI power terminal.

f.  Connect the power cable shield wire to the HMI power terminal’s chassis ground input.

2.    Route the power cable to the HMI power supply.  The power cable should not be any longer
than necessary.
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3.   Install the power supply wires as follows (with colors shown for Maple Systems cable P/N
6030-0009):

Color Power Supply HMI520 HMI530 HMI550

Red +Output/+24 Vdc +dc 24V 24V +dc 24V

Black -Output/+24 Vdc return -dc 24V GND -dc 24V

Shield Case ground FG

� The power connector on the Silver Series is a terminal block with wire clamps.   Lugs
are not required.
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Connect the HMI to the PLC

Each PLC supported by Maple Systems has its own wiring requirements. Maple Systems offers HMI-to-PLC
communication cables for most PLCs that are built to any length and tested for high reliability.  Most cables are
available for next-day shipment from Maple Systems.  Components and instructions necessary to construct your
own HMI-to-PLC communications cables are also available. Refer to Maple Systems’ Technical Note 1061 or visit
our Web site, www.maple-systems.com/cables.htm.

Port 1
PLC (RS-232)

Port 2PLC (RS-485),
PC (RS-232)

Pin # Function Pin # Function

1 (no connection) 1 RXD-

2 TXD 2 RXD+

3 RXD 3 TXD-

4 (no connection) 4 TXD+

5 GND 5 GND

6 (no connection) 6 (no connection)

7 (no connection) 7 TXD

8 (no connection) 8 RXD

9 (no connection) 9 (no connection)
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STEPS:

1.   Connect the “HMI” end of the communication cable into either the RS-232 port or the RS-485 port as
required for your application (HMI housing is marked).

2.   Tighten the two cable screws at each end to ensure shield ground path.

3. Route the communication cable to the PLC. Refer to the “HMI Cable Routing” section for more
information.

4. Connect the “PLC” end of the cable to the PLC and tighten the cable screws.

5.    Connect the green shield wire from the cable to earth ground (          ) on the PLC. If this wire is not
present, make the ground connection  inside the PLC connector.

6. The HMI530/550 has a printer port and can be connected to an Epson compatible printer.

Panel Prep a ra tion

A metal panel or mounting surface with a minimum thickness of 15 gauge (0.059 inch/3.3mm) if cold-rolled steel or 
hardened steel, or 10 gauge (0.101 inch/2.6mm) if aluminum alloy (6061-T6 preferred) is required.  Thinner panels
or surfaces may bow between the mounting clamps and not form a seal with the gasket.

The area of the panel or mounting surface where the gasket comes into contact must be flat and free of scratches,
pits, and other features that prevent the gasket from sealing properly. If the panel or mounting surface is not
uniform, thick, flat, stiff, or smooth enough, then a sealant such as silicone may be required.

WARNING: The HMI requires a stiff, flat, smooth mounting surface free of blemishes
to  seal properly to NEMA 4.

The diagrams in Appendix C show the dimensions of the panel cutout required for proper installation of the
HMI520, HMI530, and HMI550 models.

� Clean and deburr the panel cutout before the HMI is installed.

Mount the HMI to the Panel
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STEPS:

1.   Prepare the four screw clamps for the HMI520/530 or the six screw clamps for the HMI550 by positioning
the metal brackets at the midpoints of the screws.  Position the screws so that the ends don’t protrude from
the plastic portions.

2.   Set the HMI in the panel cutout and hold it in place until all clamps are in position.

3.   Tighten the screw clamps until all are uniformly snug.

CAUTION:  Do not over-tighten the screws beyond snugness, or you may damage the housing.

REINSTALLATION:  Because the gasket will take a “set” to the panel, be sure to reinstall the HMI to the same
panel cutout when a NEMA 4 seal is required.  For best results, also replace the gasket itself.
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Con fig u ra tion Wir ing

The HMI must be configured for a particular protocol before use. The EZware-500 software (used on a PC with
Windows 95 or higher) is used for configuring the HMI. For detailed instructions on installing and using the
software, please refer to the software documentation section of this manual.

Connect the HMI to the PC for Con figuration

To configure the HMI using Maple System’s configuration software, you will need the HMI Configuration
Y-adapter Cable, Maple P/N 7431-0098. Connect the end marked “HMI” into Port 2 on the HMI, marked
“PLC[RS-485]/ PC[RS-232], and connect the end marked PC into the proper COM port on your PC. The end
marked “PLC” is not used here. See the figure below for serial port pin assignments and the next two figures for
connecting the Silver series to a PC.
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Fac tory Con fig u ra tion

Each HMI arrives from the factory with a demo project file that illustrates some of the most popular features of the
HMI.  Please follow the directions enclosed in Chapter 2, Creating Your First Project, to configure your HMI for
the PLC that you are using.

Each HMI has a potentiometer located on the back for adjusting the level of contrast on the display.  It is set for
optimum clarity at the factory but you can change the setting if necessary.

The HMI also has a black reset pushbutton and a four position DIP switch located through an access hole on the
back of the enclosure.  The reset switch can be used to reinitialize the HMI if the HMI malfunctions.  Only Dip
switch 1 and 2 have functionality.  Dip switch 1 puts the HMI into Touch Calibration mode.  Dip switch 2 forces the
HMI into download mode, and needs to be set for downloading from a Compact Flash card.  For normal operation,
all of the DIP switches should be set to the OFF position.

The touch screen of the HMI is fully calibrated before it leaves the factory so you shouldn’t need to adjust it.
However, with time the touch screen may need to be recalibrated.

�To calibrate the touch screen

1.   Connect the HMI to your computer for programming.

2.   From the Start menu, click Programs, then Maple Systems, then EZware-500, then the
EasyManager program.

3.   Click Jump To Touch Adjust.  The HMI screen should change to calibration mode.

4.   After the HMI displays a crosshair cursor, you are prompted to touch the cursor for:

1010-1001a, Rev 01

In stal la tion of HMIs 21

Shielded Power Cable,
Maple P/N 6030-0009

HMI Power Supply Output

FG

DC Output -V (Gnd)
DC Output +V (+24V)

DC
24V

HMI550

PLC [RS-485]PRINTER
PC [RS-232]

PLC [RS-232]

Enhanced
models only

PC

(If mouse is using
Com 1, use Com2)

Maple Systems HMI
programming cable,
P/N 7431-0098

RS-485

Com2 Com1

Printer

PLC/Host

RS-232

HMI-PLC communication cable

Connecting the HMI530/550 to a PC



a.   Top left position

b.   Top right position

c.   Bottom left position

d.   Bottom right position

5.   The HMI screen displays two rectangular objects.  To determine whether the touch screen is
properly calibrated, place and hold your finger somewhere on the touch screen other than on
the rectangular spots.  The crosshair cursor should appear directly under your finger.  If
needed, press the left rectangle to repeat the calibration.  Press the right rectangle to end
calibration.

6.   Once you have completed calibration, press the touch screen again to return to normal
application mode.
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Chapter 2 - Creating Your First Project

Often the best way to learn about new software is to just jump right in.  This chapter will step you through the
process of installing the EZware-500 configuration software and then using the software to create a sample project
that can be downloaded to your HMI.  We won’t go into much detail as to how each feature works.  The purpose of
this chapter is only to provide you with an overview of the process of creating a functional HMI that can
communicate to a PLC.  For our sample project, we will configure the HMI using the MemoryMap_Master protocol
but you may feel free to select whichever protocol driver you intend to use.

By the end of this chapter, you should be able to:

• Install EZware-500 configuration software.

• Create a sample project with two windows and several graphics objects.

• Save a project, compile a project and download the project to the HMI.

• Verify that the HMI is functioning properly.

Before You Be gin

Before you install EZware-500, make sure your computer meets the following minimum system requirements:

• Pentium-based 90MHz or higher processor

• 16 MB of RAM (more memory improves performance)

• 10 MB available hard disk space

• VGA or higher-resolution monitor set for 256 color 800x600 pixel mode

• Microsoft Mouse or compatible pointing device

• One available RS-232 port

• Microsoft Windows 95, 98, NT, XP or higher

Connecting HMI to Com puter

Before you start your first project, the HMI should be connected to the computer so that the project can be
downloaded after creating it.  You should also connect the PLC that you are using to the HMI so that you can test
the operation of the HMI after you have finished creating this sample project.

�To connect your HMI to the computer

1. Connect a +24VDC power supply to the HMI.

2. Connect the Y-adapter programming cable (Maple P/N 7431-0098) to the computer and HMI.

• Connect the end marked HMI to the HMI port la beled PC[RS-232].

• Connect the end marked PC to the COM port of the com puter.

3.    Apply power to the HMI.

�Changing the PC COM Port used by EZware-500

1. EZware-500 is initially configured to use Com Port 2:

2. In Windows, click the Start button.

3. Select Programs.

4. Select EZware500.

5. Select EasyManager.
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6. In the top left drop-down list box, select COM 1.

7. Choose EXIT.

�To connect your PLC to the HMI

1. Maple Systems produces PLC communications cables, which will connect the HMI to most of 
the PLCs available.  The cables can be manufactured to any length you may require.  A listing
of all the PLC cables Maple Systems offers can be found on our website at

2. If you have decided to make your own cable, make sure that it is wired correctly for your
particular PLC.  Maple Systems provides cable wiring diagrams to guide you through the
construction of your cable.  These can also be found on our website at
www.maple-systems.com/cables.htm.

3. Connect the PLC communications cable from the serial port on your PLC to the appropriate
serial port on your HMI.

• If you are us ing RS-232 com munications, then con nect the HMI end of the ca ble to the HMI
port labeled PLC[RS-232].

• If you are using RS-485 communications, then connect the HMI end of the cable to the HMI
port labeled PLC[RS-485].  If you wish to use the Y-adapter programming cable, then
connect to the cable end that is marked PLC.

4. Apply power to the PLC.  The Silver Series HMI is programmed at the factory with a sample
demo that shows some features of the HMI.  The HMI should display a sample startup screen.
The HMI will now accept a new project from EZware-500.

Starting EZware-500

Before you can create a sample project, you must start the configuration software.  The EZware-500 software has
three main applications:

• EasyBuilder – used to create the project downloaded to the HMI.

• EasyManager  - used to place the HMI into different operating modes.

• EasyASCIIFontMaker  - used to edit the text fonts that display characters on the HMI.

�To start the EZware-500 software

1. From the Windows Task Bar, click the Start button, point to Programs, and then click the
EZware-500 folder.

2. Click EasyManager to start the EasyManager application.

3. Select the appropriate COM port on your computer.

4. Select a baud rate of 38400.

� After you have successfully downloaded a project to the HMI using this baud rate, try
using 115200 to decrease the required download time.

5. Click Project Download/Upload.

6. Click Complete Download/Upload.

� After you have downloaded your first project to the HMI, you can switch to Partial
Download/Upload to decrease the required download time.
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7. On the EasyManager dialog box, click EasyBuilder.

8. The Welcome to EasyBuilder dialog box appears.  Select the correct HMI model.

9. Click OK to display the main screen of EasyBuilder.

�� If the main screen of EasyBuilder is displayed after you click EasyBuilder from the
EasyManager dialog box, select the correct model of HMI by clicking New from the
File menu.

The following illustration shows the various sections of EasyBuilder.

Creating a Sam ple Pro ject

This section walks you through the creation of an EasyBuilder project named EBPrj1. Once downloaded to the
HMI, this basic configuration allows the HMI to connect to the PLC, display a startup screen, and display a screen
containing one PLC register monitor when a switch on the startup screen is pressed.

Although we strongly recommend that you perform the following steps to create this sample project, the project is
already included in your EasyBuilder software with the following filenames:

HMI520M.EPJ
-sample project for the HMI520M

HMI520C.EPJ
-sample project for the HMI520C

HMI520T.EPJ
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-sample project for the HMI520T

HMI530C.EPJ
-sample project for the HMI530C

HMI530T.EPJ

-sample project for the HMI530T

HMI550M.EPJ
-sample project for the HMI550M

HMI550H.EPJ
-sample project for the HMI550H

Set ting the Sys tem Pa ram e ters

Whenever you begin a new project, you should always set the system parameters before you create any windows.
System parameters determine the basic operating conditions of the HMI such as what type of PLC it is connecting
to.

�To edit the System Parameters

1. Click the Edit menu on the main screen of EasyBuilder.

2. At the bottom of the menu, click System Parameters.  The Set System Parameters dialog box
appears.

3. The dialog box has six tabs: PLC, General, Indicator, Security, Editor and Hardware.  Select
the PLC tab.

4. Select the PLC that you are using or MemoryMap_Master from the PLC type pull-down
box.

5. Select RS485 from the Serial port I/F box.

6. Select 8 bits from the Data bits box.

7. Select 1 bit from the Stop bits box.

8. Select 19200 from the Baud rate box.

9. Select Odd from the Parity box.

10. Select 0 for the HMI station No. and PLC station No. Boxes.

11. Select Disable from the Multiple HMI box.

12. Select 3.0 from the PLC time out constant box.

13. Select 0 from the PLC block pack box.

14. Now click on the General tab.

15. Select 10 for the Startup window No. Box.

16. Click OK to return to the EasyBuilder main screen.

� The communications parameters selected above were selected at random.  Please enter
the PLC type and communications parameters that match your PLC.  For more
information, consult your PLC operations manual or Maple Systems Controller
Information Sheets available on our website at www.maple-systems.com .

Cre ating a Startup Window

We will configure Window #10 as the startup screen.  The HMI can store up to 1999 predefined windows but
screens 0-9 are reserved.  Therefore, the first window screen that is available for configuration is Window #10.  By
default, this is the startup screen when you begin a new project.  This section will show how to place text in the
window and how to create two function keys that will open and close Window #11.
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�To place text on Window#10

1. From the Draw menu, click Text.  The Create Text Object dialog box appears.

2. Click the pull down box from the Color box.  The Color dialog box appears.

3. Click on the white color box, then click OK.  The color box should reflect the color that you
have chosen.

4. Select 16 in the Font box.

5. Select Left in the Align box.

6. Double-click the word ‘text’ in the Content box and type “This is the Startup Screen!.”

7. Click OK.

8. On the main screen of EasyBuilder, you will see a white rectangle outline that is attached to
your cursor in the work area.  This represents the text box just created.  Center the rectangle
somewhere on the top third portion of the work area and then click.  The text box “This is the
Startup Screen!” should appear.

�To create a function key on Window#10

1. From the Parts menu, click Function Key.  The Create Function Key Object dialog box
appears.

2. Type On Button in the Description box.

3. Click Popup Window.

4. Type 11 in the Window No. Box.

5. Click the Shape tab.

6. Click Use shape, then click Shape library.  The Shape Library dialog box appears.

7. Click button1 in the Shape library box.

8. Scroll through the selections to selection 23.  Click the shape, then click OK.  The shape
should appear in the Shape tab.

9. Click the Label tab.

10. Click the pull down box from the Color box.  The Color dialog box appears.

11. Click on the black color box, then click OK.  The color box should reflect what you have
chosen.

12. Select 16 in the Font box.

13. Select Left in the Align box.

14. Type ON in the Content box.

15. Click the Use Label box.

16. Click OK.

17. On the main screen of EasyBuilder, you will see a white square outline that is attached to your
cursor in the work area.  This represents the function key just created.  Center the square
somewhere on the bottom left portion of the work area and then click.  The function key
should appear.

18. Double-click on the function key.  The Function Key Object’s Attribute box appears.

19. Click on the Profile tab.

20. Enter 47 for the X position.  Enter 168 for the Y position.

21. Enter 62 for the Width.  Enter 49 for the Height.

22. Click OK.

23. On the main screen of EasyBuilder, you should see the function key that you just created
move and/or change size.  This function key is used to display Window #11.
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�To create a second function key on Window#10

1. We could create the second function key by repeating the steps for the first function key.
Instead, however, we will take advantage of the first function key and copy it.

2. Click the first function key to highlight it.

3. From the Edit menu, click Copy.

4. From the Edit menu, click Paste.  A copy of the function key appears in the upper left corner
of the work area.  Deselect the function key by clicking on any blank space in the work area.

5. Double-click on the second function key.  The Function Key’s Object Attribute dialog box
appears.

6. In the General tab section, change the Description to Off Button.

7. Click on Change Window.  Enter 10 for Window number

8. Click on the Label tab.  Type OFF in the Content box.

9. Click on the Profile tab.

10. Enter 196 for the X position.  Enter 168 for the Y position.

11. Click OK.

12. On the main screen of EasyBuilder, you should see the second function key that you just
created move to the lower right hand side of the work area.  This function key is used to close
Window #11.

You have finished configuring your first window.  It should look something like the picture below:

Cre ating a Popup Win dow

We will configure Window #11 as a popup window.  Up to six popup windows can be displayed on a full screen
window.  The windows may overlap each other or may be minimized to an icon.  This section will show how to
create a scale and a numeric register that displays the current value of the scale.  You will also create an increment
and decrement key to change the value in the scale meter.

�To create Window#11

1. From the Window menu, click Open Window.  The Open Window dialog box appears.

2. Click New Window.  The Select Window Style dialog box appears.
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3. Click Base Window.   The Window Setting dialog box appears.

4. Enter 79 for the X position.  Enter 58 for the Y position.

5. Enter 160 for the Width.  Enter 120 for the Height.

6. Click the pull down box from the Background Color box.  The Color dialog box appears.

7. Click on the white color box, then click OK.  The color box should reflect the color that you
have chosen.

8. Click OK.

9. Select Window_11 in the Open Window dialog box.

10. Click Open.  The main screen of EasyBuilder should reappear with Window #11 displayed in
the work area.

�To create a rectangle on Window#11

1. From the Draw menu, click Rectangle.  The Attributes dialog box appears.

2. Click on Interior Filled.

3. Click the pull down box from the Interior box.  The Color dialog box appears.

4. Click on the white color box, then click OK.  The color in the Interior box should reflect the
color that you have chosen.

5. Click on an area somewhere inside Window #11. Create a rectangular shape by moving the
mouse cursor.  Click again to permanently create the rectangle.

6. From the Edit menu, click Select.

7. Double-click somewhere on the rectangle.  The Rectangle Object’s Attribute dialog box
appears.

8. Click the Profile tab.

9. Enter 48 for the X position.  Enter 13 for the Y position.

10. Enter 61 for the Width.  Enter 36 for the Height.

11. Click OK.

12. On the main screen of EasyBuilder, you should see the rectangle that you just created move
and/or change size.  This rectangle is used as a backdrop to the scale meter.

�To create scale lines on Window#11

1. From the Draw menu, click Scale.

2. Click on an area somewhere inside Window #11. Create a scale shape by moving the mouse
cursor.  Click again to permanently create the scale lines.

3. From the Edit menu, click Select.

4. Double-click somewhere on the scale lines.  The Scale Object’s Attribute dialog box appears.

5. In the Scale Style box, click Up.

6. Type 10 in the Division box.

7. Type 8 in the Meter length box.

8. Click on the Profile tab.

9. Enter 51 for the X position.  Enter 16 for the Y position.
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10. Enter 56 for the Width.  Enter 28 for the Height.

11. Click OK.

12. On the main screen of EasyBuilder, you should see the scale that you just created move
and/or change size.  This scale should be enclosed by the rectangle.

�To create a meter display on Window#11

1. From the Parts menu, click Meter Display.  The Create Meter Display Object dialog box
appears.

2. Type Meter Display in the Description box.

3. Click the Meter Display tab.

4. In the Style 2 Indicator box, click Up half.

5. In the Value Span box, enter 100.

6. Click OK.

7. On the main screen of EasyBuilder, you will see a white square outline that is attached to your
cursor in the work area.  This represents the meter display just created.  Click to place the
meter display in Window #11.

8. Double-click on the meter display.  The Meter Display Object’s Attribute dialog box appears.

9. Click on the Profile tab.

10. Enter 51 for the X position.  Enter 16 for the Y position.

11. Enter 56 for the Width.  Enter 28 for the Height.

12. Click OK.

13. On the main screen of EasyBuilder, you should see the scaled meter display that you just
created move and/or change size.  The scaled meter display is now complete.

�To create a numeric register on Window#11

1. From the Parts menu, click Numeric Data.  The Create Numeric Data Object dialog box
appears.

2. Type Numeric Data in the Description box.
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3. Click OK.

4. On the main screen of EasyBuilder, you will see a white rectangle outline that is attached to
your cursor in the work area.  This represents the numeric register just created. Click to place
the numeric register on Window #11 somewhere underneath the scale meter.  Four pound
signs “####” should appear.

�To create an increment key on Window#11

1. From the Parts menu, click Set Word.  The Create Set Word Object dialog box appears.

2. Type Increment Button in the Description box.

3. Click on the pull down box of the Set Style Attribute and select JOG++.

4. Enter 1 in the Inc. value box.

5. Click on the pull down box of JOG Delay and select 0.5 second.

6. Enter 100 in the Attribute Upper limit box.

7. Click the Shape tab.

8. Click Use shape, then click Shape library.  The Shape Library dialog box appears.

9. Click Select Lib…  The Open dialog box appears.

10. Select button3.slb from the list of shape libraries.  Then click Open.

11. Click button3 in the Shape library box.

12. Scroll through the selections to selection 21.  Click the shape, then click OK.  The shape
should appear in the Shape tab.

13. Click OK.

14. On the main screen of EasyBuilder, you will see a white square outline that is attached to your
cursor in the work area.  This represents the increment key just created. Click to place the
increment key on Window #11.

15. Double-click on the increment key.  The Set Word Object’s Attribute dialog box appears.

16. Click on the Profile tab.

17. Enter 19 for the X position.  Enter 74 for the Y position.

18. Enter 31 for the Width.  Enter 29 for the Height and click OK.
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19. On the main screen of EasyBuilder, you should see the increment key that you just created
move and/or change size.  The increment key is now complete.

�To create a decrement key on Window#11

1. As with the second function key of Window #10, we are going to create the decrement key by
copying the increment key and then making changes to the attributes.

2. Click the increment key to highlight it.

3. From the Edit menu, click Copy.

4. From the Edit menu, click Paste.  A copy of the increment key appears in the upper left
corner of the work area.  Deselect the increment key by clicking on any blank space in the
work area.

5. Double-click on the second increment key.  The Set Word Object’s Attribute dialog box
appears.

6. In the General tab section, change the Description to Decrement Button.

7. Click on the pull down box of the Set Style Attribute and select JOG—.

8. Enter 0 in the Attribute Bottom limit box.

9. Click the Shape tab.

10. Click Shape library.  The Shape Library dialog box appears.

11. Scroll through the selections to selection 22.  Click the shape, then click OK.  The shape
should appear in the Shape tab.

12. Click on the Profile tab.

13. Enter 105 for the X position.  Enter 74 for the Y position.

14. Click OK.

15. On the main screen of EasyBuilder, you should see the decrement key that you just created
move to the lower right hand side of the work area.
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The following illustration shows how the popup window looks:

You have now done your part in creating this sample project.  It is now time for EZware-500 to do its part.

Fin ishing Up

There are still a few steps, which must be completed before you can test your first project.  In this section, you will:

• save the project onto your computer hard drive

• compile the project into a format that can be understood by the HMI

• download the project to the HM

• verify that the HMI operates as expected

• exit the EZware-500 software

�� If you haven’t already done so, now would be a good time to connect the HMI to the
computer and to connect the PLC that you are using to the HMI.  For more
information, consult the first part of this chapter or see “Installation of HMIs” later on
in this manual.

�Saving your first project

1. From the File menu, click Save As. The Save As dialog box appears.

2. In the File name text box, type EBPrj1.

3. Click Save.  The file is saved onto your computer hard drive and the main screen of
EasyBuilder reappears.

�Compiling your first project

1. From the Tools menu, click Compile. The Compiling dialog box appears.

2. Click Compile. EasyBuilder will compile your project and display error results.

3. If no errors occur, click Close.  The main screen of EasyBuilder reappears.  If errors have
occurred, repeat the steps in the Creating a Sample Project section.

�Downloading your first project

1. Apply power to your HMI.

2. From the Tools menu, click Download. The EasyDownload Complete Project dialog box
appears.

3. If the HMI is correctly connected to the computer, then the download process will begin.
You will notice that a horizontal bar graph is displayed on the computer indicating how much
of the project has been downloaded.  The HMI will also display several Write Flash
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commands that scroll on the screen.  If a timeout error is displayed, please review your
connection of the HMI to the computer and make sure that the appropriate settings in
EasyManager are used.

4. After the download is finished, the Mission Complete dialog box is displayed.

5. Click OK.  The main screen of EasyBuilder reappears.

6. You will now use EasyManager to get the HMI to execute the project you just downloaded.
If you want to exit EasyBuilder, from the File menu click Exit.

�Displaying your project on the HMI

1. From the Windows Task Bar, click EasyManager. The EasyManager dialog box appears.

2. Click Jump To Application.  This will send a command to the HMI to run the project.

3. The HMI should display the following screen.
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4. Press the ON function key to display the popup window.

5. Press the increment and decrement keys on the HMI to see the value in the data register and
scale meter change.  Press the OFF function key to remove the popup window.

CONGRATULATIONS! You have completed your first EZware-500 project.
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Chapter 3 - Simulator Mode

As you saw from creating the sample project in the last chapter, downloading any changes you make to the HMI can
take time.  To decrease the amount of time required to download a project to the HMI you can make these changes
in EasyManager:

• Select the 115200 baud rate.  The default setting of 38400 is recommended for older computers or
when using a very long programming cable.

• Select Partial Download/Upload.  The default setting is Complete Download/Upload.  A
complete download should be used whenever you receive a later version of EZware-500 or any
Boot ROM updates.  It should also be used whenever you select a different PLC protocol driver.

However, even with these improvements, it may still take 1-2 minutes to download a project. A better way of testing
changes made to a project is to use the computer to simulate the operation of the HMI.

This chapter shows you how to dramatically save time when creating and testing a project by putting the computer
into Simulation Mode.  In Simulation Mode, the computer displays a screen that simulates what is seen when the
HMI executes the project file.  You can use the mouse on your computer to simulate the operation of the touch
screen on the HMI.  Rather than waiting two minutes to test each change you make to your project, you can now
instantly switch to Simulation Mode to see if your project is working as expected.

You can enter Simulation Mode in three ways.  Using the sample project that you created in the last chapter, we will
guide you through the three methods.

The Sim u la tion Screen

All modes of simulation use the same screen.

For our example, we are showing the sample project as it would appear after the ON function key has been pressed.
When the Simulation Mode screen first appears, it will always show the startup screen of the project.  You can test
any objects you have created which require touch screen input by clicking on them.  In this example, clicking on the
increment key simulates the key as it is pressed on the touch screen.  Simulation Mode always uses the compiled
version of the project that you have created (the *.eob file).  Therefore, you must save and compile any changes you
make to the project before you can simulate it.

Simulating the HMI is done in on-line or off-line mode. On-line simulation has two modes:
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‘Normal’ mode requires that the HMI be connected to the computer and that the PLC be connected to the HMI.

‘Direct’ mode requires only that the PC be connected to the PLC.  Please note the following:

• Maple Systems’ standard communication cables will not work in Direct mode.  The ‘HMI’ end of
the cable must be wired for the PC’s serial port.

• To simulate protocols using RS422/485, an RS422/485 card must be installed in the PC.

• The Allen Bradley DH485 and Telemecanique UniTelWay protocols are not supported in Direct
mode.

The On-Line simulation mode is selected in EasyManager, by checking or unchecking the Direct  Online-Simulator
box.  Whether started from EasyBuilder or EasyManager, the Online-Simulator will operate in the mode selected by
the Direct Online-Simulator box.

On-line simulation is most useful when a project is near completion and you need to test the interaction of the
project with the PLC. It is also very convenient when making minor changes to a project because these changes can
be instantly checked for operation. When ‘normal’ on-line simulation is used, the computer interrogates the PLC
through the HMI to access any data required. When ‘direct’ on-line simulation is used, the computer interrogates the
PLC directly.

Off-line simulation does not require any connection to the HMI. Because of this, off-line simulation is most often
used when starting a project. You can quickly test new ideas and create preliminary screens without the HMI.
Off-line simulation is also great for demonstrating the operation of the HMI and becoming familiar with the
operation of the HMI before it is installed. If you want to simulate the interaction with a PLC when off-line, it can
be done by creating additional windows on the HMI which allow PLC data input.

����To use off-line simulation mode from EasyBuilder:

1. If the project has been modified since the last time it was saved and compiled, or if it has not
yet been compiled, it must be saved and compiled before the simulator can start.

2. From the Tools menu, click Off-line Simulation or click the Off-line Simulation icon in the
Standard toolbar.

3. The Simulation Mode screen should appear.

4. To end off-line simulation press the Space bar or right click in the simulation screen and click
Exit.

����To use on-line simulation mode from EasyBuilder

1. If the project has been modified since the last time it was saved and compiled, or if it has not
yet been compiled, it must be saved and compiled before the simulator can start.

2. From the Tools menu, click On-line Simulation or click the On-Line Simulation icon in the
Standard toolbar.

3. The Simulation Mode screen should appear.

4. To end on-line simulation press the Space bar or right click in the simulation screen and click
Exit.

Simulation mode can also be started from EasyManager.  EasyManager requires only the compiled project file
(*.eob).  This can be useful in situations in which you want to demonstrate changes made to a project for a client
without giving him access to your project file. It also allows you to rapidly switch from simulating one project to
another without having to open, save, and compile each project.

�To use off-line simulation mode from EasyManager

1. Start the EasyManager software.

2. Click Offline-Simulator.  The Open Project box appears.
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3. Click on the compiled project file that you wish to simulate.

4. Click Open. The simulation screen should appear.

5. To end off-line simulation press the Space bar or right click in the simulation screen and click
Exit.

�To use on-line simulation mode from EasyManager

1. Start the EasyManager software.

2. If using Direct Online Simulation, check the Direct Online-Simulator box.  If using Normal
Online Simulation, leave unchecked.

3. Click the Online-Simulator.  The Open Project dialog box appears.

4. Click on the compiled project file that you wish to simulate.

5. Click Open. The simulation screen should appear.

5. To end on-line simulation, press the Space bar or right click in the simulation screen and click
Exit.

Trou ble shooting Tools Dur ing Sim u la tion

Simulation mode allows additional functionality.  By placing the mouse anywhere on the simulation screen and
doing a right click, a new menu comes up with additional features.

Search: Allows searching the entire project for a particular PLC address. To search, check the PLC and then type
the address.  Searching can also be done by parts.  Check Part and select the type of object.

PLC Monitor:  Allows monitoring of the polling communication between the HMI and the PLC.   This monitor
can help troubleshoot register fault problems.  To view each time the HMI polls the PLC and grabs a single or a
block of registers, click on the Block Capture.  Each poll communicates the following information:

• The window from which the register or block of registers is called (Win000 are background tasks
such as alarm scan objects)

• Time it took to get the data

• Register address

• Number of 16-bit words it grabbed

• Register type

If Block Capture fails to retrieve the data, the message “FAIL” will appear to the right.

System Resource:  Displays information about the availability of the following HMI resources:

• RAM memory

• Timers

• Queues

Data Monitor:  Shows live PLC data polling based on individual object types.

Emulator Setting:  Sets up how the Simulator appears and operates.

Print Screen (preview & save to file):  Prints a picture of the current screen displayed.  To preview before printing,
select Screen Preview.  “Print screen to a file” will create a bitmap image of the screen.

Print Window (preview & save to file):  To print object/address information within, select Window printing and
then select the Table radio button.  To preview, select Window Preview.  Selecting Print window to a file creates
a bitmap image of the screen data.

Cap turing Sim u la tion Screens to Use as Doc u men ta tion

�To capture screen pictures for creating documentation

1. Run the simulator (either on-line or off-line)
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2. When the window to be captured is displayed, hold the ALT key down and push the PRINT
SCREEN key on your keyboard.  This will send a bitmap image of the simulation window to
the clipboard.

3. Open a word document or your publishing software and PASTE (CTRL + V) the image from
the clipboard.

Wiring for Nor mal Sim u la tion Mode

This section describes how to connect the PC/PLC/HMI for Online Simulation in the “Normal” mode.  To configure
the HMI using Simulation Mode, you will need an HMI Configuration Cable, Maple P/N 7431-0098. Connect the
end marked “HMI” into Port 2 on the HMI, marked “PLC[RS-485]/ PC[RS-232],” and connect the end marked PC
into the proper COM port on your PC. Plug the end marked “PLC” into the appropriate port on your PLC. See the
figure below for serial port pin assignments and the following two figures on the next page for connecting the Silver
Series to a PC and a PLC.

The following section describes how to connect the PC/HMI for Online-Simulation in the ‘Direct’ mode.

Note the following restrictions:

•  Maple Systems’ standard communication cables will not work in Direct mode.  The ‘HMI’ end of
the cable must be wired for the PC’s serial port.

• To simulate protocols using RS422/485, an RS422/485 card must be installed in the PC.

• The Allen Bradley DH485 and Telemecanique UniTelWay protocols are not supported in Direct
mode.

To configure Direct Online-Simulation, you will need a cable connecting the PC to the PLC.  Standard Maple
communication cables will not work.  The cable needs to be wired such that the PLC’s RX pin(s) is connected to the 
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PC’s TX pin(s), and the PLC’s TX pin(s) is connected to the PC’s RX pin(s).  Any common pins also need to be
brought through, and shield connections should also be made.

Refer to Maple Systems communications cable drawings for guidance, but remember that the HMI end will have to
be changed.  Refer to the figures on the previous pages for information on power connections and HMI serial
connector pinouts.
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Now that you are familiar with using simulation mode, the next chapter guides you through the fundamental
operation of three primary segments of the EZware-500 configuration software.
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Chapter 4 - Using EZware-500

Over view

The EZware-500 software is composed of three separate applications which are accessible from the EZware-500
folder: EasyBuilder, EasyManager, and EasyASCIIFontMaker.  EasyBuilder is the application software used to
create a project file.  EasyManager is a utility application that puts the HMI into different operating modes.  Finally,
the EasyASCIIFontMaker program allows you to modify the text fonts that are used in EasyBuilder.

By the end of this chapter, you should be quite familiar with the operation of EasyManager and
EasyASCIIFontMaker.  You will also be able to maneuver around EasyBuilder easily.  This will pave the way for
actually creating graphics objects in later chapters.

The EasyManager

The EasyManager utility sets the communications parameters that are used by the computer when communicating to 
the HMI.  The utility can also be used to change the operating mode of the HMI.
The following illustration shows the various commands available:
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Com mu ni ca tions Set tings

• Com Port   Select COM1 – COM10 on the computer to download a project to the HMI.

• Baud Rate  Select 38400 or 115200 bps to download or upload a project to the HMI.  We
recommend that you use 115200 unless your computer is unable to transmit at that speed.

• Project or Recipe Download/Upload  Select Project Download/Upload when you want to
download the project. Select Recipe Download/Upload to update your recipe files (recipe module
only available for some models).

• Complete or Partial Download/Upload  When you first program the HMI you should select a
complete download.  A complete download should also be used whenever a new version of
EZware-500 is used or you receive a Boot ROM update.  Finally, a complete download should be
performed whenever the PLC protocol driver is changed.  If, however, you are  making changes to
a project file then you can decrease the download time by selecting  partial download/upload.

Op er ating Modes

• Click EasyBuilder to start the EasyBuilder application software.

• Click Online-Simulator to open a compiled project file (*.eob) in on-line simulator mode.  Check
Direct Online-Simulator to perform online simulation without using the HMI.

• Click Offline-Simulator to open a compiled project file (*.eob) in off-line simulator mode.  See
the chapter “Simulator Mode” for more information.

• Click Download to send a compiled project file stored on the computer to the HMI.

• Click Upload to receive a compiled project file from the HMI to be stored in the computer.

� Files uploaded from the HMI are “.eob” files.  These need to be decompiled, before
they can be modified by the EasyBuilder software.  To decompile, go to the Tools menu, 
and select Decompile.  Browse for your file and then press the “Decompile” button.
This will create a “.epj” file, which can be opened and modified in EasyBuilder.  (If the
project was created in a version of EasyBuilder prior to v.2.0, it will not decompile.)

• Click Jump To RDS to place the HMI in Remote, Debug, Simulation mode.  This mode is used
only when you need to update the Boot ROM.

• Click Jump To Application to place the HMI in normal application mode.  This command must be
sent to the HMI to get the HMI to execute the project file that is stored inside of it.

• Click Jump To Touch Adjust to calibrate your touch screen.  The HMI displays a crosshair cursor 
and you are asked to touch the crosshair cursor for:

• the top left po si tion

• the top right po sition

• the bottom left po sition

• the bottom right position

• Two rectangle objects then appear on the HMI screen.  To determine if the touch screen is properly
calibrated, place and hold your finger somewhere on the touch screen other than on the rectangle
spots.  The crosshair cursor should appear directly beneath your finger.  If necessary, press the left
rectangle to repeat the calibration.  Press the right rectangle to end calibration.

• Once calibration is complete, press the touch screen again to go back to normal application mode.

� The touch screen is always calibrated at the factory, so it shouldn’t require calibration
under normal circumstances.
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That’s all there is to EasyManager!  Most of the time, you will use EasyManager to  start the project that you have
downloaded from EasyBuilder to the HMI by clicking the Jump To Application button.

The EasyASCIIFontMaker

The EasyASCIIFontMaker application allows you to modify the text font characters that are supplied with
EZware-500.  This feature of the Silver Series HMIs enables you to create any special text characters that you may
need.  In fact, you can even create an entirely new font!

EasyBuilder’s De fault Text Fonts

EasyBuilder uses three font types to display text in eight different font sizes: 8, 16, 24, 32, 48, 64, 72, and 96.

• The Type 8 font is used to display the size 8 font characters.  The font characters are stored in a file
in the EZware-500 directory called ASCFONT.8.

• The Type 16 font is used to display the size 16, 32, and 64 font characters.  These font characters
are stored in a file called ASCFONT.16.

• The Type 24 font is used to display the size 24, 48, 72, and 96 font characters.  These font
characters are stored in a file called ASCFONT.24.

Using the EasyASCIIFontMaker

The fol low ing illustra tion shows the ASCIIFontMaker appli ca tion screen with the ASCFONT.16 file opened:

�
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�To modify a font file

1. Start the EasyASCIIFontMaker application.

� You must close the EasyBuilder application before you can modify a font file.

2. Click Open from the File menu.  Open the font file you wish to modify.

3. Click Edit from the View menu to place the application into edit mode.

4. Click Toggle from the View menu to be able to modify a character.

5. Click the particular character that you wish to modify.

6. Click on any square with the character block to draw.  Clicking the same square again while
in Toggle mode will clear the square.

7. Right-click to Copy, Paste, or Clear a character.

8. After you are satisfied with the changes made, click Save from the File menu.

� It is generally good practice to copy the font files to backup files before you make any
changes so that you can restore them later, if necessary.

The table below describes the use for each icon on the toolbar.

Icon Name Description

New Starts a new font file.

Open Opens an existing font file.

Save Saves the font file.

Cut Not currently used.  Right click on any character to copy, paste, or clear it.

Copy Not currently used.  Right click on any character to copy, paste, or clear it.

Paste Not currently used.  Right click on any character to copy, paste, or clear it.

Print Not currently available.

About Used to show the version of EasyASCIIFontMaker.

Help Not currently available.

Edit Puts the application into Edit mode so that characters can be modified.

View x1 Shows how the characters look in various Zoom modes.

View x2 Shows how the characters look in various Zoom modes.

View x3 Shows how the characters look in various Zoom modes.

View x4 Shows how the characters look in various Zoom modes.

Toggle
In Edit mode, using this format allows you to click once to fill a square in the character block.  Click
again to clear the square.

On In Edit mode, this format always fills a square when it is clicked.

Off In Edit mode, this format always clears a square when it is clicked.

None Use this format to ensure that no characters are changed.
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The EasyBuilder Ap pli ca tion

This section guides you in how to operate the EasyBuilder application.  However, it does not show you how to
program your HMI or how to create graphics objects.  These topics are reserved for later chapters.  This section
shows the fundamental operation of EasyBuilder from saving files, printing projects, and selecting the target PLC to
showing how graphics objects can be easily manipulated in the EasyBuilder work area.  When you have completed
this chapter, you will be better able to use the features that are explained in later chapters.

The following illustration is used for reference to the following sections:

Man ag ing Pro jects

Like most Windows™ application software, EasyBuilder will open, save, close, and print files using the standard
windows format.

Open ing, Editing Pro jects

�To create a new project

1. On the File Menu, click New or click the New icon in the Standard toolbar.  The  EasyBuilder
dialog box appears.

2. Select the HMI model you intend to use with your project.
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3. Select the Display Mode you intend to use with your project.

4. Landscape mode is the standard display mode for conventionally installed HMIs, with 640 x
480 or 320 x 240 resolution. Portrait mode configures display on HMIs installed at right
angles, with resolution of 480 x 640 or 240 x 320.

� A project’s display mode may be changed after the initial selection has been made.  To
set  Display Mode select Edit-System Parameters…, and select the Hardware tab.  To
change the Display Mode, resize the window’s resolution to fit the mode selected.
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5.   Click OK.  The main screen of EasyBuilder appears with a blank work area.

�To open an existing project

1. On the File Menu, click Open or click the Open icon in the Standard toolbar.  The Open
dialog box appears.

2. Click on the project file you intend to open.

3. Click Open.  The main screen of EasyBuilder appears with the initial screen of the project
displayed.

�To close a project

1. On the File Menu, click Close.  If changes have been made to the project file, EasyBuilder
will ask you if you would like to save the project.  Then the main screen of EasyBuilder will
remain but with no work area displayed.  You must now use the Open or New commands to
edit a project.

�To save an existing project

1. On the File Menu, click Save or click the Save icon in the Standard toolbar.

2. If the project already has a name, then the project will automatically be saved.  If this is a new 
project, then the Save As dialog box appears.

3. Enter a file name and then click Save.

4. The main screen of EasyBuilder reappears.

�To save a project using the compress feature

The compress feature allows you to save a project in compressed format so that the project data takes less space on
your hard drive.  This utility also will save the graphics libraries associated with the project into the project file.
This facilitates sending a copy of the project to another person who has EZware in order to download the project
into an HMI.

1. From the Tools menu, select Compress/Uncompress....  The Compressing dialog box
appears.

2. In the Compress frame box under Source Name, select the project (*.epj) file that you wish
to compress.  File must have a .cmp extension.

3. Click Compressing… to begin.  The utility will compress the project file and all related
graphics libraries into a single file.

�To extract a compressed project file

1. From the Tools menu, select Compress/Uncompress....  The Compressing dialog box
appears.

2. In the Uncompress frame box under Source Name, select the project (*.cmp) file that you
wish to uncompress.

3. Click Uncompressing… to begin.  The utility will extract the project file and all graphics
libraries from the *.cmp file.

�To exit EasyBuilder

On the File Menu, click Exit or click on the standard windows Close icon in the upper right corner.
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Print ing Pro jects

A text-based project summary can be printed from within EasyBuilder.  Printing from the Project Simulator allows
more options, including generic pictures of the screens.  To print the summary, select Print Object Summary from
the File menu.  Other options include Print Preview and Print Setup.

�Printing project data is done from the Project Simulator

1. Start the project in the On- or Off-line simulator.

2. Display the window to be printed.

3. Right-click anywhere in the window.

4. To print or save a copy of the window, select Print Screen or Print Screen to File.  To print
object/address information for the screen, select Print Window or Print Window to File. A list
of active windows is displayed.  Select the desired window.  Select Image to display an image
of the window, or Table to display object/address information.

Editing and Creating Screen Ob jects

This section shows how to manipulate graphics objects that are placed onto the work area of EasyBuilder.  We will
use examples from sample projects that are included with the EasyBuilder software: HMI520M.EPJ, HMI520C.EPJ,
HMI530C.EPJ, and HMI550H.EPJ.  Please load one of these project files and have EasyBuilder ready before you
begin this section.

We will refer to Window_12 of the project.  To display Window_12 on EasyBuilder, perform the following steps.

�To open a window

1. On the Window Menu, click Open Window.  The Open Window dialog box appears.

2. Click Window_12.

3. Click Open.  Window_12 appears in the work area of EasyBuilder.
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Dis play Options

Before we begin describing some of the commands that can be used to edit graphics objects, there are a few
commands that apply to the general work area of EasyBuilder.
EasyBuilder provides a Window No. Treebar window that can be used to easily maneuver between windows of a
project.  It also allows you to select any object that is on the window that is currently displayed.

�To display/hide the Window No. Treebar

1. On the View Menu, click Window No. Treebar.

�Using the Window Treebar to display window screens

1. The Window Treebar combines into a single tree a list of all of the windows in a project, and
all of the objects on each window.  Using the 520CDEMO.EPJ project, the following should
be seen : 

2. Notice that the tree displays the title for each window next to the window number.  This
makes it easy to determine windows have been created for a project.  The asterisk next to
Window #10 indicates that this window is currently open.

3. To display an open window,  click on the window number in the Window Treebar.  To
display a window that is not yet open, double-click on the window number.  This will
automatically open the window and display it.
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4. To change any settings or close an open window, click on the window number to select it. 
Then right-click anywhere inside the Window Treebar to display a pop-up dialog box.  Select
Close to close the window or Setting to change any of the window settings.

5. Finally, to create a new window  click on any window number that is not currently used. 
Then right-click inside the Window Treebar and click Create.

�Using the Window Treebar to change object attributes

1. On the Window Treebar, click  + adjacent to any window number.  The tree will expand to
list the objects on that window, as shown:

2. The Object ID of each objects will be listed.  For example, TX_0 is Text Display #0, FK_0 is
Function Key #0, etc.

3. To highlight a particular object on the screen, click on the Object ID in the list.  This allows
the quick selection of a particular object, especially on crowded screens or screens where
objects may be overlapping..

4. To display the object’s attribute dialog box, double-click the Object ID  in the Window
Treebar.
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�Using the grid function

One option is to have the work area covered with grid lines.  These grid markings can be helpful when trying to
align objects that are created on the work area.  If grid lines are selected, you can decide what size each grid is.

1. On the Option Menu, click Grid/Snap, then click the Display box or click the Grid icon in
the Standard toolbar.

� If you still don’t see the grid after you have enabled it, make sure that the color of the
grid doesn’t match the background color of the window currently displayed.

�Changing the grid size

1. On the Option Menu, click Grid/Snap.

2. Select the X spacing and Y spacing for grid size.

� Spacing is measured in pixels.

�Changing the grid color

1. On the Option Menu, click Window Property.  The Window Property dialog box appears.

2. Click the pull down box from the Color box.  The Color dialog box appears.

3. Click on the appropriate color box, then click OK.  The color box should reflect what you
have chosen.

4. Click OK.

Another option is to display what are known as Object ID tags.  Every time you create a new object in EasyBuilder,
an Object ID tag is assigned to the new object.  This is done for several reasons:

• Object ID tags are required by EasyBuilder to differentiate each object created.

• If an error occurs during the compile process, EasyBuilder can refer to the window and object ID to 
indicate the object that is causing problems.

�To enable/disable Object ID tags

1. On the Option Menu, click Window Property.  The Window Property dialog box appears.

2. Click the Display Object ID checkbox to display tags.

3. Click OK.

If you enable the Grid on the work area, you may also take advantage of a useful feature called Snap.  The Snap
option causes all objects placed into the work area to fall along the boundaries set by the grid lines.  The Snap
option can help provide a more ordered appearance to graphics objects.

�To use the snap option

1. The Grid option must be enabled.

2. On the Option Menu, click Grid/Snap.  The Grid/Snap Settings dialog box appears.

3. Click the Snap checkbox.

4. Click OK.

Finally, you will find that you can move objects by selecting them with the mouse cursor and dragging them to a
new location.  However, you may find it difficult to select an object without accidentally moving it just a little.  At
times this may be frustrating so you may want to disable the move feature using the mouse and only move an object
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by changing it’s X and Y position parameters in the Profile tab of the object’s attributes box.  This is the intent of
the Fix Objects feature.

�To enable the fix objects command

1. On the Option Menu, click Grid/Snap.  The Grid/Snap Settings dialog box appears.

2. Click the Fix Objects checkbox.

3. Click OK.  Movement by mouse cursor is now disabled.

�To zoom in on the selected window

 Use the zoom pulldown menu at the top right of the screen.

�To change the state of the selected window

1. Use the zoom pulldown menu at the top right of the screen.  The objects will appear as they
would in the selected state.

�To change the language to enable language specific characters

1. On the Option Menu, click Language.  Then select your appropriate option.  To use a
particular language, EasyBuilder must be installed in that version of Windows.

Ba sic Editing Com mands

�To select a graphics object

1. On the Edit Menu, click Select or click the mouse cursor icon in the Draw toolbar.

2. Click on the graphics object.  For example, using Window_12, click on Alignment.  This
causes the text box to be selected, with small square blocks around the edges indicating the
boundaries of the object.  Deselect the object by clicking somewhere else in the work area.

3. When a graphics object is selected, it can then be modified, copied, deleted, or moved to a
new location.

�To select multiple graphics objects

1. On the Edit Menu, click Select or click the mouse cursor icon in the Draw toolbar.

2. Click and hold down the left mouse button at the upper left corner of the graphics objects you
wish to highlight. For example, using Window_12, click to the left and above of Alignment.
Multiple objects can be selected by holding down the CTRL key and clicking on the objects
you wish to select.  The ESC key can be used to deselect all items.
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3. Move the mouse cursor to the lower right corner of the highlighted objects.  Notice that a
rectangle is formed as you do this. In this example, move the mouse to the right and below
Make Same Size.

4. Release the mouse button.  The rectangle outline changes to small clear square blocks around
the perimeter of the objects selected.

� If you do not completely enclose any graphics objects you wish to highlight then they
will not be selected.

5. When several graphics objects are selected, they can easily be moved, deleted or copied
together.

�To select next object

1. This option can be used to easily select an object that is underneath another object on the
screen.  To use this option, you must first select the overlapping object.

2. On the Edit Menu, click Select Next Object or click on the Select Next Object icon  on the
Standard toolbar.  You can also right-click on the top-most object on the screen.  This will
display a menu with a list of the overlapping objects on the bottom.  Then  check the object
that you wish to access.

3. Once the object you are trying to access is selected, you can proceed to modify its attributes
or delete it.

�To select all objects

1. On the Edit Menu, click Select All Objects.

2. Small clear square blocks appear around the perimeter of all the objects on the window.

3. You can now easily move, delete or copy the entire window screen to a new window.

�Using the Undo and Redo commands

1. The Undo command is used to cancel the last command or action that you made.  For
example, select the Alignment text box in Window_12.

2. Press the Delete key on your keyboard to delete the text box.

3. From the Edit menu, click Undo or click the Undo icon from the Standard toolbar.  You can
also press CTRL+Z.  The deleted text box reappears.

4. The Redo command is used to cancel the Undo command.  For example, if you decided that
you really did want the Alignment text box deleted,  click the Redo command.
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�Using the Cut  , Copy , and Paste  commands

1. These commands are all selected from the Edit menu or by clicking the appropriate icon in
the Standard toolbar.

2. Select the graphics object or objects you wish to cut or copy.

3. Click Cut to copy and remove the graphics object(s) from the work area or click Copy to 
copy the graphics object(s).  Using Window_12, select the scale meter and then press
CTRL+X to cut the object from the work area.

4. Objects cut or copied from one window can be pasted into other windows.  Once the object
has been selected and cut or copied,  open another window, then paste the object into that
window.

5. In this example, paste the scale meter back into Window_12 by pressing CTRL+V.  The
pasted object appears highlighted in the upper leftmost corner of the work area.

6. Move the scale meter by clicking on the highlighted object and dragging it back to the
original position.

�Using the Multi-Copy command

The Multi-Copy command is used to make multiple copies of a single object on a screen.  This is most useful when
creating new keyboards or data tables. In addition to copying the object, this command will automatically assign
new PLC memory addresses to each object, (applies only to Bit-type objects).

1. Select the object you wish to copy.

2. From the Edit menu, select Multi. Copy....  The Multi. Copy dialog box appears.

3. Modify the settings according to your requirements.

4. Click OK. The main screen of EasyBuilder is redisplayed with the Multi. Copy command
executed.

Multiple objects can be created according to these parameters:

� Pitch vs. Interval: This setting affects how EasyBuilder places the copies of an object on the screen relative 
to each other.  The Pitch setting will interpret the X Distance setting as the distance from the left side of an
object to the left side of the next object and the Y Distance setting as the distance from the top of one object
to the top of another object.

The Interval setting will interpret the X Distance setting as the distance from the right side of one object
to the left side of the next object.  The Y Distance setting is the distance from the bottom of one object
to the top of the next object.

� RGT vs. BTM: This setting determines in what order each new copy is made.  This will affect how the
automatic PLC memory addressing is created for each object.  The RGT (right) option creates copies along
the X axis first (from left to right), then along the Y axis (from top to bottom).  The BTM (bottom) option
creates copies along the Y axis first, then the X axis.

� X Distance, Y Distance: These settings determine the spacing (in pixels) between objects.

� Quantity X, Quantity Y: These settings determine the number of copies to be made along the X axis
(horizontal) and the Y axis (vertical).

� Adjust Distance:  This is the offset used when assigning a new PLC memory coil address to each new
copy.  For example, if 1 is selected, then EasyBuilder will add one to the PLC memory coil address for each
new copy made.

�Using the Window Copy command

The Window Copy command is used to copy a window from an existing project into the project that you are
currently editing.  This feature reduces time spent creating new projects since you can now use windows that you
created for other similar projects.

1. From the Edit menu, select Window Copy....  The Window Copy dialog box appears.
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2. In the Source Project: box, specify the path to the project that contains the window screen
you wish to  copy.  Use the Browse command button if you are unsure of the location or
name of the project file.

3. In the Source Window No.: box, enter the number of the window screen you wish to copy.

4. In the Desti. Window No.: box, enter the number of the window screen in the project you are 
currently editing that you wish to copy the contents of the source window to.

5. Click OK. The main screen of EasyBuilder is redisplayed with the Window Copy command
executed.

�To delete a graphics object(s)

1. Select the object or objects you wish to delete.

2. Press the Delete key or from the Edit menu, click Delete.

� You can restore the deleted object by using the Undo command.

�To move a graphics object(s)

1. Select the object or objects you wish to move.

2. When you place the mouse cursor over a highlighted object, the cursor changes to a crosshair.
This indicates that you are able to move the selected object.  Move the object by clicking on it
and dragging the object to the proper position on the work area.

�To resize a graphics object

1. Select the object to be resized.

2. To resize the object, move the mouse cursor over one of the small black squares.  The cursor
changes to a double-arrow icon to indicate that it is in resizing mode.

3. Click and drag the mouse to resize the object.

4. Objects can also be resized by changing the width and height attributes in the Profile tab of
the Attributes dialog box, (see below).

�To change attributes of a graphics object

1. Select the object to be changed, then select Change Attributes from the Edit menu.  You can
also double-click the object.

2. The object’s attribute dialog box is displayed.  Object Attributes defines what the object is or
how it behaves, (i.e. size, position, color, etc.).  Click OK to accept any changes made or
Cancel to cancel any changes.

�To view object attributes of multiple graphics objects on a window

1. There will be times when you may want to quickly determine what PLC data registers are tied 
to which objects in a window.  This can easily be done using the object attributes command.

1010-1001a, Rev 01

Using EZware-500 57



2. For this example, open Window_11 to display the popup window of the sample project.

3. On the Edit menu, click Select all objects.

4. From the Edit menu, click Change Attribute. The Object Attribute dialog box is displayed.

5.  All of the objects that use PLC data registers or the internal memory of the HMI are listed in
this dialog box according to their Object ID tag.  Alongside each ID tag is the PLC or HMI
memory identifier.

Group ing Ob jects

When creating graphics on a window, you may create a complex graphic that is actually composed of several
simpler objects overlaid onto each other.  The scale meter in Window_12 is such an example.

This meter is actually composed of three separate objects:
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          a rectangle            a scale a meter display

These objects are then overlaid to represent the scale. Grouping the three objects together makes it easier to move
or copy the scale meter.  Instead of copying each separate object, the scale meter can be assigned as a group, then
copied as though it were one object.

�To group objects

1. Select the objects to be grouped.

2. From the Edit menu, click Group or click the Group icon from the Manager toolbar.

3. All objects within the group can now be copied, deleted, or moved by clicking on the group.

�To ungroup objects

1. Select the objects to be ungrouped.

2. From the Edit menu, click UnGroup or click the UnGroup icon from the Manager toolbar.

3. All objects within the group can now be copied, deleted, or moved separately.

Layering Ob jects

Graphics objects can be overlaid upon each other.  When ‘layered’ the graphics object on the topmost layer will be
completely seen.  How much of the other graphics objects are seen depends on what is on top of them.  The
following layer commands help to position the overlaid objects exactly how you want them. To better illustrate how
layering works we will use a rectangle object, a circle object and an arc object that are overlaid on each other in
Window_12 of the sample project.

�Using the top  and bottom  layer commands

1. Select one of the layered objects.  In this example, select the layered rectangle from
Window_12.
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2. From the Edit menu, click Layer, then TopLayer or click the TopLayer icon from the
Manager toolbar.  Note that the rectangle completely overlaps the circle and the arc.

3. From the Edit menu, click Layer, then BottomLayer or click the BottomLayer icon from
the Manager toolbar.  Note that the rectangle recedes behind the circle and the arc.

�Using the next  and previous  layer commands

1. These two commands can move an object through the various layers of other objects.

2. Select one of the layered objects.  Again, select the layered rectangle from Window_12.

3. From the Edit menu, click Layer, then PreviousLayer or click the PreviousLayer icon from
the Manager toolbar.  Note that the rectangle covers the circle but not the arc.

4.    From the Edit menu, click Layer, then NextLayer or click the NextLayer icon from the
Manager toolbar.  Note that the rectangle recedes behind the circle and the arc.

Normally, an object that is controlled by a PLC Register (i.e., a Word Lamp, Bit Lamp, Animation, etc.) is brought
to the Top Layer when the value in the PLC Register changes.  This behavior can be changed by the Part Layout
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option on the Editor tab of the System Parameters dialog.  A setting of Control is the default, and sets the behavior
as outlined above.  A setting of Nature will result in the object remaining at the layer assigned during development.

��The Part Layout setting is global, and affects all PLC-controlled objects in the application.

Nudg ing Ob jects

Nudging is used to fine-tune the movement of objects in the work area of EasyBuilder.  Using the nudge feature on
a selected object will move that object in the specified direction either by one pixel or by the grid setting amount.

�Using the nudge top  , bottom  , left  , and right    commands

1. Select one of the layered objects or a group of objects in the work area of EasyBuilder.

2. From the Edit menu, click Nudge, then select the direction of the nudge or click the
appropriate icon from the Manager toolbar.

Aligning Ob jects

Alignment can be used to quickly align two or more objects.  To better illustrate, refer to the left side of Window_12 
of the sample project:

�Using the align left  command

1. Select the objects you wish to align.  For this example, select the three rectangle objects of
Window_12
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2. From the Edit menu, click Align, then Left or click the appropriate icon from the Manager
toolbar.

3. From the Edit menu, click Undo to put the objects back in their original position.

�Using the align right  command

1. Select the objects you wish to align.  For this example, select the three rectangle objects of
Window_12

2. From the Edit menu, click Align, then Right or click the appropriate icon from the Manager
toolbar.

3.    From the Edit menu, click Undo to put the objects back in their original position.

�Using the align top  command

1. Select the objects you wish to align.  For this example, select the three rectangle objects of
Window_12
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2. From the Edit menu, click Align, then Top or click the appropriate icon from the Manager
toolbar.

3. From the Edit menu, click Undo to put the objects back in their original position.

�Using the align bottom  command

1. Select the objects you wish to align.  For this example, select the three rectangle objects of
Window_12

2. From the Edit menu, click Align, then Bottom or click the appropriate icon from the
Manager toolbar.

3. From the Edit menu, click Undo to put the objects back in their original position.

�Using the align horizontal center   command

1. Select the objects you wish to align.  For this example, select the three rectangle objects of
Window_12
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2. From the Edit menu, click Align, then Horiz. Center or click the appropriate icon from the
Manager toolbar.

� Centering is based on the horizontal center of the left-most object.

3. From the Edit menu, click Undo to put the objects back in their original position.

�Using the align vertical center command

1. Select the objects you wish to align.  For this example, select the three rectangle objects of
Window_12

2. From the Edit menu, click Align, then Vert. Center or click the appropriate icon from the
Manager toolbar.

� Centering is based on the vertical center of the top-most object.

3. From the Edit menu, click Undo to put the objects back in their original position.
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Making Ob jects the Same Size

This feature is handy if you want to quickly make two or more objects the same size. This is most often used when
you are trying to overlap objects that must be the same size.  To better illustrate, refer to the left side of Window_12
of the sample project:

�The make same width  command

1. Select the objects you wish to make the same width.  For this example, select the left and
center rectangle objects of Window_12

2. From the Edit menu, click Make Same Size, then Width or click the appropriate icon from
the Manager toolbar.

� EasyBuilder always uses the width of the last object that was created as the basis for
the width.  In this example, the left rectangle was created first, then the middle
rectangle, finally the right rectangle.  See what happens when the make same width
command is applied to the center and right rectangles.
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�The make same height  command

1. Select the objects you wish to make the same height.  For this example, select the left and
center rectangle objects of Window_12

2. From the Edit menu, click Make Same Size, then Height or click the appropriate icon from
the Manager toolbar.

� EasyBuilder always uses the height of the last object that was created as the basis for
the height.  In this example, the left rectangle was created first, then the middle
rectangle, finally the right rectangle.  See what happens when the make same height
command is applied to the center and right rectangles.

�The make same size   command

1. Select the objects you wish to make the same size.  For this example, select the left and center
rectangle objects of Window_12
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2. From the Edit menu, click Make Same Size, then Both or click the appropriate icon from the 
Manager toolbar.

� EasyBuilder always uses the size of the last object that was created as the basis for the
size.  In this example, the left rectangle was created first, then the middle rectangle,
finally the right rectangle.  See what happens when the make same size command is
applied to the center and right rectangles.

Flip ping Ob jects

These three commands allow you to quickly ‘flip’ or position an object in a new direction.  To better illustrate, we
will again refer to Window_12 of the sample project.

�To flip vertically

1. Select the object you wish to flip vertically.  For this example, select the left triangle object of
Window_12.
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2. From the Edit menu, click Flip Vertical or click the appropriate icon from the Manager
toolbar.

3. From the Edit menu, click Undo to put the left triangle object back in its original position.

�To flip horizontally

1. Select the object you wish to flip horizontally.  For this example, select the right triangle
object of Window_12.

2. From the Edit menu, click Flip Horizontal or click the appropriate icon from the Manager
toolbar.

3. From the Edit menu, click Undo to put the right triangle object back in its original position.

�To rotate

1. Select the object you wish to rotate.  For this example, select the right triangle object of
Window_12.

2. From the Edit menu, click Rotate 90 degrees or click the appropriate icon from the Manager
toolbar.
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� To Lock an Object

Each object position and size can be locked by using the Pin button.  When the object is locked, its position and size
cannot be changed.

1. Select the object you wish to lock.

2. From the Edit menu, click Pinned or click the appropriate icon from the Manager toolbar.

3. To unlock the object, deselect Pinned from the Edit menu or click the appropriate icon from
the Manager toolbar.

Gen eral Settings

The final section of this chapter shows all the settings or parameters that can be configured using EasyBuilder.
From the Edit menu, click System Parameters.  The System Parameter Setting dialog box appears.  The dialog box 
has six tabs: PLC, General, Indicator, Security, Editor, Hardware, and Aux.
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PLC Set tings Con fig u ra tion

�To configure PLC settings

1. Select the appropriate PLC driver from the PLC pull-down menu.

� You can “export” a project created for one PLC brand to a different PLC brand by
loading the project file into EasyBuilder, then entering a different PLC type in this box.
EasyBuilder will go through your entire project and attempt to change each reference
to PLC data registers to a logical selection for the new PLC protocol; however, se
strongly recommend that you review these changes to assure that they are satisfactory.

2. If you haven’t already done son, select the appropriate HMI model: HMI520M, HMI520C,
HMI520T,  HMI520H, HMI530C, HMI530T, HMI550M or HMI550H.
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� You can “export” a project created for one HMI model to a different HMI model.  If the
original project was created for the color HMI, then changing to the 4-shade blue
version causes EasyBuilder to select the closest monochrome shade for each color
used.  If the original project was created for the 4-shade blue HMI, changing to the
color version causes EasyBuilder to select a standard set of colors to represent each
blue shade.

3. Set the serial port type the HMI will use to communicate with the PLC.

� RS232: Uses the HMI’s 9-pin female connector labeled PLC[RS232].

� The following selections use the HMI’s 9-pin male connector labeled PLC[RS485]
PC[RS232].

RS485 default: The selected protocol determines 2 or 4 wire.

RS485 4W: Forces RS485 4-wire configuration.
��� RS485 2W: Forces RS485 2-wire configuration.

����Ethernet: Uses the RJ45 10BaseT connector.

4. Select baud rate, parity, data bits, and stop bits.  Use Maple Systems’ Controller Information
Sheets or the PLC manufacturer’s operations manual for information on the communications
parameters required by the PLC.  These parameters have to match the PLC settings.

5. Parameter 1 and 2 are used to configure a delay time for the HMI.  The time set on these
parameters is the time the HMI will wait before sending another request for information.
Parameter 1 is used in the Protocol level and Parameter 2 is used at the Operating System
level.  Refer to the Controller Information Sheets if these parameters are required.  Parameters
3-6 are not used.

6. Set the HMI Station No. used by some protocols that require the HMI to have a unique
network address.  Consult your Controller Information Sheets for information on the
protocols to which this parameter applies.

7. Set the PLC Station Number or Node Address of the PLC with which the HMI will
communicate.

8. Multiple HMI and HMI-HMI link speed: Used when connecting multiple HMIs to a single
PLC.  Disable this setting if you are connecting only a single HMI to a PLC.  For more
information on connecting multiple HMIs, see Connecting Multiple HMIs to one PLC at the
end of this chapter.

9. Connect I/F:  Allows selection of the method by which multiple HMIs can be daisy-chained.
The options are Serial or Ethernet.  If Ethernet is selected, configure the Local and the Server
IP addresses.  For more information, see Connecting Multiple HMIs Using the Ethernet Port
at the end of this chapter.

10 PLC Block Pack:  Determines how many words are read from the PLC in one
communication cycle.  For more information on this feature, see PLC Block Pack at the end
of this chapter.
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Gen eral Set tings Con fig u ra tion

1. Task button attribute:  Used to Disable or Enable the Task Bar window.  The position field
determines if the buttons on the window are located on the Left or Right on the HMI screen.
When the Task Bar is enabled, it allows access to the Fast Selection window.  The
background color and text alignment can also be configured.  For more information on the
Fast Selection window, consult Chapter 4 - Creating Windows.

2. Alarm Bar Pixels per Scroll:  Selects the number of pixels that the text on the Alarm bar
scrolls to the left on each scroll.  The speed of the scroll can also be controlled.

3. No. of Windows: Selects the maximum number of pop-up windows that can be displayed
simultaneously.  The default value is 6.  The options are 2-6.

4. Password:  Used to set the numeric password that prevents unauthorized uploading of a
project.  To disable Password protection, set the password to 0.  This is the default value.
By using this feature, the HMI programmer can prevent another person from using Ezware to
upload a project that is stored in the HMI and download it to another HMI.
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� To Use Password Protection

1. Once the project is downloaded to the HMI, the password becomes active.

2. When you try to upload the project from the HMI to your computer, EasyManager will
prompt you to enter a password.  If the password is entered correctly, then EasyManager
uploads the project file.  If the password is incorrect, then an error message appears and the
upload process is halted.

• Startup Win dow No.:   Used to select which screen will be dis played when the HMI is pow ered up 
or re set.  The default set ting is the initial win dow that is created with each new pro ject (Window
#10).  The startup window must be a full-sized window.

• Backlight saver:  Al lows the ability to shut off the HMI’s backlight.   The num ber of minutes of
inactivity that the HMI will al low be fore the backlight is shut off can be pro grammed here.  Set ting
the value  to 0 dis ables the backlight saver.  The backlight saver is dis abled when the HMI op erator
touches the screen.

� When the backlight is off, any touch of the HMI screen will only activate the backlight,
even if the operator presses an active object such as a function key.  Once the backlight
is on, then the active object will respond to additional key presses.

• The backlight can also be activated by using the PLC Control Object.  For more information on
this feature, see PLC Control Object.

• Cursor color: Sets the color of the cursor during a data entry operation.

• Buzzer:  Enables or disables the HMI’s buzzer.  By default, the HMI sounds a key clock every time
the HMI operator touches the screen where an active touch screen object resides.  To disable the
buzzer, select disable on the pull down menu.

• Pop-up window: Determines how a pop-up window will behave when placed on  a Common
window.

• Nor mal: The pop-up window is displayed when called, and any sub sequent windows will be
placed in front of it.

• Above Any Oth ers: The pop-up window is displayed when called and re mains in front re -
gardless of other sub sequent windows dis played.

• Attribute:  Determines how the common window is drawn.

• Below Base Screen: The base window is placed in front of the com mon win dow, so the com-
mon win dow ap pears be hind the base win dow.

• Above Base Screen: The base window is placed be hind the com mon win dow, so the com mon
window ap pears in the front of the base win dow.

• Extra No. of Events: Specifies how many extra events may be placed in the Event Log, beyond
the default limit of 200 events.  For more information on the Event Log feature, see Chapter 11 -
Capturing Alarms and Events.

• RTC Source: Selects whether the HMI Local Words or its own internal RTC are used for
displaying time and date information.  The real-time clock is battery-backed with a rechargeable
battery.  In the absence of power, the battery will retain the clock settings for approximately  six
months.  The battery is automatically recharged whenever the HMI is operating, and has a life of
approximately five years.

• When In ter nal RTC is se lected, the time and date in formation is available to the HMI through
certain re served words in the HMI’s rec ipe area.  These ad dresses can be read from or writ ten
to us ing any of the HMI ob jects that are word-based, such as Nu meric Data, Nu meric En try,
Word Lamp and Set Word.  Note that Data Type is BCD.

• When Lo cal Word is se lected,  use the Data Trans fer Ob ject to send the PLC’s in ternal RTC
to the HMI’s Lo cal Words.  For more information on the HMI’s reserved Lo cal Words, see the 
sec tion Using In ter nal Data Mem ory of HMI.

• Print:  Allows configuration of several settings when using the printing capabilities of the HMI. 
For more information, see Chapter 15 - Using a Printer with the HMI530/550.
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• Message Board Window No.: Allows selection of the number of the base window which will be
used as the message board.  A setting of 0 disables the message board.  Use a number of 10 or higher
for this setting.  For more information on configuring a message board, see Chapter 5 - Creating
Windows.

In di ca tor Set tings Con fig u ra tion

The indicator tab is used to configure different parameters associated with the task bar.  The task bar contains three
optional indicators; Touch, CPU and Alarm.

The Touch Indicator

• Attribute: Enables or disables the touch indicator.

• Non-configured area:  Sets the background color of the touch indicator when a non-configured
area on the touch screen is touched.

• Inactive area: Sets the background color of the touch indicator when an inactive area on the
touchscreen is touched.   An inactive area is an area that contains a touchable object that is currently
disabled.
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• Active area:  Sets the background color of the touch indicator when an active area on the
touchscreen is touched.  An active area is an area that contains a touchable object.

• Frame:  Sets the color of the circle containing the touch indicator.

The CPU Indicator

• Attribute: Enables or disables the CPU indicator.

• Color: Sets the color of the CPU indicator.

The Alarm Indicator

• Attribute: Enables or disables the alarm indicator.

• Color: Sets the color of the alarm indicator.

��For more information on the task bar, consult Chapter 5 - Creating Windows
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Se cu rity Set tings Con fig u ra tion

The Security tab is used to configure the security features in the HMI.  The HMI supports three levels of security.
The security features apply only to base windows.  Pop-up windows or objects on the screens do not support
security.
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• Security Control: Enables  the HMI’s security features.  The three password fields are not visible
if the box is not checked.

• Password Level 0 is used to enter the numeric password for access to level 0 (the lowest) security.
Level 0 is the default security level.  This field is not visible if the security control box is
unchecked.

• Password Level 1 is used to enter the numeric password for access to level 1 (the middle) security .
This field is not visible if the security control box is unchecked.

• Password Level 2 is used to enter the numeric password for access to level 2 (the highest) security .
This field is not visible if the security control box is unchecked.

� For more information on windows security, consult Chapter 5 - Creating Windows

Ed i tor Set tings Con fig u ra tion
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• Beginning Window No: Indicates what window-0 number EasyBuilder will start using when
numbering windows.  When the project is first created in EasyBuilder, the software automatically
creates a beginning window.  EasyBuilder can be set to start numbering windows that are created,
starting with the initial window at either 10 or 1.  The default and recommended setting is to start at
10.

• Compiler Level:  Used to set the compiler warning level.  Before a project can be downloaded to
the HMI, the project has to be saved and compiled.  EasyBuilder can generate two levels of
compiler messages.  Level 0 is the minimum level and generates only error messages.  Level 1 is the
highest level, and generates both error and warning messages regarding part and PLC address size
mismatch.  Level 0 is the default setting.

• The Part Layout setting allows you to control the level on which objects are displayed during
runtime.  The Control  setting causes the HMI to bring objects to the top layer when the object is
updated.  The Nature setting causes the HMI to leave the objects on the layer in which they were
placed during development.

• Address Mode : Allows the HMI to access more than one PLC.  Select extended when connecting
to multiple PLCs.  Select standard if connecting to one PLC only.  For more information on this
feature, see Networking Multiple Controllers Using Modbus RTU Extended V3 Protocol at the end
of this chapter.

1010-1001a, Rev 01

78 Sil ver Se ries In stal la tion & Op er a tion Man ual



Hard ware Set tings Con fig u ra tion

• TFT PCD value: Used to adjust the refresh rate of the TFT display.  (This option applies only to
the HMIs with TFT LCD display type.)  This option allows you to select high or low refresh rate.
We recommend using the high refresh setting.

• Display mode:  Used to select the HMI’s display mode.  The two options are landscape and
portrait. The default is landscape.

• Eventlog database: Enables storing of the event log data in part of the recipe module’s
non-volatile storage.

• DataBase start address: The starting RW address in which Eventlog data is stored.  When the
memory is full, new Eventlog data is written to this address, overwriting the existing data.

• System Parameter: Enables storing of System Parameters in part of the recipe module’s
non-volatile storage.  Data from the General, PLC and Security tabs of the System Parameters
dialog can be stored.  When this feature is enabled, the HMI reads the data from the non-volatile
memory when the HMI is powered up or reset.  At runtime, any of these parameters can be
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modified with standard objects that write data to the appropriate recipe address.  The new values
take effect when the HMI is reset.

Aux Set tings Con fig u ra tion

The Aux tab is used to configure the Aux port.

� For more information on this feature, see Using the Aux Port at the end of this chapter.

PLC Block Pack

This feature allows the HMI programmer to enhance the update rate of data received from the PLC when the PLC
registers displayed on a screen are ‘blocked’ close together. The default setting is 0.  This means that the HMI sends
a command to the PLC requesting data for each register that is displayed on screen.  For instance, if you have five
data fields configured on the HMI to monitor %R1, %R2, %R3, %R4, and %R5 of a GE PLC, then the HMI sends
five separate commands to the PLC to update these fields.

1010-1001a, Rev 01

80 Sil ver Se ries In stal la tion & Op er a tion Man ual



This is the slowest method of updating the registers, but it does have the advantage that the update rate does not
depend on having the PLC registers all together, (R1-R5).  In other words, if monitoring %R1, %R10, %R65,
%R156, and %R2048, the update rate would be exactly the same as monitoring %R1-%R5.

The “PLC block pack” feature allows you to take advantage of any groups or ‘blocks’ of registers that allow the
HMI to send a smaller number of update commands to the PLC to get the information needed.  The HMI will
request data for up to 32 contiguous PLC registers depending upon the PLC block pack setting and the addresses of
the PLC registers monitored on screen.  The PLC block pack # represents the maximum number of  ‘skips’ between
registers allowed before the HMI considers a PLC register to be part of a different block.

For example, suppose we wish to monitor the following 7 PLC registers on one screen: %R1, %R2, %R4, %R7,
%R12, %R14 and %R100.If PLC block pack is set to 0, the HMI sends seven separate commands to get the data.  If
PLC block pack is set to 1, the HMI checks the spacing between requested registers.  If the spacing is more than 1,
then a separate command is sent.  In this example, the HMI sends four commands- one command to read R1, R2,
and R4; one command to read %R7, one command to read %R12 and %R14, and one command to read %R100.

With most PLC protocol drivers, more time is spent with ‘overhead’ data than getting the actual data that you need.
With the example above, setting the block pack number to 1 probably reduces the time required to update the PLC
data by as much as 40%!  So properly setting the PLC block pack can have a major impact on the update rate of the
HMI.

If the PLC block pack setting were adjusted to 4 or greater, the HMI sends only two commands- one command to
read %R1, %R2, %R4, %R7, and %R12; and another command to get %R100.  The update rate is now probably
three times as fast! 

You might think that the best setting is 10 so why not have the PLC block pack always on 10?  However, in some
situations, a setting of 10 may actually slow down the update rate.  For example, if the PLC registers displayed on
the screen are actually %R1, %R10, and %R40 with the PLC block pack is set to 10, the HMI will send two
commands: one to get %R1 and %R10, another to get %R40.  If the PLC block pack were set to 0, then the HMI
would have sent three commands.  In this case, however, the three commands probably take less time than the two
commands because the HMI has to receive data for ten registers (%R1-%R10) in one command takes more time
than the overhead associated with two commands.  Therefore, you should experiment with this setting if you find
that the update rate is longer than you would like.

Now that you know your way around EZware-500 and its various applications, it is time to start creating your own
project.  The next seven chapters show you in detail, all of the features that you can use to create a user-friendly
touch screen graphics operator interface terminal.  Along the way, we will attempt to provide you with clear
definitions of each feature and, if necessary, some additional examples of how each feature might be used.

Restart the HMI Au tomatically af ter a Pro ject is Down loaded

EasyBuilder can automatically start the application that was just downloaded.

�To enable automatic restarting of the HMI

1. From the Option menu, select Window Property.  The Window Property dialog box is
displayed.

2. Check the Jump To Application When Download Done checkbox..

3. Click OK to exit the Window Property dialog box.

Automatically Save and Com pile the Pro ject

EasyBuilder can automatically save and compile the project when downloading or simulating.

�To enable automatic save and compile

1. From the Option menu, select Window Property.  The Window Property dialog box is
displayed.

2. Check the Automatic Save And Compile At Download And Simulate checkbox.

3. Click OK to exit the Window Property dialog box.
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Com pact Flash

Compact Flash (CF) cards enable one to download an EZware project from a PC to a compact flash card, and then
put that card into the HMI, and download the project to the HMI.  This eliminates the need for a laptop or PC at the
installed HMI’s location, and makes downloading the same project to multiple HMIs simple.

Any CF Type1 flash card may be used that has been formatted for the FAT format, and has a memory size equal to
or greater than 64MB.

�To store the file from the PC to the Compact Flash Card:

1. Open ImageCF.exe (located in the EZware folder).  The following screen will appear.

2. Press the magnifying glass to browse for your project’s .eob file.  Press open, and
ImageCF.exe automatically converts the *.eob file to an “ImageCF.bin” file which will create
itself in your EZware directory.

3. Copy the ImageCF.bin file to the Compact Flash card.  (Using Windows Explorer, drag the
ImageCF.bin onto your Compact Flash Reader device.)

4. Insert the Compact Flash card into an HMI.

5. Find the Dip Switches on the back of the HMI.  Set Dip Switch 2 “On,” then push the Reset
button (or cycle power). The HMI will show some text and at the bottom right side of the
screen a green button will appear.  Press the green button and the HMI will load the project
from the Compact Flash Card and automatically reboot to application mode.

� Dip Switch 2 on the back of the HMI should be moved back to the “Off” position after
the  project has downloaded.

Connecting Mul ti ple HMIs to one PLC

Most of the PLCs on the market communicate to HMIs using a master/slave format.  The PLC typically behaves as
the slave responding to requests from the HMI for data and not initiating any communications.  Therefore, the HMI
must continuously poll the PLC for data needed.  Some of the PLC protocols do not allow multiple master devices
(HMIs) to connect to the PLC.  If you want to connect two or more HMIs to a PLC, you often need to purchase
multiple communications modules for the PLC, which can be very expensive.

To address this need, the Silver Series has a built-in feature which allows multiple HMIs to connect together in a
daisy-chain fashion.  One of the HMIs is designated as the ‘master’ while the other HMIs are defined as ‘slaves’.
The master HMI is directly connected to the PLC communications port.  Each slave HMI then communicates
through the master HMI to get data from the PLC.

No additional communications modules are required.  This feature provides an effective and inexpensive way to
connect multiple HMIs to a single PLC.

Hard ware Con nec tion

As stated above, the HMIs are connected in a daisy-chain fashion using RS232 communications.  This means that
you can have a maximum of 50 feet distance between HMIs.  Also, because connection uses a daisy-chain method,
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if one of the HMIs loses power all other HMIs further down the chain will be unable to communicate to the PLC.
The HMIs are wired together in the following fashion:

Soft ware Con nec tion

You must configure the HMI that connects to the PLC as the master.  All other HMIs should be configured as slave
HMIs.

� To configure the Master HMI
1. Click the Edit menu on the main screen of EasyBuilder.

2. At the bottom of the menu, click System Parameters.  The Set System Parameters dialog box
appears.

3. The dialog box has three tabs: PLC, General, and Indicator.  Select the PLC tab.

4. Select Master from the Multiple HMI box.

5. Select either 38400 or 115200 for the HMI-HMI link speed.  Make sure this setting matches
the settings for the slave HMIs.

6. Select a unique station number in the HMI station no. box.

7. Click OK to save the System Parameters settings and return to the main screen of
EasyBuilder.

�To configure the Slave HMI
1. Click the Edit menu on the main screen of EasyBuilder.

2. At the bottom of the menu, click System Parameters.  The Set System Parameters dialog box
appears.

3. The dialog box has three tabs: PLC, General, and Indicator.  Select the PLC tab.

4. Select Slave from the Multiple HMI box.

5. Select either 38400 or 115200 for the HMI-HMI link speed.  Make sure this setting matches
the setting for the master HMI.

6. Select a unique station number in the HMI station no. box for each slave HMI.

7. Click OK to save the System Parameters settings and return to the main screen of
EasyBuilder.

Sharing Data Be tween the Master HMI and Slave HMI

Each HMI can be programmed to access data from the PLC as though it were the only HMI connected to the PLC.
The master HMI will poll each slave HMI connected and allows each HMI to retrieve data from the PLC.  You can
also exchange data between the slave HMIs and the master HMI.  Any local word registers (LW) or local bits (LB)
located in the master HMI can be accessed and written to by the slave HMIs. Do this by using the Ms_LW and
Ms_LB memory registers.  For example, if the master HMI is storing data in LW10, the slave HMI can access that
data by using Ms_LW10.
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If the slave HMIs and the master HMI are both accessing the same areas of memory in the PLC, it becomes more
efficient to program the master HMI to access the PLC memory than create a Data Transfer Object to copy the PLC
data to LW and LB registers inside the master HMI.  The slave HMIs can then access the PLC data by using the
Ms_LW and Ms_LB registers.  The biggest bottleneck in communications is trying to get all of the needed data
from the PLC.  By doing this, you greatly reduce the amount of time required to get the information from the PLC.

Connecting Multiple HMIs Using the Ethernet Port

The Silver Series HMIs are equipped with Ethernet ports.  One, or several HMIs can be connected to a PLC that
uses the Modbus TCP/IP protocol.  A single HMI may be directly connected to the PLC Ethernet port via a
crossover Ethernet cable, or multiple Master HMIs may be connected to a PLC using an Ethernet switch and
standard Ethernet cabling.  Each slave HMI can communicate through the master HMI to get data from Master HMI
local memory and the PLC.  No additional communications modules (other than possible network infrastructure
such as routers, hubs and switches) are required, providing an effective an inexpensive way to connect multiple
HMIs to a single PLC.

The PLC must use a Modbus TCP/IP protocol driver if it is to be connected to the HMI Ethernet port.  PLCs that use 
other protocols such as Industrial Ethernet or AB Ethernet IP are not supported by the Silver Series touchscreens.
Only Modbus TCP/IP is supported.

Hard ware Con nec tions

There are several wiring scenarios for connecting HMI touchscreens to a PLC.  Most depend upon individual needs.

The simplest connection (with example network IP addresses) is a point-to-point connection, such as the one
illustrated below:

This allows one HMI touchscreen to be the master and the PLC to act as the slave device.  Only one PLC can be
addressed in this type of configuration.

Multiple PLCs

If more than one PLC is to be addressed by a single HMI, use the HMI RS485 port and use the Modbus RTU
Extend V3 protocol.  One slave HMI may be connected to the master via a crossover Ethernet cable or several Slave 
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HMIs may be connected to the master using an Ethernet switch or hub device.  If a hub is used, use standard
Ethernet cabling and connect the HMI master cable into the UPLINK port.

To configure the scenario above , select "Modbus RTU Extend V3" for the PLC type.  PLC I/F should be RS485
default.  Select Multiple HMI (Master/Slave) and connect Ethernet.  Under the {Editor} tab of the system
parameters, select Address Mode: Extended.

Multiple HMI Masters

If several HMIs need to be connected to one PLC and the HMIs need to be independent of one another (each can be
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disconnected without interrupting the other), then they can be connected as individual master devices using an
Ethernet switch, as illustrated below:

This configuration can only support one PLC, and all master HMIs must use the same protocol and the same server
address for the PLC.  A master HMi will not be able to see local memory or status of any other master HMI.  A
slave HMI can be connected to monitor/control a specific HMI master.  A slave can control and view the internal
memory and status of a master HMI.

If a router is to be used for connecting to a different network, then enter the router IP address and configure the
router to address the PLC on its network.  See the illustration below:
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Soft ware Con fig u ra tion

In the Edit-System Parameters -{PLC} tab, configure as follows:

You must configure the HMI that connects to the PLC as the master.  All other HMIs should be configured as slave
HMIs, unless an Ethernet switch is used, in which case the HMIs may all be masters with separate local IP
addresses, and all have the same Server (PLC) address.

�To configure Master HMIs to talk with a PLC over the Ethernet port:

1. Click on Edit-System Parameters and select the {PLC} tab.

2. Select PLC Type as Modbus RTU TCP/IP.

3. Select PLC I/F port as Ethernet.
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4. For the multiple HMI box, select Disable if there are no slave HMIs.  Select Master if any
HMI is to be a slave unit, and, if so, select Ethernet for Connect I/F.

5. Select a unique IP Address in the Local IP Address: boxes.

6. Enter in the IP Address for the PLC in the Server IP Address: boxes.  Note: Whatever the
network addresses are, the numbers (octets) in the first three boxes must match for the Local
IP and the Server IP.

7. Enter 255.255.255.0 for the Subnetwork Mask.

8. If there is a router that will be between the HMI and the PLC, enter the router IP address in
the Default Route IP address section.

�To configure the Slave HMI if there is an Ethernet connected Slave HMI Unit:

1. Click Edit-System parameters and select the PLC tab.

2. Select PLC Type as Modbus RTU TCP/IP.

3. Select PLC I/F port as Ethernet.

4. For the Multiple HMI box, select Enable.

5. Select Slave from the Multiple HMI box.

6. Select Ethernet for the Connect I/F.

7. Select a unique station number in the HMI station no. box for each slave HMI, and click OK.

Sharing Data be tween the Master HMI, Slave HMI and PLC

Master HMI to a PLC

The master HMI will be programmed just as if it were the only HMI connected to the PLC.

Slave HMI to a Mas ter HMI

Any local word registers (LW) or local bits (LB) located in the master HMI can be accessed (read) and written to
(write) by the slave HMIs.  Do this by using the "Ms_LW" and "Ms_LB" memory registers.  For example, if the
master HMI is storing data in LW10, the slave HMI can access that data by using a device type: Ms_LW and device
address: 10.  Multiple HMI is set to Master.  Connect I/F is set to Ethernet.

Slave HMI to the PLC

The slave HMIs may access data in the PLC in two ways:

1. It may write to the local words/bits in the master HMI (via Ms_LW and Ms_LB registers),
and those values may be transferred to the PLC by setting up a data transfer object in the
master HMI program.  Note: If the master and the slave HMIs are accessing the same areas of 
memory in the PLC, this method is more efficient because the time required to get
information from the PLC is reduced.

2. It may read/write directly to the PLC addresses (as though it were the only HMI connected to
the PLC).  Note: This method may result in inconsistent Master/Slave communications.
Maple Systems recommends using method #1.

Networking Multiple Controllers

The Silver Series provides capability of accessing data in multiple controllers from a single master station.  The
Silver Series can address each object to its respective controller node, giving operators the ability to seamlessly
interact with an entire multi-drop network without changing either screen or station numbers.  This allows the
information to be organized in the most logical way rather than being clumped by controller address, which may not
be anywhere near ideal for the operator.  In addition, directly accessing the necessary data from each controller
eliminates the need to use a data concentrator PLC to present a single point of access.  With the inherent noise
immunity and line-length capability of RS485, you can view information and control equipment from anywhere in
the plant at one convenient location.

Operators can access up to 16 slave controllers by setting the Address Mode in the System
Parameter-Setting-Editor dialog box to Extended.  Each object on the HMI is given a slave address, delineated by
a # sign, followed by the register address.
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�To configure a Bit Lamp object using Extended Addressing:
1. From the Parts menu, click Bit Lamp.  The Create Bit Lamp Dialog appears.

2. In the Read address frame, select the PLC coil.  For Device address, enter the PLC node
address followed by a # sign and the register address.  For this example, the PLC node=1 and 
the register address=100.

The system may be wired with either a 2-wire or 4-wire cabling scheme, with a single signal return wire in either
case.  This is selected in the System Parameter Setting dialog on the General tab.

In genera, a 4-wire system is preferred, since it prevents the possibility of the Master (HMI) and the Slave
(controller) units interfering with each others' transmissions.  There is a user-adjustable polling delay.

��To set the user-adjustable polling delay:

1. Select Edit-System Parameters from the main menu.  The System Parameter Setting dialog
appears.

2. Select the PLC tab.

3. For Parameter 1, enter a value between 1-999 (mSec).

4. It is best to start with a large delay until communication is established with all of the slave
controllers, then decrease it until a minimum reliable setting is reached.  This is especially
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true of 2-wire configurations, as the HMI may reissue a command if the reply is not processed
quickly enough.

5.  For PLC I/F port, select RS485 4W or RS485 2W.

Man ag ing Com mu ni ca tion Fail ures

When communicating with multiple devices over a network, it is possible that one or more of the devices may fail
without affecting other devices on the network.  When this happens, plant personnel may need to be notified of the
failure, while still maintaining communications with the rest of the network.

Starting in EasyBuilder v 2.60, communications failures to any node can be managed by the HMI.  A series of local
bits monitor and control communications failures on both the main and auxiliary communications ports.

Bits PLC Node

LB9100-9227 Main port nodes 0-127

LB9228-9355 Aux port nodes 0-127

When a communications failure is detected on a particular PLC node address, the corresponding local bit will be
turned off, and communication to that node address is suspended.  To restart communications to that node, the bit
must be turned back on.

Using the Aux Port

HMI generation 6 (marked-006) models are now equipped with a secondary Aux port for both RS-232 and RS-485
communications.  This aux port can be used to operate a secondary PLC.  To use the aux port correctly, the user
must upgrade their EasyBuilder software to version 2.6.0 or higher.  The setup screen for the aux port can be found
as a tab option under the Edit-System Parameters menu selection.

PLC [RS-232] and PLC [RS-485] + AUX [RS-485] Port

Pin Designations

Pin assignment of the 9-pin, female Sub-D, PLC [RS-232] Port

Pin # Symbol PLC [RS-232]
AUX [RS-232]
only -006 Series

1 Aux_TxD Transmitted Data

2 TxD Transmitted Data

3 RxD Received Data

4 Not used

5 GND Signal Ground

6 Aux_RxD Received Data

7 CTS Clear to send input

8 RTS Ready to send output

9 Not used
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Pin assignment of the 9-pin, male Sub-D PC [RS-232] and PLC [RS-485] Port

Pin # Symbol
PLC [RS-485]
4-wire main port

PLC [RS-485]
2-wire main port

AUX [RS-485]
(only -006 series)

PC [RS-232]

1 Rx- Receiver (-) Xcver_Data (-)

2 Rx+ Receiver (+) Xcver_Data (+)

3 Tx- Transmitter (-)

4 Tx+ Transmitter (+)

5 GND Signal Ground

6 Aux_Data- Xcver_Data (-)

7 PC_TxD Transmitted Data

8 PC_RxD Received Data

9 Aux_Data+ Xcver_Data (+)
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In version 2.6.2, set in Edit-System Parameters-{Aux} tab dialog set the Aux port driver (Aux type) and
communications parameter.
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�To set up the Aux I/F port parameters

1. Select the Aux Port driver.�Currently, it only supports the Animatics SMC v. 1.00, Baldor
MINT v. 1.03, and the Modbus RTU Extend [AUX v. 3.00] protocols.

2. Select the hardware port to use for auxiliary communications.�(RS232 port - full duplex,
RS-485 - half duplex.

3. Select the Aux port communications timing parameters.  Set the communications parameters
to match your PLC.

4. Set Data bits, Stop bits, Baud rate and Parity. These must match your PLC settings.

5.  Set parameters 1-6, which are dependent on the individual driver selected.

a.  For Modbus RTU Extend V3 [AUX] protocol:

• Pa ram e ter 1: Not used.

• Pa ram e ter 2: Turn Around De lay (n*mS): This set ting is used to add some de lay for
RS485 (half-duplex) com munications.  The num ber en tered is the extra wait time (in 10 mS
increments) that the HMI adds be fore it transmits a re try on the bus. (Range: 0-1000).  If
RS232 is se lected as the I/F port, then this pa ram e ter is ignored.

• Pa ram e ter 3-6: Not used.

� To set Aux ID and general parameters

1. Set Aux station.  This is used when the Aux device has a node or station identifier.  The HMI
needs the station number to initiate communications.  Set as needed or leave at 0 if not used.
Station numbers are 0-127 (use the range as appropriate for PLC type.)  If the Extended
address mode* is selected, the HMI will ignore the aux station setting.

2. Set Aux timeout constant. This setting determines how long (in seconds) the HMI will wait
for a response from the Aux device.  The range is from 0 to 127 seconds.

3. Set Aux block pack. This is used to determine how the unit will communicate (register
polling) to the Aux device.  By increasing this number, larger blocks of registers can be
fetched from the Aux device by issuing one command for a block of registers instead of a
command for each individual register.  In some cases, this speeds the update of information
on the display, but in other cases it may cause unwanted delays.  Experiment with this number
to optimize.

*� Extended address mode: When more than one aux device is connected on a RS485
bus, select the Extended address mode in the Editor tab of the System Parameter
Setting. Then use the extended addressing format for all object addresses (i.e. 4x: 2#1
=Modbus address 40001 for node #2).
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�To enter a read or write address for the Aux port

When Entering in data register types and address using the extended mode to be used by the Aux port device, select
the Aux. check box first, then add the address in the extended mode format [node address]#[address].
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Chapter 5 - Creating Windows

This section shows how to create windows using EasyBuilder.  To better illustrate some of the examples, please
open the sample project (HMI520M.EPJ, HMI520C.EPJ, HMI520T.EPJ, HMI530C.EPJ, HMI530T.EPJ or
HMI550H.EPJ) included with the EZware-500 configuration software.

Win dows Fun da men tals

An operator interface terminal wouldn’t be very useful if all of the information to be displayed could only be placed
onto one screen.  Therefore, most HMIs have multiple screens that you can use to display information.  The Maple
Systems Silver Series is capable of storing up to 1999 windows (actual limit is determined by memory requirements
of each screen), giving you maximum flexibility in designing your operator interface.  We prefer to call these
screens ‘windows’ because they have several features not normally associated with screens:

• Windows can be created in any size.  You can make the window full-sized so that it fits the entire
area of the HMI display or you can create a window that partially covers the display.

• Windows can be overlaid on top of each other.  A maximum of six windows can be displayed on the
HMI at any given time.  All data on each window displayed is updated continuously regardless of
whether or not it is covered up by another window.

• Windows can be easily moved about the HMI display to allow portions of other windows to come
into view.

• Windows can be minimized to an icon on the bottom of the HMI display.  This feature allows the
plant floor operator to minimize windows that contain data (such as numeric keys) which don’t
need to be seen all the time and yet must be readily available.

The Silver Series has three basic types of windows available for use:  Base windows, a Common window, and a Fast
Selection window.  Base windows are the windows that you will most often use.  The common window and fast
selection window are two windows reserved for special functions.  By the end of this chapter, you should be able to
create these windows and use the many features available to them.

Opening a Win dow

To view the contents of a window in EasyBuilder, it must first be opened.  When you create or open an existing
project file only the initial window is opened.  To view any other windows that have already been created, you must
first open the window. This can be done using the Window Treebar (see Chapter 3, “Using EZware-500”, Display
Options) or by performing the following:

�To open a window

1. From the Window menu, select Open Window.  The Open Window dialog box appears.

2. Click on the Window you wish to open.  Then click Open.  Note: you can also open the
window by  double-clicking the window.

3. The Open Window dialog box closes and the opened window is displayed in the EasyBuilder
work area. 
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Let’s look at the Open Window dialog box again using the sample project.

The Open Window dialog box lists all of the windows currently created for the project.  You will notice that in the
sample project, three windows have been created: 10, 11, and 12.  The asterisk next to Window #10 indicates that
this window has already been opened.  Each window is listed with the Window name and size.  The window name
is the name that you assign to the window when it is created.  The window size is shown for quick reference.
Finally, you will notice that the Open Window dialog box is also used to create a new window, change any of the
settings for a window, or delete a window.  Press the Close command button to return to the main EasyBuilder
screen.

By default, when a window is opened it will replace any window that was displayed in the work area of
EasyBuilder.  To switch between open windows, click the Window menu and select from the list of windows
currently open.  You can also cascade or tile the open windows to see the windows at the same time.

EasyBuilder requires more resources from your computer every time you open another window.  When many
windows are open, the performance of the computer may be affected.  Therefore, you may wish to close some of the
windows until you need to edit them.

�To close a window

1. You will notice three small icons located in the upper right hand corner of each window: the

minimize icon  , the maximize icon            , and the close icon   .  To close

a window,  click  the close icon associated with that window .

These icons show in the window if minimized.  Otherwise, the icons are located on the rightmost end of the menu
bar of EasyBuilder.

Creating a New Window

Whenever you create a new project, the initial window (Window #10), the fast selection window (Window #4), the
common window (Window #6), and the numeric keypad window (Window #50) are automatically created.  To
create a new window, the following steps must be performed.
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�To create a new window

1. From the Window menu, select Open Window.  The Open Window dialog box appears.

2. Click New Window.  The Select Window Style dialog box appears.

3. Click Base Window. The Fast Selection and Common Window buttons appear grayed out
because those windows have already been created.  The Window Setting dialog box appears.

4. Modify the window parameters, then press OK.  The Open Window dialog box reappears.

5. If you wish to open the window you just created,  click on the window and click Open.
Otherwise, click Close to return to the main screen of EasyBuilder.

Win dow Set tings

Let’s look more closely at the parameters you can change when creating a new window.
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� When a window is initially created, the window settings can be edited to make
changes; however, once a window has been created, the window number can not be
changed.  To change the window settings, highlight the desired window and click on the 
Setting... button.

Assigning a Window Name

The Name is a description box used to help you identify what the window is used for without having to actually
open the window and look at the contents.  Up to 50 characters can be entered into this field with space characters
allowed.

Assigning the Window Number

Although 1999 windows are available on the Silver Series, two are specifically reserved for the Common Window
and the Fast Selection window and another eight are reserved for internal use.   Therefore, you can assign #10-255
to any window you create.  When you initially create a window, EasyBuilder will automatically assign the lowest
available number to the window.  However, you can assign any number within the allowed range.  In this manner,
you can group windows together that may share some common traits.
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Assigning a Position

This is the starting position that the window goes to when it is initially called onto the HMI screen.  The starting
position is labeled Start Pos: in the Window Setting Dialog box.  The X and Y positions refer to the pixel location of 
the HMI display at which the upper left hand corner of the window is to be displayed.

The default setting is X=0 and Y=0 which is the upper left hand corner of the HMI display.  The X-axis refers to the
horizontal location and the Y-axis refers to the vertical location.  The HMI520C  has a 320 x 240 ( HMI520T is 320
x 234)  pixel display, so the ranges are X=0-319 and Y=0-239.  The HMI530/550 has a 640 x 480 pixel display, so
the ranges are X=0-639 and Y=0-479.

Assigning Size of Window

You can vary the size of a new window to create full screen or popup windows.  Popup windows are most often
used to display data that does not need to be on the HMI display all the time.  For example, you might want to
configure a numeric keypad in one popup window that can be minimized to an icon when not needed.  To use the
numeric keypad, just maximize the popup window.  The allowable range for the width is 100-320 (640 for the
HMI530/550) pixels.  The allowable range for the height is 100-240 (234 for the HMI520T, 480 for the
HMI530/550) pixels.

Win dow Styles

There are several options that can be assigned to each window created that affect how it operates with other popup
windows.

Tracking Feature

The tracking feature causes any popup window that was called from another popup window to move when the first
popup window is moved.  Think of a ‘parent/child’ relationship in which the calling popup window is the parent and 
the called popup window is the child.  Any place that the parent window moves, the child window follows.  This
includes maximizing and minimizing the windows into an icon.  If tracking is enabled and the parent window is
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minimized to an icon, then the child window is automatically minimized at the same time.  For example, suppose
that the HMI displays the following:

Then popup window #12 is displayed:
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We then use the function key on popup window #12 to display popup window #13.

If window #13 has the tracking feature enabled, then moving window #12 (the parent) will cause window #13 (the
child) to move as well.  This is because window #13 was ‘called’ from an object on window #12.

The tracking feature is often used in instances in which you want to make it very clear that the information on one
window (the child) always pertains to another window (the parent).
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Monopoly Feature

The monopoly feature is used to ‘monopolize’ all touch screen action that can occur on the HMI screen.  For
instance,  suppose the HMI display is currently showing a full screen window with several touch screen objects.

If a popup window is displayed which does not have the monopoly feature enabled, the HMI operator is able to
press any function keys on the popup window or the full screen window since objects on both screens are active.

In this example, the HMI operator is able to press Key1-3 on the full screen window or the switch on Popup
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Window#21.  If another popup window is displayed that does have the monopoly feature enabled, then Key1-3 on
the full screen window will not respond when pressed.

Please note that the monopoly feature only disables touch screen objects on the full screen window.  The switch on
Popup Window#21 can still be activated, as can any popup window displayed on the full screen.

The monopoly feature can be used to display a popup window with some action that the HMI operator must perform
before being allowed to do some other action on the HMI.  For example, you might construct a dialog box that asks
the HMI operator if some step in the control process has been performed.  The dialog box would have Yes and No
function key options which, with the monopoly feature enabled, the HMI operator must press before continuing.

Clipping Feature

With clipping enabled, any portion of a child window that lies outside the boundary of the parent window is
‘clipped’ or not displayed on the HMI screen.  The tracking feature must be enabled when the clipping option is
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used.  For this example, let’s look at an HMI screen in which Popup Window#13 is a child window that was called
by an object in Popup Window#12, the parent window.

Without clipping, if we move Window#13 so that a portion of the window is out of the area covered by
Window#12, then the entire area of Window#13 is still shown on the HMI screen.
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With clipping enabled on Window#13, the same move would cut off part of Window#13.

Like the tracking feature, clipping is most often used to reinforce the notion that one window is tied to the operation
of another window.

Coherence Feature

Normally, when a popup window is displayed on the HMI screen, it covers all other windows that are currently
displayed on screen.  The coherence feature causes the popup window to be displayed underneath all other windows 
currently displayed.  In other words, the coherence feature makes that window subordinate to all other windows.
When the coherence feature is applied to a popup window, you will see the entire popup window only if there are no 
other popup windows taking up the same area.

The coherence feature only works if the popup window that has this feature enabled, is called from a full screen
base window.  If the popup window (child) is called from another popup window (parent), then the child window
will appear above the parent even with the coherence feature enabled.
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For example, suppose that you have a full screen that calls up Popup Window #13.

If the full screen calls a popup window (with coherence disabled), it displays on the HMI screen over any other
popup windows that might occupy the same area.  In this example, the full screen calls up Popup Window #12.
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However, if Popup Window #12 had the coherence feature enabled, a different picture would have occurred.

Although Popup Window #12 was displayed after Popup Window#13, it appears behind it.  Even if the HMI
operator ‘activates’ Window #12 by touching some object on that window, it will remain behind all other popup
windows displayed.

� If two popup windows are displayed with the coherence feature enabled on both, then
the popup window that is displayed first will be the dominant window.

Coherence is most often used on popup windows that take a large area of the HMI display. When they are displayed,
they often completely cover smaller popup windows that are already on display, making it difficult to access the
covered popup windows.

Set ting the Win dow Se cu rity Level

EasyBuilder provides the ability to restrict access to window screens so that only authorized personnel can view
them. Three security levels are available: Level 0 (Lowest), Level 1 (Middle), and Level 2 (Highest).

You must perform the following three steps to use the Window Security Level feature:

1. Assign passwords to the three levels of security access.

2. Assign a security level to each of the window screens.

3. Create a Numeric Input Object that allows you to change the current access level.

�To assign Window Security Level passwords

1. From the Edit menu, select System Parameters. The Set System Parameters dialog box
appears.

2. Click the Security tab to display the Security form.

3. To enable the Window Security Level feature, check the Security Control box.
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4. The Password frame box appears showing the current passwords for the three security levels.

5. Each password can have a value of 0 (indicating no password is assigned to that level) or 1 to
4,294,967,295.  After entering a password for each level, click OK to go back to the main
screen of EasyBuilder.

These passwords must be entered by the HMI operator to gain access to any window screens that are assigned a
security level.

�To assign a security level to window screens

1. All window screens are initially configured with the lowest level security access allowing
total accessibility.  To change the level of access, you must change the window screen’s
security level in the window settings dialog box.

2. From the Window menu, select Open Window. The Open Window dialog box appears.

3. Click on the window you wish to modify, and then click the Setting command button. The
Window Setting dialog box appears.

4. In the Window Setting form, select Lowest, Middle, or Highest level from the Security
Level drop-down list box.  Click OK to return to the Open Window dialog box.

5. Click Close to return to the main screen of EasyBuilder.

�To create the ability to change window security level

1. Create a window(s) that contains a Numeric Input Object.  For more information on creating a 
Numeric Input Object, see “Representing PLC Data Registers” section in Chapter 6.

2. From the Parts menu, click Numeric Input.  The Create Numeric Input Object dialog box
appears.

3. In the Read address frame, select local word LW9040.  LW9040 is a reserved internal data
register of the HMI that is used to change the window security access level.

4. Select BIN (binary) format.  Select No. of words: as 2.

5. Click the Numeric tab to display the Numeric form.

6. In the Display attribute box, select Decimal display or, if you wish to prevent others from
seeing the password code, select Mask display.

7. Then create a numeric keypad to allow entering numbers into the Numeric Input Object, (see
Chapter 7 – Using and Creating Keypads).

Two additional local word registers are used to support the Window Security Level feature:

• LW9042 is a 16-bit Read Only register which always shows the current window security level: 0,
1, or 2.

• LW9043 is a 16-bit Read/Write register that quickly ‘forces’ the window security level to a lower
level by  entering the level number.  For instance, if the current security level is Level 2 (the highest
security level), you can move quickly from this level to Level 1 or Level 0 by entering the number 1
or 0 respectively into this register- no password is required.  This feature enables someone who has
the highest security level to switch the HMI to a lower level without having to memorize all three
passwords.

As signing Un der lay Win dows

EasyBuilder allows you to assign up to three underlay windows to any base window that you are creating.  First,
create the underlay window; then select it from the pull-down list box when you change the settings of the base
window.

How to Dis play Un derlay Win dows

When you have common objects to display on multiple screens, use the Underlay Window feature to store these on
underlay windows attached to a base window.   This decreases the amount of memory required for the project.  The
base window “calls” the underlay window.  Each full-size base window can display up to three underlay windows,
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which are called Underlay #1, Underlay #2, and Underlay #3. Objects on the underlay windows cannot be edited
from the base window on which they are displayed.

A pop-up window cannot display any underlay windows.

To assign underlay windows to a base window, you must first create the underlay windows.  Underlay windows are
created the same way base windows are created.  Then you can assign the underlay windows to the base window.

�To assign underlay windows to a base window

1. From the Window menu, select Open Window.  The Open Window dialog box appears.

2. Highlight the base window you wish to use.

3. Click the Setting command button.  The Window Setting dialog box appears.

4. Click the pull-down list box for each Underlay Window to assign the underlay window
screens to the base window.

5. Click OK.  Click Close on the Window Setting dialog box.

Rules That Ap ply to Un derlay Win dows

Please note the rules that apply when you use the underlay window feature:

• Only the objects of an underlay window are displayed on the base window.  All background
information about the underlay window (i.e. background color, frame color and size, etc.) are not
displayed on the base window.

• Active objects  can be ‘overlaid’ on top of each other over two or more underlay windows.  For
example, a Set Bit object that is configured to set an HMI local bit LB0 is located at X=20, Y=50 for
Underlay Window #1.  Another Set Bit object that controls LB1 is placed  on Underlay Window #2
at the same location.  When the Base Window displays these two windows, both objects will be
active so that when they are pressed both LB0 and LB1 will be set.

• Static objects may be overlaid using underlay windows.  However, any static object that is on the
Base Window has the highest precedence and will be displayed over any static objects that are on
the underlay windows.  Active objects have higher precedence over static objects.

• Popup windows cannot display underlay windows.

• Underlay windows are always positioned from the top left corner of the screen.  Any position
settings you make when creating the underlay window are ignored when the window is displayed
by a Base Window as an underlay window.

For more information and an example of how to use underlay windows, consult the EasyBuilder Help files.

Creating a Frame

EasyBuilder provides the option of having a frame around any window that you create.  You can select from seven
sizes: 4, 6, 8, 10, 12, 14, or 16 pixels wide.  The default setting is no frame.  If a frame is selected, you can select
one of 16 colors when using the HMI520C, HMI520T, HMI530C, HMI530T or HMI550H color HMIs or one of
four shades for the HMI520M monochrome HMI.

Win dow Back ground

You can also select a different background color for each window created.  The default setting is black.

�To select a different background color

1. From the Window menu, select Open Window.  The Open Window dialog box appears.

2. Click on the window that you wish to change the background color. Click Setting.  The
Window Setting dialog box appears.

3. In the Background frame section, check the Filled box.

4. Click the pull-down arrow of the Color box.  The Color dialog box appears.
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5. Select from one of the 16 basic colors or add 16 new colors from the customized list of colors.
To create a customized color, click on one of the boxes in the Customized color box, then
click Customize color.

6. The color table dialog box appears allowing you to select one of the 256 colors available.

7. Click OK in the Color dialog box to go back to the Window Setting dialog box.  Click Close
to return to the EasyBuilder main screen.

Instead of using a solid background color, you can select a pattern that is displayed in the background of a window.

�To select a background pattern

1. From the Window  menu, select Open Window.  The Open Window dialog box appears.

2. Click on the window that you wish to change the background pattern. Click Setting.  The
Window Setting dialog box appears.

3. In the Background frame section, check the Filled box.

4. Click the pull-down arrow of the Color box.  The Color dialog box appears.

5. Select from one of the 16 basic colors or add 16 new colors from the customized list of colors.
To create a customized color, click on one of the boxes in the Customized color box, then
click Customize color.

6. The color table dialog box appears allowing you to select one of the 256 colors available.

7. Click OK in the Color dialog box to go back to the Window Setting dialog box.

8. Click the pull-down arrow of the Pattern Color box and select a color.  Note: to use the
background pattern, the color selected for Pattern Color must be different then the color
selected for the solid color.

9. Once a pattern color is selected, click OK in the Color dialog box to go back to the Window
Setting dialog box.

10. Click the pull-down arrow of the Pattern box.  The Pattern Style dialog box appears.

11. Select the pattern you wish to use, then click OK.  The Window Setting dialog box reappears.

12. Click OK in the Color dialog box to go back to the Window Setting dialog box.  Click Close
to return to the EasyBuilder main screen.

Deleting a Win dow

�  Before any window can be deleted from a project, the window must be closed.  To close
a window, see the section earlier in this chapter on opening windows.

�To delete a window

1. From the Window menu, select Open Window.  The Open Window dialog box appears.

2. Highlight the window that you wish to delete.

3. Click the Delete command.  A dialog box appears asking if you want to delete this window.

4. Click Yes. The dialog box disappears and the selected window is deleted.

5. Click Close in the Open Window dialog box to go back to the EasyBuilder main screen.

Using Base Win dows

Of the three types of windows, base windows are the most commonly used.  A base window is used to create a full
screen window or a popup (partially sized) window.  You may have up to six popup windows on the screen at any
moment in time.  Base windows can be minimized to an icon on the task bar.  Base windows can also be moved
about on the HMI display and can overlap each other.  The number of objects that can be placed onto each base
window is limited only by the total amount of memory available within the HMI.
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How to Dis play Base Win dows

Base windows can be displayed on the HMI screen by using a function key to display the window or by using the
PLC to call up the window.

Using a Func tion Key

The Function Key Object is a graphics touch screen object that you place onto a window to perform an action.
Function keys have many purposes which are discussed in later sections, but two actions that a function key can
perform are:

• Calling a full screen window

• Calling a popup window

Calling a full screen window

If a function key object is created to call a full screen window, the window that is displayed replaces all other
windows that are on display regardless of how many are open.  Therefore, think of calling a full screen window as
performing two actions: closing any open windows and displaying a full screen window.

�To call a full screen window using a function key object

1. From the Parts menu, select Function Key.  The Create Function Key Object dialog box
appears.

2. In the General Tab, click Change Window.

3. In the same frame, enter the Window No. you want to call.

4. In the Shape tab, click on the shape or bitmap checkbox, and then click on the Shape
library or Bitmap library. Select the shape or bitmap you wish to use to represent the
function key.

5. In the Label tab, select a label for the function key.

6. Click OK to return to the main screen of EasyBuilder.

7. Place the function key object where you want it on the window you are editing.

You must select a window that is full size (320 x 240 for the HMI520C/M, 320 x 234 for the HMI520T,  640 x 480
for the HMI530/550) pixels when using the Change Window function.

Calling a popup window

If a function key object is created to call a popup window, the window that is displayed is generally overlaid over all
other windows that are on display.  Therefore, think of calling a popup window as  opening another active window
for display.  Note that the maximum number of popup windows displayed at any one time is six.

�To call a popup window using a function key object

1. From the Parts menu, select Function Key.  The Create Function Key Object dialog box
appears.

2. In the General Tab, click Popup Window.

3. In the same frame, enter the Window No. you want to call.

4. In the Shape tab, click on the shape or bitmap checkbox, then click on the Shape library or
Bitmap library. Select the shape or bitmap you wish to use to represent the function key.

5. In the Label tab, select a label for the function key.

6. Click OK to return to the main screen of EasyBuilder.

7. Place the function key object where you want it on the window you are editing.
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You must select a window that is less than full size (320 x 240 for the HMI520C/M, 320 x 234 for the HMI520T,,
640 x 480 for the HMI530/550) pixels when using the Popup Window function.

To display a full screen or popup window,  press the touch screen where the function key object is located.  The
window displays in the location on the HMI display as determined by the X and Y position in the Window Settings
box for that window.

�� For more information on using the Function Key object, see the chapter on
“Representing Data with Graphics Objects”.

Using the PLC to dis play a base win dow

Three objects are used by the PLC to call or display a base window.  The PLC Control Object is used by the PLC to
display full screen windows.  The Direct and Indirect Window Objects are used by the PLC to display popup
windows.

The PLC Control Object

The PLC can display a full screen window by using the PLC Control Object.  This object allows the HMI to
continuously scan a PLC register to display a full screen window, which corresponds to the number in the PLC
register.

Once the HMI displays a full screen that is requested by the PLC Control Object, the HMI will automatically write
the number of the requested screen to the next consecutive register.  For example, if you assign internal data register
LW10 to a PLC Control Object/Change Window and the number 3 is placed into this register, then the HMI will
display Screen #3.  Finally, it will put the number 3 into LW11.  This allows the PLC to confirm that the Screen has
been properly displayed by the HMI.

You can create as many PLC Control Objects as you need- each object is universal and is not dependent upon which
HMI screen is currently on display.
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�To call a full screen window using the PLC Control object

1. From the Parts menu, select PLC Control.  The PLC Control Object dialog box appears.

2. Click Add. The PLC Control Object’s Attribute dialog box appears.

3. Select the Device type and Device Address for the actual PLC address you wish to monitor.

� The HMI will write the number of the newly-displayed window to the next consecutive
address after the address specified in this step.
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4. Select either BIN (binary) or BCD format.

5. Click OK to return to the PLC Control Object dialog box.

6. You should see a new entry that lists the PLC address that is monitored by the HMI.

The PLC must only enter window numbers that represent full size (HMI520C: 320 x 240, HMI520T: 320 x 324,
HMI530/550: 640 x 480) windows when using the PLC Control Object function.  The HMI automatically closes
any open windows before the window called by the PLC Control Object is displayed.

The Direct and Indirect Window Objects

If you want the PLC to call up a popup window that is to be overlaid on top of other windows already open, then
there are two methods used to do this:

• Direct Window Object

• Indirect Window Object

� Unlike the PLC Control Object, the Direct and Indirect Window Objects are only active
for the windows that they are placed into.

The Direct Window Object is used to display a popup window using a PLC coil.  The HMI continuously reads the
value of the PLC coil to determine if it is set to 1.  If so, then the predefined popup window is displayed.

The Indirect Window Object is used to display a popup window using a PLC data register.  Similar to the PLC
Control Object, the HMI continuously monitors the selected PLC data register.  It will display any popup window
that corresponds to the number placed into the PLC data register by the PLC.

The PLC must reference a window that is less than full size (HMI520: 320 x 240, HMI530/550: 640 x 480) when
using the Direct Window and Indirect Window objects.
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�To call a popup window using the Direct Window Object

1. From the Parts menu, select Direct Window.  The Create Direct Window Object dialog box
appears.

2. In the General Tab, select the PLC address according to Device Type and Device Address.

3. In the same tab, enter the Window No. you want to call.

4. Click OK to return to the main screen of EasyBuilder.  The mouse cursor will have a square
object that represents the size of the popup window.

5. Place the Direct Window object where you want the popup window to appear.
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6. You can resize the object after you have placed it or  double-click on the object to display its
attributes.

7. Click the Profile tab to change the position or the size of the Direct Window Object.  Note
that the size does not refer to the size of the popup window since the size of the popup
window is determined in the Window Settings dialog box.  This size refers to the area of the
Direct Window Object which is analogous to a box in which the popup window is to be
placed.  If the size is too small, then the popup window will appear clipped when displayed.
Similarly, if the size of the Direct Window Object is larger than the actual size of the popup
window, the excess space will be blank.
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�To call a popup window using the Indirect Window Object

1. From the Parts menu, select Indirect Window.  The Create Indirect Window Object dialog
box appears.

2. In the General Tab, select the PLC address according to Device Type and Device Address.

3. Select BIN or BCD format.

4. No. of Words is currently set to 1 and cannot be changed.  This represents a 16-bit PLC data
register.

5. Click OK to return to the main screen of EasyBuilder.  The mouse cursor will have a square
object that represents the size of the popup window.

6. Place the Indirect Window object where you want the popup window to appear.
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7. You can resize the object after you have placed it or  double-click on the object to display its
attributes.

8. Click the Profile tab to change the position or the size of the Indirect Window Object.  Note
that the size does not refer to the size of the popup window since the size of the popup
window is determined in the Window Settings dialog box.  This size refers to the area of the
Indirect Window Object which is analogous to a box in which the popup window is to be
placed.  If the size is too small, then the popup window will appear clipped when displayed.
Similarly, if the size of the Indirect Window Object is larger than the actual size of the popup
window, the excess space will be blank.

Tips and Sug gestions

Having trouble deciding which method to use to display a base window?  Here are some suggestions:

• If you want to clear the HMI display of all open windows and display a new full screen
window, then use the PLC Control Object function or select the Change Window option in the
Function Key Object. The PLC Control Object is global (meaning it does not matter which
windows are currently on display), so the HMI will always monitor the PLC address that you have
selected.  The Function Key Object can be made local to one or more windows by placing the
object on only those windows.  It can also be made global (meaning the HMI operator can always
change to this window no matter which window is currently displayed),  by placing the Function
Key Object on the Common Window or the Fast Selection Window in the Task Bar, (more about
these later in this chapter).

• If you want to display a popup window on one particular full screen window, then try using the
Popup Window option in the Function Key Object.  This is particularly useful if you want the HMI
operator to control the ability to display the popup window.  If you want the PLC to determine
when to display the popup window, then try using the Direct Window object.
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• If you want to display a popup window that can be shown on any full screen window, then try
using the Popup Window option in the Function Key Object.  You should place the Function Key
Object in the Fast Selection Window with the Task Bar enabled, (more information is available on
the Task Bar later in this chapter).  This will allow the HMI operator access to that popup window
regardless of which full screen window is displayed.  If you want to display the popup window only
when some condition in the PLC has occurred, then try using the Direct Window object on the
Common Window, (more about the common window later in this chapter).

• If you want to display one of many possible popup windows on any full screen window, then
try using the Indirect Window object on the Common Window.  You can then let the PLC
determine which popup window should be displayed or you can create several Set Word objects to
allow the HMI operator to select which window to look at, (more about the Set Word object in a
succeeding chapter).

• If you want to display a child popup window within a parent popup window, then it is best to
use either the Indirect or Direct Window object not the Function Key object, even when you want
the HMI operator to press a key to display the child popup window.  Using the Function Key object
causes the popup window to be displayed at the Window Setting position regardless of the location
of the parent window.  This means that the child window could appear outside of the parent
window’s area, especially if the parent window can be moved about the HMI screen.  By using the
Indirect or Direct Window object, the child window will always be located within the parent
window even when the parent window has moved.  To allow the HMI operator to press a key to
display the child popup window,  configure a Set Word or Set Bit object to trigger the Indirect or
Direct Window object, (more about Set Word and Set Bit objects in a succeeding chapter).

Creating a moving window

The popup windows that you create for display on the HMI can be configured so that the HMI operator can touch
the window and touch somewhere else on the HMI display to move the window to that location.  To create a popup
window that can be moved, you must perform the following steps:

1. Create a popup window

2. Add a Function Key object with the Window Bar attribute in the popup window

The best way to show how this is done is to go through an example.

� Creating a moving window

1. Create a new window that is 150 x 100 pixels similar to Window #13 shown below:

Note that it really doesn’t matter what type of objects are displayed in the window.

2. From the Parts menu, select Function Key.  The Create Function Key Object dialog box is
displayed.

3. Click Window Bar.

4. Click the Shape tab.  Click Use Shape. Click on the Shape Library… command.  Select
Shape#0 from the button1 library. Click OK to return to the Create Function Key Object
dialog box.

5. Click the Label tab.  Click the Use label checkbox.

6. Enter the text ‘Window #13’ into the Contents box. Click OK to exit the Create Function
Key Object dialog box and go back to the EasyBuilder main screen.
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7. Place the new Function Key object somewhere on Window #13.  Reenter the Function Key
Attributes dialog box by double-clicking on the Function Key object.

8. Click the Profile tab.  Select X=4 and Y=4. Select Width=119 and Height=21.

9. Click OK.

10. Window #13 should now look something like this:

The Window Bar option in the Function Key Object allows the popup window to move about the HMI screen.
When Window#13 is displayed, the HMI operator is able to move the popup window about the screen by touching
the Window Bar on the top of Window#13 then touching another area of the HMI display where the Window
should be relocated.

Creating a popup win dow that can be minimized

By using the Task Bar, popup windows you create for display on the HMI can minimized to a small icon that is
displayed in the Task Bar.  To create a popup window that can be minimized, you must perform the following steps:

• Create a popup window

• Add a Function Key object with the Window Bar attribute in the popup window

• Enable the Task Bar (Edit Menu =>System Parameters, select General tab in the Task button
area select Enable from the Attribute pull down menu.)

• Add a Function Key object with the Minimize Window attribute in the popup window (optional)

Once more, an example is in order.  Enabling and using the Task Bar are discussed later in this chapter.

�Creating a window that can be minimized

1. Use Window #13 from the last example:

2. From the Parts menu, select Function Key.  The Create Function Key Object dialog box is
displayed.

3. Click Minimize Window.

4. Click the Shape tab.  Click Use Shape. Click on the Shape Library… command.  Select
Shape#0 from the button1 library. Click OK to return to the Create Function Key Object
dialog box.

5. Click the Label tab.  Click the Use label checkbox.

6. Enter a dash mark ‘-’ into the Contents box. Click OK to exit the Create Function Key
Object dialog box and go back to the EasyBuilder main screen.
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7. Place the new Function Key object somewhere on Window #13.  Reenter the Function Key
Attributes dialog box by double-clicking on the Function Key object.

8. Click the Profile tab.  Select X=124 and Y=4. Select Width=21 and Height=21.

9. Click OK.

10. Window #13 should now look something like this:

The Window Bar option in the Function Key Object allows the popup window to be minimized into an icon.  When
the Task Bar is enabled, displaying Window#13 causes an icon to appear inside the Task Bar.  The icon is labeled
with the title that appears in the Window Bar of Window#13. By double-clicking the icon, the window will
disappear from the HMI screen.  The Minimize Window option in the Function Key Object accomplishes the same
action when it is pressed.

To maximize the window, the HMI operator  presses the icon.  The popup window reappears in the last position that
it was moved to.

Returning to a pre vi ous win dow

You can configure a function key to display the full-sized base window that was on the HMI screen before the
currently shown window. Perform the following:

�Create a function key to return to previous window

1. From the Parts menu, select Function Key.  The Create Function Key Object dialog box is
displayed.

2. Click Return to Previous.

3. Configure the rest of the function key, and then click OK.
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4. Place the function key object onto the full-sized base screen.

� Placing a ‘return to previous’ function key onto a popup window will not work.

Using a func tion key to close a win dow

You can configure a function key to close any popup window that is currently displayed on the HMI screen:

�Create a function key to close a window

1. From the Parts menu, select Function Key.  The Create Function Key Object dialog box is
displayed.

2. Click Close Window.

3. Configure the rest of the function key, and then click OK.

4. Place the function key object onto the popup window.

� Placing a ‘close window’ function key onto a full-size base screen will not work.

Using the Com mon Win dow

Your project might require that some data be displayed on the HMI screen at all times, regardless of which
window(s) are displayed.  For example, you may want to display a company logo on the HMI screen at all times, or
you may want to display some critical data or an alarm message which should be seen no matter what windows are
displayed.

Using base windows to display this information requires that you configure every full screen base window with the
same graphics object.  The common window however, is a predefined window in the HMI that you can enable to
display this information.  When created, the common window always operates in the background as a full screen
window that overlays any full screen base window displayed.

Whenever you create a new project, the common window (Window #6) is automatically created.
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� To Access the common window

1. From the Window menu, select Open Window.  The Open Window dialog box appears.
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2. Highlight the Common Window and click Settings.  The Window Setting dialog box
appears.

3. As you can see, most of the parameters for a common window are disabled and cannot be
changed.  Window #6 is always reserved for the common Window.  Although the Style
settings are active, none of these settings affects the operation of the common window.

4. Press OK.  The Open Window dialog box reappears with the Common Window selected.

5. If you wish to open the common window, click Open.  Otherwise,  click Close to return to
the main screen of EasyBuilder.

Op tional set tings

Displaying popup win dows from the com mon win dow

As with full screen base windows, popup windows can be called from the common window.  In the System
Parameters settings, you have the option of selecting any popup windows called from the common window to be
displayed normally or to display above any popup windows called from a base window.  If the Normal setting is
selected, then the popup window called from the common window is displayed on top of any popup windows
already on the HMI display.  Popup windows displayed after common popup window are displayed over it.

If the Above any others setting is selected, then the popup window called from the common window is displayed
above any popup windows that may be called from a base window.
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�To set the popup window option for a common window

1. From the Edit menu, select System Parameters.  The Set System Parameters dialog box
appears.

2. Select the General tab. In the Common Window frame box, select either Normal or Above
any others for the Popup Window box.

3. Click OK to return to the main screen of EasyBuilder.

The following illustration shows how this setting affects the operation of popup windows called from the common
window.

Popup window #21 was called from the common window with the Popup Window: Normal setting.
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Window #13 is now called from the base window.

As expected, window #13 is displayed over window #21.  The entire area of window #21 can be seen if the HMI
operator activates it by pressing it. 

Now suppose that the same scenario is played out with the Popup Window: Above any others setting.

Window #13 is now called from the base window, as before.
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Notice that although window #13 was called after window #21, it is window #21 that remains above.  Even when
window #13 is activated by pressing it, window #21 continues to be the dominant window- always displaying above
window #13.

Displaying the common window above/below the base screen

This setting resolves the conflict that can occur if a graphics object on the common window occupies the same space
on the HMI display as a graphics object on a base screen.  Using the Above base screen attribute forces the
graphics object on the common window to cover the base window graphics object.  Using Below base screen has
the opposite effect.

Common Window Base Window

When above base screen is set, the result is:
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When below base screen is set, the result is:

�To set the above/below base screen option for a common window

1. From the Edit menu, select System Parameters.  The Set System Parameters dialog box
appears.

2. Select the General tab. In the Common Window frame box, select either Above base screen
or Below base screen for the Attribute box.

3. Click OK to return to the main screen of EasyBuilder.

�� Active graphics objects (objects that display information or graphics according to a
data value in a PLC register or coil) take precedence over passive graphics objects
(objects such as circles, lines, rectangles, etc.).  Therefore, a Set Word object on a base
window will cover a Rectangle object on a common window which occupies the same
space even with the Above base screen attribute enabled.

Changing the Ac tive Com mon Win dow

Although only one common window can be on the HMI display at one time, you do have the ability to create
multiple common windows by using base windows as common windows.  Then, with the help of a Function Key
object, the HMI operator can change the active common window.

The ability to change the common window adds more flexibility to your project should you need it.  For example,
you may have a series of full screen windows which all need a keypad for entry.  Another series of full screen
windows may require a common alarm message.  By changing the common window with each series of windows,
you can customize each common window to contain only the graphics objects that are needed.

� To change the active common window

1. Create a common window.

2. Create a base window that is full screen.  This will be used as another common window. 
Note that when a base window is used as a common window, the Start Pos:, Style, Frame,
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and Background settings are ignored by the HMI.  For this example, let’s use Window#30 as 
the alternate common window.

3. Create another full screen base window that can be displayed along with the common
windows, (such as a startup window).  Let’s use Window#10, the initial window, for our
example.

4. On Window#10, create a Function Key object that is used to change the common window.
From the Parts menu, click Function Key.  The Create Function Key Object dialog box
appears.

5. On the General tab, click Change Common Window.

6. In the same frame, enter 30 for Window No..

7. Click the Shape tab.  Click Use Shape. Click on the Shape Library… command.  Select
Shape#0 from the button1 library. Click OK to return to the Create Function Key Object
dialog box.

8. Click the Label tab.  Click the Use label checkbox.

9. For our example, type CCW (meaning Change Common Window) into the Contents box.
Click OK to exit the Create Function Key Object dialog box and go back to the EasyBuilder
main screen.

10. Place the new Function Key object somewhere on Window #10.

Below is an illustration of what the default common window, Window#30 (alternate common window), and
Window#10 (startup window) might look like:

Default Common Window #30 Window #10
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When the HMI initializes, it displays the startup screen (Window #10) and the default common window.

To change common windows, we press the CCW function key that we have configured to change the common
window to Window#30.

Window#30 remains the common window until another function key object is pressed that changes the common
window or until the HMI is reset.

Using the Fast Se lection Window

In the last section, you read that common windows are great for displaying information that should be displayed all
the time, regardless of which base windows are active.  However, you may create projects that require a window
that is always accessible (like a common window) but not always displayed.  For example, you may want a numeric
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keypad available for any data entry.  However, a keypad takes precious space on the HMI display. Ideally it should
appear on screen only when a key was pressed and then, by pressing another (or the same) key, the keypad should
disappear.

This is essentially the purpose of the Fast Selection window.  The Fast Selection window is available only if the
Task Bar is activated (more about this feature later in this chapter).  The Fast Selection window can also be used as a 
menu key that allows the HMI operator to rapidly switch screens.

Whenever a new project is created, the fast selection window (Window #4) is automatically created.

� To access a fast selection window:

1. From the Window menu, select Open Window.  The Open Window dialog box appears.

2. Highlight the Fast Selection Window and click Settings. The Window Setting dialog box
appears.
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3. Click Fast Selection.  The Window Setting dialog box appears.

3. The Name: and Window No.: are reserved to identify the Fast Selection window.  The other
parameters can be modified, (see the Window Settings section earlier in this chapter for more
information).  Notice that the default size is Width=70 and Height=214.  The default was
selected to create a ‘sidebar’ that contains function keys to display other windows. The
example below illustrates how the Fast Selection Window can be used for this purpose. 4.
Press OK.  The Open Window dialog box reappears with the Fast Selection window selected.

5. If you wish to open the fast selection window, click Open.  Otherwise,  click Close to return
to the main screen of EasyBuilder.
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Using the Fast Se lection Key

The fast selection key is used to display the Fast Selection window.  Pressing the key again causes the Fast Selection 
window to close.

Changing screens us ing the Fast Se lection window

One of the more useful purposes of the Fast Selection window is to use it as a ‘menu’ key for switching screens on
the HMI display.  The following example illustrates how you might create a Fast Selection window for this purpose.
The example steps you through creating six full-screen base windows, enabling the Task Bar, and creating a Fast
Selection window to call up the six screens.

We will start with the following six screens.
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Next, create a new Fast Selection window using default settings.  For this example, we will create six Function Key
objects that change windows.  Configure each Function Key object with the Change Window attribute and place
the object into the Fast Selection window.

Finally, the Task Bar must be enabled, (see the next section for instructions). After downloading the project file to
the HMI, the following initial screen should be shown.
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Press the Fast Selection key on the Task Bar to activate the Fast Selection window.

Press one of the Function Keys to switch to another full screen window.
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Finally, pressing the Fast Selection Key will remove the Fast Selection Window until it is needed again.

As you can see, the Fast Selection window, though not seen, is always readily available.

� The Fast Selection window can only call full screen windows not popup windows.
Therefore, you cannot use Function Key objects with the Popup Window attribute in
Fast Selection windows.

Changing the Fast Se lection Window

As with common windows, only one fast selection window can be on the HMI display at one time.  However, you
can create multiple fast selection windows by using base windows.  Then, with the help of a Function Key object,
the HMI operator can change the active fast selection window.

This feature allows you to customize each fast selection window created to perform a specialized function
depending upon which set of windows is currently displayed.  For example, for a group of data entry screens, you
may want the fast selection window to contain a numeric keypad.  For a group of data monitoring screens, you may
want the fast selection window to contain a trend graph.

� To change the active fast selection window

1. Create a fast selection window. Note: To use this feature, you must change the default width
setting of the fast selection window from 70 to at least a minimum of 100.  This is because the
minimum allowable width size for base windows is 100.

2. Create a base window that is the same width and height as the fast selection window you just
created.  This will be used as another fast selection window.  Match all settings to that used
on the fast selection window.  For our example, we will use Window#11.

3. Create a full screen base window that can be used to change the fast selection windows, (such
as a startup window).  Let’s use Window#10, the initial window, for our example.

4. On Window#10, create a Function Key object that is used to change the fast selection
window. From the Parts menu, click Function Key.  The Create Function Key Object dialog
box appears.

5. On the General tab, click JOG FS-Window.

6. In the same frame, enter 11 for Window No..
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7. Click the Shape tab.  Click Use Shape. Click on the Shape Library… command.  Select
Shape#0 from the button1 library. Click OK to return to the Create Function Key Object
dialog box.

8. Click the Label tab.  Click the Use label checkbox.

9. For our example, type CFS11 (meaning Change Fast Selection Window#11) into the
Contents box. Click OK to exit the Create Function Key Object dialog box and go back to
the EasyBuilder main screen.

10. Place the new Function Key object somewhere on Window #10.

11. Now create another Function Key object with the JOG-FS attribute but select 4 for Window
number

12. For the label, enter CFS04  (meaning Change Fast Selection Window#04), which is the
default Fast Selection window.

13. In the Edit-System Parameters menu under the General tab section, enable the task bar.

14. Save, compile, and download the project to your HMI.

Below is an illustration of what the default fast selection window, Window#11 (alternate fast selection window),
and Window#10 (startup window) might look like:

Default Fast Selection Window
Alternate Fast Selection

Window#11
Startup Window #10
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When the HMI initializes, it displays the startup screen (Window #10) and the task bar.

Press the Fast Selection key on the task bar to view the default Fast Selection window.
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To change fast selection windows, press the CFS11 function key that has been configured to change the fast
selection window to Window#11.

Window #11 will remain the Fast Selection window until a function key with the Jog-FS attribute is used to change
the Fast Selection window again or the HMI resets.  To change back to the default fast selection windows, we press
the CFS04 function key that we have configured to change the fast selection window back to the default fast
selection window (Window #4).
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Using the Task Bar

The Task Bar has three purposes:

• Allows you to minimize popup windows to an icon that is placed in the Window bar.

• Allows you to access the Fast Selection window that you create.

• Displays information about the activity of your HMI, as an option.

The Task Bar is optional and must be enabled to see it on the HMI screen.

�To activate the task bar

1. From the Edit menu, select System Parameters.  The Set System Parameters dialog box
appears.

2. Click the General tab to display the General form.

3. In the Task Button frame, click Enable in the Attribute box.

When enabled, the Task Bar should look like the following illustration:

Using the Window Bar

The window bar is where the minimized popup window icons reside.  You can display a maximum of six popup
windows at one time and every time a popup window is displayed on the HMI screen, an icon representing that
window is displayed on the window bar of the task bar.

The window bar can be displayed or removed by pressing the Window Bar Key labeled Easy.  Besides containing
the popup window icons, the Window Bar also contains three optional indicators: the Touch, CPU, and Alarm

indicators
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The Touch In di ca tor

This optional feature provides you with additional feedback when pressing the touch screen of the HMI.  One of
three colors is displayed in the circle, depending upon what area of the touch screen is touched.  The three areas are:

• Non-configured area – Any area on the touch screen that does not contain an active touch screen
object.

• Active area – Any area that contains an active touch screen object which, when pressed, executes
some action.

• Inactive area – Any area that contains an active touch screen object but the active object is not able 
to execute its intended function.  For example, a Function Key with the Popup Window option is
defined as an active area when first pressed since it causes the popup window to be displayed.
However, once the popup window is displayed,  pressing this key serves no purpose and then it
becomes an inactive area.

�To activate the touch indicator

1. From the Edit menu, select System Parameters.  The System Parameter Setting dialog box 
appears.

2. Click the General tab to display the General form.

3. In the Task Button frame, click Enable in the Attribute box.

4. Click the Indicator tab to display the Indicator form.

5. In the Touch Indicator frame, click Enable in the Attribute box.

6. Select which colors you would like to use for the Non-Configured Area, the Inactive Area,
the Active Area, and the Frame box.

7. Click OK to exit the System Parameters dialog box.

The CPU In di ca tor

This optional feature reflects the status of the HMI’s microprocessor.  As the color indicator grows, the
microprocessor of the HMI is processing more data.  The CPU indicator could be used as a rough indicator of how
much activity is occurring in the HMI.

� To activate the CPU indicator

1. From the Edit menu, select System Parameters.  The Set System Parameters dialog box
appears.

2. Click the General tab to display the General form.

3. In the Task Button frame, click Enable in the Attribute box.

4. Click the Indicator tab to display the Indicator form.

5. In the CPU Indicator frame, click Enable in the Attribute box.

6. Select the color you would like to use.

7. Click OK to exit the System Parameters dialog box.

The Alarm In di ca tor

This optional feature reflects the status of alarms. The color indicator grows every time a new alarm condition
becomes active.  The color indicator is full when ten alarms are active.  The Alarm indicator can be used as a rough
indication of how many alarms are active.  This can be used to notify the HMI operator when an alarm has occurred
so that he may go to some alarm screen to get more information.
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�To activate the Alarm indicator

1. From the Edit menu, select System Parameters.  The Set System Parameters dialog box
appears.

2. Click the General tab to display the General form.

3. In the Task Button frame, click Enable in the Attribute box.

4. Click the Indicator tab to display the Indicator form.

5. In the Alarm Indicator frame, click Enable in the Attribute box.

6. Select the color you would like to use.

7. Click OK to exit the System Parameters dialog box.

Gen eral Set tings

In EasyBuilder, you can configure how the task bar looks when it is activated for a more customized look.  From the 
Window menu, select Open Window.  In the Open Window dialog box, click the Task button… dialog box.  The
Window Setting box appears:

The only parameters that apply to the Task Bar are the Width and Height settings.  The default setting for the
Width parameter is 100 but you can select from a range of 10-200.  The default setting for the Height parameter is
30 but you can select from a range of 10-100.
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Click on the Window… button to change settings for the Window Bar key.  The Fast Selection key can be modified
by clicking the Screen… button.  The Window Attribute dialog box appears.  You can change the shape used for
the two hot keys or the label that identifies them.  You can also change the speed at which these keys display the
Window Bar and the Fast Selection Window.

Creating a Mes sage Board

You may have an application for an HMI in which the HMI operator must be able to leave messages for someone
else to read.  The message board feature creates a popup window that can be displayed on the HMI for such a
purpose.  Once displayed, the HMI operator  ‘draws’ on the touch screen to write messages.  The messages remain
on the message board until a touch screen command is issued to clear the message board or the HMI is reset.  One
message board may be created per project and it must be created from a popup window.  You can only call up the
message board using the Direct Window Object.  The message board popup window can contain any graphics
objects and the HMI operator can write over any graphics objects that appear on the window.

�To create a Message Board

1. Create a Base Window that is partially sized, (to be used as a popup window).

2. From the Edit menu, click System Parameters.  The Set System Parameters dialog box is
displayed.

3. Click the General tab to display the General form.

4. Enter the number of the base window just created in Message board window (0, 10-1999):
which is located at the bottom of the General form.  Note: 0 is used to disable the message
board feature.

5. Click OK.

6. Use the Function Key Object, Direct Window Object, or Indirect Window Object to call up
the message board.

Op tional Pa ram e ters

In addition to using the message board, the HMI operator can change the following parameters.

Set the Op eration Mode for the Mes sage Board

Using the Function Key Object, you can program a touch screen object to change ‘operating mode’ of the pen. 
There are three operating modes:

• Pen:  select this mode when you want to write a message.

• Brush: select this mode when you want to erase parts of a message.

• Clip: select this mode to ‘clip’ or cut out a rectangular section of a message.

The touch screen object can be placed onto the message board or any other window.

�To create a Change Message Board Operation Mode key

1. From the Parts menu, select Function Key.  The Create Function Key Object dialog box
appears.

2. Click the General tab to display the General form.

3. Click the Message Board option.

4. Select Set operation mode from the pull-down.

5. Click the Attributes button to select the operation mode you want to use.

6. Click OK to exit the Create Function Key Object dialog box.

7. Place the new touch screen object on the window screen.

When this key is pressed, it will change the operation mode used when a message is written on the board.

1010-1001a, Rev 01

Cre ating Win dows 143



Set the Pen Style for the Mes sage Board

Using the Function Key Object, you can program a touch screen object to change the thickness of the line used for
the pen.  The touch screen object can be placed onto the message board or any other window.

� To create a Change Message Board Pen Style key

1. From the Parts menu, select Function Key.  The Create Function Key Object dialog box
appears.

2. Click the General tab to display the General form.

3. Click the Message Board option.

4. Click the Set operation mode pull-down box and select Set pen style.

5. Click the Attributes button to select the line width you want to use.

6. Click OK to exit the Create Function Key Object dialog box.

7. Place the new touch screen object on the window screen.

When this key is pressed, it will change the line thickness used when a message is written on the board.

Set the Pen Color for the Mes sage Board

Using the Function Key Object, you can program a touch screen object to change the color used for the pen.  The
touch screen object can be placed onto the message board or any other window.

�To create a Change Message Board Pen Color key

1. From the Parts menu, select Function Key.  The Create Function Key Object dialog box
appears.

2. Click the General tab to display the General form.

3. Click the Message Board option.

4. Click the Set operation mode pull-down box and select Set pen color.

5. Click the Attributes button to select the color you want to use.

6. Click OK to exit the Create Function Key Object dialog box.

7. Place the new touch screen object on the window screen.

When this key is pressed, it will change the color used when a message is written on the board.

Clear the Mes sage Board

Using the Function Key Object, you can program a touch screen object to clear the message board.  The touch
screen object can be placed onto the message board or any other window.

�To create a Clear Message Board key

1. From the Parts menu, select Function Key.  The Create Function Key Object dialog box
appears.

2. Click the General tab to display the General form.

3. Click the Message Board option.

4. Click the Set operation mode pull-down box and select Clear board.

5. Click the Shape tab to select the shape that you want to use.

6. Click the Label tab to select the label.

7. Click OK to exit the Create Function Key Object dialog box.

8. Place the new touch screen object on the window screen.

When this key is pressed, it will clear any messages written on the message board.
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Below is an illustration of how a message board might look with all of the options available on the message board.

In this example, the HMI operator can change the operation mode of the message board by pressing the Pen, Brush,
or Clip keys.  The Pen Style can be changed by pressing the Thin, Normal, and Thick keys.  The Pen Color is
changed by pressing the Red, Blue, or Green keys.  Finally, any messages written on the board by the HMI operator
can be erased by pressing the Clear Board key.

To write on the message board, we recommend that you use some dull pointed device (such as a retractable pen) that
won’t mar or leave a permanent mark on the HMI’s touch screen.  Then practice your penmanship!
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Chapter 6 - Creating Graphic Objects

Draw ing Ob jects

To display any graphics objects on the HMI screen you must either create them using the drawing tools included
with EasyBuilder, import them from another applications program, or select from the many choices available in the
graphics libraries included with EasyBuilder.

This chapter shows you how to create, use, and save graphics objects in EasyBuilder.  You have learned from
previous chapters how graphics objects are placed onto windows.  In this chapter, we concentrate on how to create
graphics objects.

Using the Draw ing Tools

Several drawing tools are provided in EasyBuilder to make it easier to create graphics objects.  With these tools, you
can create simple geometric shapes such as straight lines, circles, rectangles, and polygonal shapes.  You can also
combine several various geometric shapes to form complex shapes that can be stored into one of the graphics
libraries for later retrieval.

The Line Tool

Use the Line tool to create straight lines on a window.  Each line that you create has three parameters associated
with it:  length, thickness, and color.

�To create a line

1. From the Draw menu, click Line or click the Line icon in the Draw toolbar.  The Attributes
dialog box appears.

2. Click the pull down box from the Color box.  The Color dialog box appears.

3. Click on the appropriate color box, then click OK. The color box should reflect what you
have chosen.

4. Click on the line thickness that you want to use.

5. Move the mouse cursor over to the work area of EasyBuilder onto the window that you are
currently editing.  The mouse cursor has changed from an arrow to a crosshair cursor.

6. Click to mark the beginning of the line. Move the mouse to the location where the end of the
line should be.  Click the mouse cursor again to mark the end of the line.  The line object is
formed and displayed on the window screen with small white square blocks around the
boundaries of the line.

7. To continue creating more lines  repeat the last step.  To move the line just created, click on
the Select option from the Edit menu or  click the Select icon in the Draw toolbar.  Move the
line to the preferred location.

8. To change any of the attributes, double-click on the line to display the Line Object’s
Attribute dialog box.

The Rect an gle Tool

The rectangle tool is used to create rectangles or squares.  Each rectangle created has four parameters associated
with it:  size, thickness, color, and filled.

�To create a rectangle

1. From the Draw menu, click Rectangle or click the Rectangle icon in the Draw toolbar.  The
Attributes dialog box appears.

2. If the interior of the rectangle is to be filled with a color, check the Filled box.  Two
additional settings appear.

3. If you want to fill the rectangle with a solid color, then select a color for the Interior box.
Click Pattern Style to display the Pattern Style dialog box.  Select the upper left-most
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pattern for a solid color.  If you want to use a pattern for the filled section of the rectangle,
then select from the available patterns, and click OK to exit the Pattern Style dialog box.  In
the Attributes dialog box, select the Pattern color.

4. In the Frame section, click the pull-down arrow of the Color box and select a color.  Click
OK in the Color dialog box to go back to the Attributes dialog box.

5. Click on the line thickness that you want to use.

6. Move the mouse cursor over to the work area of EasyBuilder onto the window that you are
currently editing.  The mouse cursor has changed from an arrow to a crosshair cursor.

7. Click to mark a corner of the rectangle. Move the mouse to where the opposite corner of the
rectangle should be.  Click the mouse cursor again to mark the corner of the rectangle.  The
rectangle object is formed and displayed on the window screen with small white square
blocks around the perimeter of the rectangle.

8. To continue creating more rectangles  repeat the last step.  To move the rectangle just created, 
click on the Select option from the Edit menu or  click the Select icon in the Draw toolbar.
Move the rectangle to the preferred location.

9. To change any of the attributes, double-click on the rectangle to display the Rectangle
Object’s Attribute dialog box.

The El lipse/Cir cle Tool

The ellipse tool is used to create ellipses or circles.  Each ellipse created has four parameters associated with it:  size, 
thickness, color, and filled.

�To create an ellipse

1. From the Draw menu, click Ellipse/Circle or click the Ellipse/Circle icon in the Draw
toolbar.  The Attributes dialog box appears.

2. If the interior of the ellipse is to be filled with a color, check the Filled box.  Two additional
settings appear.

3. If you want to fill the ellipse with a solid color, then select a color for the Interior box. Click
Pattern Style to display the Pattern Style dialog box.  Select the upper left-most pattern for a
solid color.  If you want to use a pattern for the filled section of the ellipse, then select from
the available patterns, and click OK to exit the Pattern Style dialog box.  In the Attributes
dialog box, select the Pattern color.

4. In the Frame section, click the pull-down arrow of the Color box and select a color.  Click
OK in the Color dialog box to go back to the Attributes dialog box.

5. Click on the line thickness that you want to use.

6. Move the mouse cursor over to the work area of EasyBuilder onto the window that you are
currently editing.  The mouse cursor has changed from an arrow to a crosshair cursor.

7. Click to mark a corner of the ellipse. Move the mouse to where the opposite corner of the
ellipse should be.  Click the mouse cursor again to mark the ellipse.  The ellipse object is
formed and displayed on the window screen with small white square blocks around the
perimeter of the ellipse.

8. To continue creating more ellipses  repeat the last step.  To move the ellipse just created, click 
on the Select option from the Edit menu or  click the Select icon in the Draw toolbar.  Move
the ellipse to the preferred location.

9. To change any of the attributes, double-click on the ellipse to display the Ellipse Object’s
Attribute dialog box.

The Arc Tool

The arc tool is used to create arcs.  Each arc created has three parameters associated with it:  size, thickness, and
color.

� To create an arc 

1. From the Draw menu, click Arc or click the Arc icon in the Draw toolbar.  The Attributes
dialog box appears.
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2. In the Frame section, click the pull-down arrow of the Color box and select a color.  Click
OK in the Color dialog box to go back to the Attributes dialog box.

3. Click on the line thickness that you want to use.

4. Move the mouse cursor over to the work area of EasyBuilder onto the window that you are
currently editing.  The mouse cursor has changed from an arrow to a crosshair cursor.

5. Click to mark a corner of the arc.  Move the mouse to where the opposite corner of the arc
should be.  Click the mouse cursor again to mark the arc.  The arc object is formed and
displayed on the window screen with small white square blocks around the perimeter of the
arc.

6. To continue creating more arcs  repeat the last step.  To move the arc, click on the Select
option from the Edit menu or  click the Select icon in the Draw toolbar.  Move the arc to the
preferred location.

7. To change any of the attributes, double-click on the arc to display the Arc Object’s Attribute
dialog box.

The Poly gon Tool

The polygon tool is used to create polygons.  Each polygon created  has four parameters associated with it:  size,
thickness, color, and filled.

�To create a polygon

1. From the Draw menu, click Polygon.  Or  click the Polygon icon in the Draw toolbar.  The
Attributes dialog box appears.

2. If the interior of the polygon is to be filled with a color, check the Filled box.  Two additional
settings appear.

3. If you want to fill the polygon with a solid color, then select a color for the Interior box.
Click Pattern Style to display the Pattern Style dialog box.  Select the upper left-most
pattern for a solid color.  If you want to use a pattern for the filled section of the polygon, then
select from the available patterns, and click OK to exit the Pattern Style dialog box.  In the
Attributes dialog box, select the Pattern color.

4. In the Frame section, click the pull-down arrow of the Color box and select a color.  Click
OK in the Color dialog box to go back to the Attributes dialog box.

5. Click on the line thickness that you want to use.

6. Move the mouse cursor over to the work area of EasyBuilder onto the window that you are
currently editing.  The mouse cursor has changed from an arrow to a crosshair cursor.

7. Click to mark a corner of the polygon.  Move the mouse to where another corner of the
polygon should be.  Click the mouse cursor again to mark the corner.  Continue clicking each
corner until it is time to connect the last corner to the first corner of the polygon.  Right click
to complete the polygon.  The polygon object is formed and displayed on the window screen
with small white square blocks around the perimeter of the polygon.

8. To continue creating more polygons  repeat the last step.  To move the polygon, click on the
Select option from the Edit menu or  click the Select icon in the Draw toolbar.  Move the
polygon to the preferred location.

9. To change any of the attributes, double-click on the polygon to display the Polygon Object’s
Attribute dialog box.

The Scale Lines Tool

The Scale Lines tool is used to create scales.  Each scale created  has four parameters associated with it:  size,
thickness, color, and filled.

�To create a scale

1. From the Draw menu, click Scale.  Or  click the Scale icon in the Draw toolbar

2. Move the mouse cursor over to the work area of EasyBuilder onto the window that you are
currently editing.  The mouse cursor has changed from an arrow to a crosshair cursor.
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3. Click to mark a corner of the scale. Move the mouse to where the opposite corner of the scale
should be.  Click the mouse cursor again to mark the corner of the scale.  The scale object is
formed and displayed on the window screen with small white square blocks around the
perimeter of the scale.

4. From the Edit menu, select Change Attribute.  The Scale Object’s Attribute dialog box
appears.

5. In the Frame section of the Style tab, click the pull-down arrow of the Color box and select a
color.  Click OK in the Color dialog box to go back to the Scale Object’s Attribute dialog
box.

6. Click on the line thickness that you want to use.

7. In the Scale section, select from one of the six Styles:

Up Down Full ¾ Size Horizontal Vertical

8. Enter the number of divisions in the Division: box.  For Up, Down, Full, and ¾ Size enter
the Meter Length.

9. Adjust the size and position of the scale in the Profile tab, if necessary.

10. Click OK.  The Scale Object’s Attribute closes and the main screen of EasyBuilder reappears
with the Scale Object displayed.  Scale lines are most often used when creating bar graphs,
scale meters, and trend graphs.

Using Text

EasyBuilder allows you to create text boxes using eight font sizes: 8, 16, 24, 32, 48, 64, 72, and 96.  The text can be
displayed using any of the 256 colors available in the HMI520C, HMI520H HMI530C, or HMI550H or the four
shades available in the HMI520M and HMI550M.  The text can be left, center, or right justified in the text box.

�To create a text box

1. From the Draw menu, click Text.  Or  click the Text icon in the Draw toolbar.  The Create
Text Object dialog box appears.

2. Select which color you want in the Color: box.

3. Select the font size in the Font: box.

4. Select the type of justification in Align: box.

5. In the Content: box, enter the text that you would like to appear in the text box.

6. Click OK.  The main screen of EasyBuilder reappears with the outline of the text box tagged
to the cursor in the upper left corner of the work area.

7. Move the text box to the area you wish to place it on the window and click.

8. The text box appears with small square boxes around the perimeter.  Click on another area of
the window to end the edit session or double-click to reedit the text box parameters.

� If you wish to create your own characters, you can use the EasyASCIIFontMaker
program to edit the character sets.  For more information, see the section “The
EasyASCIIFontMaker” in Chapter 4 “Using EZware-500”.
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The following illustration shows the various font sizes available.

�To change the font size

1. By clicking onto a text box, you can easily change the font size by using the Font: box or the
Enlarge or Reduce buttons on the Manager toolbar.

2. Click on the pull-down box of the Font: box and select one of the font sizes or

3. Click the Enlarge button  to increase the size of the text box by one font size.

4. Click the Reduce button  to decrease the size of the text box by one font size.

5. Note that if the text box overlaps one of the borders of the window when enlarged, then the
command to enlarge the text box is ignored.

Predefined Shapes and Bitmaps

In addition to using the drawing tools to create your own graphics, EasyBuilder provides two types of predefined
graphics objects: shapes and bitmaps.   These graphics objects are stored in libraries that come with EasyBuilder,
(more on libraries in the next section).  Shapes and bitmaps are both used for the same purpose, to display a
predefined complex graphics object on the HMI screen.  The difference between shapes and bitmaps is how they are
composed and stored.

Shapes are vector-based graphics which are stored in files that contain dimensional information about the shape.
Shapes are actually composed of several simpler graphics like the ones created by the drawing tools.  Because of
this, they can usually be more easily modified than bitmaps.

Bitmaps are pixel-based graphics which are stored in files that contain information about each pixel to compose a
bitmap graphic.  The pixel is the smallest possible detail that you can change on a screen.  Because of this, although
bitmaps are more difficult to modify, they offer the most flexibility in customizing the graphic object.
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In most cases, you won’t need to know the difference between a shape graphic and a bitmap graphic.  You will base
your selection on what looks good.  However, keep the following comparisons in mind.

Shapes Bitmaps

Ease of Creation Can be created using EasyBuilder
Must be created using a desktop
graphics application such as Microsoft
PaintTM

Memory Requirements Low High

Quality of picture after changing size Good Fair to Bad

Time required to display on HMI screen Quick if not too complex Quick if not too large

Shapes and bitmaps are used in both passive and active graphics objects.  Each shape or bitmap can be resized or
moved just like any drawing object.  The following examples show how to place a pre-defined shape or a bitmap on
the HMI screen as a passive object.  Using shapes and bitmaps with active graphics objects is covered in Chapter 8
“Representing Data with Graphics Objects”.  Information on creating new shapes and bitmaps and storing them in
libraries will be covered in a later section of this chapter.

Using a Pre defined Shape

You can select from many shapes that are included in the EasyBuilder configuration software.  Shapes can be used
for active or passive objects.  The following procedure describes using a passive shape object

� To use a shape

1. From the Draw menu, click Shape.  Or  click the Shape icon in the Draw toolbar.  The
Create Shape Object dialog box appears.
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2. Click the Shape library… button.  The Shape Library dialog box appears.

3. Click the pull-down box of Shape library: and choose from one of the open libraries of
shapes.

4. Use the scroll bar to view available shapes. Click on the shape that you want.

5. Click OK  The Create Shape Object dialog box reappears.  The shape that you selected
should be displayed in this dialog box.

6. Click OK.  The main screen of EasyBuilder reappears with an outline of the shape object in
the  upper left corner of the work area.

7. Move the shape to the location desired and click.  The shape appears with small square boxes
around the perimeter of the shape.

8. The shape can be resized or you can edit the shape’s parameters by double-clicking to enter
the Shape Object’s Attribute dialog box.
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Using a Pre defined Bitmap

You can select from many bitmaps that are included in the EasyBuilder configuration software.  Bitmaps can be
used for active or passive objects.  The following procedure describes using a passive bitmap object.

�To use a bitmap

1. From the Draw menu, click Bitmap.  Or  click the Bitmap icon in the Draw toolbar.  The
Create Bitmap Object dialog box appears.
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2. Click the Bitmap library… button.  The Bitmap Library dialog box appears.

3. Click the pull-down box of Bitmap library: and choose from one of the open libraries of
bitmaps.

4. Use the scroll bar to view available bitmaps. Click on the bitmap that you want.

5. Click OK  The Create Bitmap Object dialog box reappears.  The bitmap that you selected
should be displayed in this dialog box.

6. Click OK.  The main screen of EasyBuilder reappears with an outline of the bitmap object in
the  upper left corner of the work area.

7. Move the bitmap to the location desired and click.  The bitmap appears with small square
boxes around the perimeter of the bitmap.

8. The bitmap can be resized or you can edit the bitmap’s parameters by double-clicking to enter
the Bitmap Object’s Attribute dialog box.

Graph ics Li braries

Graphics Libraries are files that come with EasyBuilder which contain graphics shapes and bitmaps.  Over 500
predefined shapes and bitmaps are included with EasyBuilder.  In addition, you can create new bitmaps or shapes
and add them to the libraries.  You can even create new libraries as you need them.  Each library contains a
maximum of 48 shapes or bitmaps.  Each shape or bitmap has a maximum of 32 ‘states’ or pictures tied to it.

EasyBuilder allows a maximum of ten bitmap libraries and ten shape libraries to be open per project file.  Finally, a
group library can be used to store several graphics objects (such as a keypad) to be easily used when needed.  For
example, you may create a bar graph that could be used in several different projects.  The bar graph can be stored
into the group library for easy retrieval.

All libraries are accessed from the Library menu or by clicking the appropriate icon in the Standard toolbar.
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What are ‘states’?

Many of the graphics objects (ex. Set Word Object or Moving Shape Object) use states to determine which picture
to display.  Shapes and bitmaps can be configured with up to 32 different states.

Each shape can be configured to show a different picture depending upon a ‘state’.  States are used when the shape
is tied to an active object that is monitoring a value in a PLC.  For instance, you would use a two-state shape to
represent a Bit Lamp object.  You can also use a different picture of a shape for a passive object.   Click the State:
pull-down box in the Shape or Bitmap library and select a different number.  Most of the predefined shapes in the
libraries have at least two states.

Using Shape Li braries

EasyBuilder includes fourteen shape libraries:
• balloons.slb(contains dialog boxes)

• captions.slb(contains various rectangle shapes)

• button1.slb(switches and lamps)

• button2.slb(switches and lamps)

• button3.slb(switches and lamps)

• button4.slb(switches and lamps)

• buttons.slb(switches and lamps)

• electric.slb(schematic symbols)

• isa_1.slb(isa symbols)

• isa_2.slb(isa symbols)

• part1.slb(switches and flags)

• pipe_m0.slb(pipes)

• pipe_m1.slb(pipes)

• pipes.slb(pipes)

When you start a new project, two libraries (button1 and button2) are automatically open.

�To display the Shape Library dialog box

1. From the Library menu, click Shape, then click Call up library. Or click the Call up Shape 
Library icon from the Standard toolbar. The Shape Library dialog box appears.
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Let’s look at the Shape Library dialog box:

The Shape Library provides several options which are discussed in the following sections.

Ac cess ing and Cre at ing Shape Li brar ies

You can open, close, or even create new shape libraries easily using the Shape Library dialog box.

�To open other shape libraries 

1. With the Shape Library dialog box displayed, click Select Lib…  The Open dialog box
appears.

2. Select which library you would like to open, then click Open.  The Shape Library dialog box
reappears with the selected library displayed.

If the project has ten libraries open, you may want to close a library so that another one may be opened.
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�To close or ‘unattach’ an open shape library

1. With the Shape Library dialog box displayed, click the pull-down box of Shape library: and
choose from one of the open libraries of shapes.

2. Select which library you would like to close, then click Unattach Lib.  A dialog box appears
asking if you really want to unattach the selected library.  Click Yes.

3. The Shape Library dialog box reappears and the library is removed from the Shape library:
list.

You have the option of creating a new library.  This can be very useful when organizing shapes.

�To create a new shape library

1. With the Shape Library dialog box displayed, click New Lib…  The New Library dialog box
appears.

2. Enter a name for the new library. Click OK.

3. The Shape Library dialog box appears with the new library loaded. Click Close.

4. The new library is now available to this project but it is not stored into the Library
subdirectory of EasyBuilder until the project file has been saved.

Cre ating, de let ing and plac ing shapes

EasyBuilder provides drawing tools that can be used to create shapes.  For more information on how to use the
drawing tools, consult the first part of this chapter.  The shapes that you create can be permanently stored into the
shape libraries for access by any project.

� To add a new shape to a library

1. This example shows how to add a two-state shape to a library. You must first create the
shapes that you plan on storing using the drawing tools supplied with EasyBuilder.  The
shapes can be any size.  You can use any combination of drawing tools to create the shape.
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2. Highlight the shape by clicking the mouse and dragging a rectangular outline so that it covers
the entire shape.  When you are done, you should see small black squares around the
perimeter of the shape.

3. From the Library menu click Shape, then Save to library.  Or  click the Save Objects to
Shape Library icon in the Standard toolbar.  The Save to Library dialog box appears.

4. Click the Shape library: box and select the library you wish to store the shape in, (for this
example eggs).

5. Click the Shape No.: pull-down box to select the location (0) to store the shape.  Note that the
State No.: will automatically change to 0, first unused state.

6. Enter a title for the new shape in the Description: box.
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7. Click OK.  The Shape Library dialog box appears with the shape stored in the library.

8. Click Close to return to the main screen of EasyBuilder.

9. From the File menu, click Save to save the shape to the library.  Important- you must save
before attempting to store the next shape.

10. Highlight the other shape by clicking the mouse and dragging a rectangular outline so that it
covers the entire shape.

1010-1001a, Rev 01

160 Sil ver Se ries In stal la tion & Op er a tion Man ual



11. Click the Save Objects to Shape Library icon in the Standard toolbar.  The Save to Library
dialog box appears.

12. Click the Shape library: box and select the library you wish to store the shape in, (for this
example eggs).

13. Click the Shape No.: pull-down box to select the location (0) to store the shape.  Note that the
State No.: will automatically change to state 1, the next available state.

14. Click OK.  The Shape Library dialog box appears with the shape stored in the library under
State 1.

15. Click Close to return to the main screen of EasyBuilder.

16. From the File menu, click Save to save the shape to the library.

� When adding new shapes to existing libraries that come with the EZware-500 software,
remember that any future upgrade that you receive from Maple Systems may overwrite
existing libraries during installation.  This will delete any new shapes that you have
entered!  Therefore, we recommend that you create new libraries to store these shapes
or make backup files of the libraries before installing new upgrades.

�Another method of adding a new shape

1. When a shape is added to the library, the shape is placed at the upper, left-hand corner of the
cell.  In some cases, however, it might be necessary to place the shape in a particular location
within the cell.

2. On the Window Property dialog (from the Option menu, select Window Property), check
the Using Function Key To Make Shape Library checkbox.

3. Create the desired shape.  Create a Function Key.  The area defined by the Function Key will
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be the area that contains the shape.  The mode of the Function Key does not matter.  Do not
assign a shape or a label.  This example shows a shape placed in the center of the library area.

4. Position the objects that compose the new shape inside the function key.

5. Select all objects, including the Function Key.
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6. From the Library menu, click Shape, then Save to Library.  In the dialog box, notice how
the shape is positioned.  The location of the objects inside the Function Key area defines how
the objects will be positioned inside the library.

If you find that some of the shapes included in the libraries are not useful, you have the option of deleting them so
that they may be replaced by another shape.

� To delete a shape from a library

1. From the Library menu, click Shape, then Call up library.

2. Select the library that the shape is located in.

3. Click on the shape that you wish to delete from the library.

4. Click Delete.  The shape is removed from the library.

5. Click Close to go back to the main screen of EasyBuilder.

6. Save the project file to permanently save changes made to the library.  Caution – once project
is saved, the shape is permanently deleted from the library and cannot be replaced.

Finally, you may want to use all or parts of an existing shape to create a new one. To do this, you must first ‘place’
the shape onto the work area of EasyBuilder for editing.

�To place a shape on the work area

1. From the Library menu, click Shape, then Call up library.

2. Select the library that the shape is located in.  For this example, select button1.

3. Click on the shape that you want to place on the work area. For this example, select item 12.

4. Click Place…  The main screen of EasyBuilder reappears with the shape in the upper-left
corner of the work area.

5. For this example, move the shape to the middle of the work area, as shown
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6. Highlight the shape and separate each separate component.

7. As you can see, this particular shape is composed of six objects.  You can edit these objects to
change the shape or create a new shape from these objects.  Please note that you are not
actually changing the shape stored in the library.   To change the shape, you must delete the
shape and store any changes you make to a new shape.
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Using Bitmap Li braries

EasyBuilder includes six bitmap libraries that contain bitmaps you can select from:
• switch1.blb(buttons, lamps)

• bmp1.blb(miscellaneous)

• icons.blb(miscellaneous)

• pipline.blb(pipes)

• pictures.blb(various pictures)

• symbol1.blb(symbols)

�To display the Bitmap Library dialog box

1. From the Library menu, click Bitmap, then click Call up library. Or click the Call up
Bitmap Library icon from the Standard toolbar. The Bitmap Library dialog box appears.
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The Bitmap Library provides several options which are discussed in the following sections.

Accessing and Creating Bitmap Li braries

You can open, close, or even create new bitmap libraries easily using the Bitmap Library dialog box.

� To open other bitmap libraries 

1. With the Bitmap Library dialog box displayed, click Select Lib…  The Open dialog box
appears.

2. Select which library you would like to open, then click Open.  The Bitmap Library dialog
box reappears with the selected library displayed.

If the project has ten libraries open, you may want to close a library so that another one may be opened.

� To close or ‘unattach’ an open bitmap library

1. With the Bitmap Library dialog box displayed, click the pull-down box of Bitmap library:
and choose from one of the open libraries of bitmaps.

2. Select which library you would like to close, then click Unattach Lib.  A dialog box appears
asking if you really want to unattach the selected library.  Click Yes.

3. The Bitmap Library dialog box reappears and the library is removed from the Bitmap
library: list.

You have the option of creating a new library.  This can be very useful when organizing bitmaps.

�To create a new bitmap library

1. With the Bitmap Library dialog box displayed, click New Lib…  The New Library dialog box 
appears.

2. Enter a name for the new library. Click OK.

3. The Bitmap Library dialog box appears with the new library loaded. Click Close.

4. The new library is now available to this project but it is not stored into the Library
subdirectory of EasyBuilder until the project file has been saved.

Cre ating and ex port ing bitmaps

Although EasyBuilder does not provide the ability to create bitmaps, the software can import bitmaps created from
some other application program.  This allows  the ability to use a wide selection of bitmaps that can be permanently
added to your bitmap libraries.  EasyBuilder only accepts bitmaps that are 256 color or less resolution.

� To add a new bitmap to a library

1. Display the Bitmap Library dialog box.

2. Click the Bitmap Library: pull-down box and select one of the bitmap libraries.

3. Click on the box location where you would like to enter the new bitmap.
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4. Click Add Bitmap… The Import Bitmap dialog box displays.

5. The Bitmap No.: is the location of the bitmap in the bitmap file.  This should reflect the box
location that you selected in step 4.

6. Enter a title for the new bitmap in the Bitmap name: box.

7. Enter the total number of states (max. 32) for the bitmap in the Total states: box.

1010-1001a, Rev 01

Creating Graphic Ob jects 167



8. Click Next.  The Get Bitmap Graphics dialog box appears.

9. Click Browse to search for the bitmap. The Open dialog box appears.  Select the bitmap file
and click Open.
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10. The Get Bitmap Graphics dialog box reappears with the bitmap displayed, along with
information about the bitmap.

11. The Transparent checkbox is used to make any color selected on the bitmap ‘transparent’.  If 
the color is configured as transparent, then when the bitmap is placed on a window, all areas
of the bitmap with the transparent color will not be shown.  This is very useful when you
want to overlap several bitmaps, (for example, when configuring a bar graph).  To use the
transparent feature,  click on the bitmap picture in the Get Bitmap Graphics dialog box on the
color that is to be transparent.  The three boxes to the right of the Transparent checkbox will
show the red, green, and blue mixture of the color and the fourth box actually shows the
color.  Then check the Transparent checkbox.

12. If you are creating a multi-state bitmap, then click Next to select the next bitmap picture for
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the other states.  When the last state is completed, then click Finished.  The Bitmap Library
dialog box reappears with the bitmap listed.

13. You have the option of selecting Compressed format for any of the bitmaps in a library.  The
compressed option decreases the size of the bitmap thereby reducing the memory
requirements of the HMI to store that bitmap.  However, because it is compressed, the HMI
will require slightly more processing time to display the bitmap.  Speed is sacrificed for
memory.  We recommend that you do not use the compression option except in cases where
you are reaching the maximum limits of storage capability of the HMI.

14. Click OK to return to Create Bitmap Object.  Click OK again to return to the main screen of
EasyBuilder.  Place the bitmap object somewhere in the work area.

15. From the File menu, click Save to permanently save the bitmap to the library.

� When adding new bitmaps to existing libraries that come with the EZware-500
software, remember that any future upgrade that you receive from Maple Systems may
overwrite existing libraries during installation.  This will delete any new bitmaps that
you have entered!  Therefore, we recommend that you create new libraries to store
these bitmaps or make backup files of the libraries before installing new upgrades.

If you find that some of the bitmaps included in the libraries are not useful, you have the option of deleting them so
that they may be replaced by another bitmap.

�To delete a bitmap from a library

1. From the Library menu, click Bitmap, then Call up library.  The Bitmap Library dialog box 
appears.

2. Select the library that the bitmap is located in.

3. Click on the bitmap that you wish to delete from the library.
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4. Click Delete bitmap.  The bitmap is removed from the library.

5. Click Close to go back to the main screen of EasyBuilder.

6. Save the project file to permanently save changes made to the library.  Caution – once the
project is saved, the bitmap is permanently deleted from the library.

Finally, you may want to export a bitmap located in one of the bitmap libraries so that it can be modified or used in
other programs.

� To export a bitmap

1. From the Library menu, click Bitmap, then Call up library.  The Bitmap Library dialog box 
appears.

2. Select the library that the bitmap is located in.

3. Click on the shape that you want to export.

4. Click Export…  The Save As dialog box appears.

5. In the File name: box, enter a file name to store the bitmap in.

6. Click Save. The bitmap is saved and the Bitmap Library reappears.

7. Click Cancel to exit the Bitmap Library and Cancel again to exit the Create Bitmap Object
dialog box.

Using Group Li braries

Any graphics object or objects displayed on the work area of EasyBuilder can be grouped together and stored into a
group library.  Graphics objects can be passive or active.  The groups that you create can be permanently stored into
the group libraries for access by any project.  Creating group objects often saves a lot of time when creating new
projects because you can use the same objects repeatedly.  For example, suppose you regularly use a scale meter
similar to the following:
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This one scale meter is actually composed of ten objects.

Rather than waste time recreating this scale meter for each new application, it would be much easier to store the
meter into a group library.

EasyBuilder includes one group library (keypad.glb) that contains sample keypads you can select from.

When a new project is started, the keypad group library is automatically open.

�To display the Group Library dialog box

1. From the Library menu, click Group, then click Call up library. Or click the Call up
Group Library icon from the Standard toolbar. The Group Library dialog box appears.
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Let’s look at the Group Library dialog box:

The Group Library provides several options which are discussed in the following sections.

Accessing and Creating Group Libraries

Group libraries can be  opened and closed easily using the Group Library dialog box.  It is even possible to create
new group libraries.

�To open other group libraries 

1. With the Group Library dialog box displayed, click Select Lib…  The Open dialog box
appears.

2. Select which library you would like to open, then click Open.  The Group Library dialog box
reappears with the selected library displayed.

If the project has ten libraries open, you may want to close a library so that another one may be opened.

� To close or ‘unattach’ an open group library

1. With the Group Library dialog box displayed, click the pull-down box of Library Name: and 
choose from one of the open libraries of groups.

2. Select which library you would like to close, then click Unattach Lib.  A dialog box appears
asking if you really want to unattach the selected library.  Click Yes.

3. The Group Library dialog box reappears and the library is removed from the Group library:
list.

The option of creating a new library is also available.  This can be very useful when organizing groups.

�To create a new group library 

1. With the Group Library dialog box displayed, click New Lib…  The New Library dialog box
appears.

2. Enter a name for the new library. Click OK.
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3. The Group Library dialog box appears with the new library loaded. Click Close.

4. The new library is now available to this project but it is not stored into the Library
subdirectory of EasyBuilder until the project file has been saved.

Cre at ing, de let ing and plac ing groups

Once a complex group object has been created, it must be stored  permanently into a group library where it can be
retrieved and used in multiple projects.  At any time, it is possible to place a group object onto the work area of
EasyBuilder for usage or editing.

�To add a new group to a library

1. Highlight the group object by clicking the mouse and dragging a rectangular outline so that it
covers the entire group.  When you are done, you should see small black squares around the
perimeter of the group.  For this example, the scale meter shown at the beginning of this
section is highlighted.

2. From the Library menu click Group, then Save to library.  Or  click the Save to Group
Library icon in the Standard toolbar.  The Save to Library dialog box appears.

3. Click the Group library: box and select the library you wish to store the group in, (for this
example meters).

4. Click the Group No.: pull-down box to select the location (0) to store the group.  Note that
the Group No.: will automatically change to 0, (first group not used).

5. Enter a title for the new group in the Description: box, (ex. Scale1).
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6. Click OK.  The Group Library dialog box appears with the group stored in the library.

7. Notice that any shape or bitmap libraries used to create the group object are listed for your
reference in the Including library box.

8. Click Close to return to the main screen of EasyBuilder.

9. From the File menu, click Save to permanently save the group to the library.

� When adding new group objects to existing group libraries that come with the
EZware-500 software, remember that any future upgrade that you receive from Maple
Systems may overwrite existing libraries during installation.  This will delete any new
group objects that you have entered!  Therefore, we recommend that you create new
libraries to store these group objects or make backup files of the libraries before
installing new upgrades.

If you find that some of the groups included in the libraries are not useful, you have the option of deleting them so
that they may be replaced by another group.

� To delete a group from a library

1. From the Library menu, click Group, then Call up library.

2. Select the library that the group is located in.

3. Click on the group that you wish to delete from the library.

4. Click Delete.  The group is removed from the library.

5. Click Close to go back to the main screen of EasyBuilder.

6. Save the project file to permanently save changes made to the library.  Caution – once a
project is saved, the group is permanently deleted from the library and cannot be replaced.

Finally, to place a group object onto the work area for use or editing, do the following.

� To place a group on the work area

1. From the Library menu, click Group, then Call up library.

2. Select the library that the group is located in.  For this example, select keypad.

3. Click on the group that you want to place on the work area. For this example, select item 0.
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4. Click Place…  The main screen of EasyBuilder reappears with the group in the upper-left
corner of the work area.

5. Move the group object to the preferred location on the window.

This completes our discussion on creating shapes, bitmaps, and group objects with EasyBuilder.  This chapter also
provided some examples on how to use the drawing tools.  The next several chapters describe the many parts or
active graphics objects that can be placed onto windows.
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